Author Topic: Can't register my free Avast 5  (Read 26644 times)

0 Members and 1 Guest are viewing this topic.

Online DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 89343
  • No support PMs thanks
Re: Can't register my free Avast 5
« Reply #15 on: February 10, 2010, 06:29:10 PM »
I have the same problem as well: When I press the 'Register for free licence' button, nothing happens!  :(

The offline registering doesn't work either.

I don't know if this may just be heavy load on the registration server, as you can imagine with the release of the new program there will be a huge amount of activity.
« Last Edit: February 10, 2010, 06:31:14 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.5.6116 (build 24.5.9153.762) UI 1.0.808/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security


  • Guest
Re: Can't register my free Avast 5
« Reply #16 on: February 10, 2010, 11:28:17 PM »
UPDATE: I just tried it again and it was successful. Looks like they fixed it.

I hope so, its on two of my customers comps that it failed to register on and im not sure if i can get hold of either of them soon (wish i hadn`t been so hasty to get all the people that use my advice & recommendations to upgrade to Avast 5 !!  should have waited for a little longer really , never mind, were all human, :P

I do like the new interface though, good stuff Alwil :D (and the registration process will be much better than the old method when its working PROPERLY !)

Cheers all.


  • Guest
Re: Can't register my free Avast 5
« Reply #17 on: February 11, 2010, 12:11:26 AM »
JhonDoe good to see You got yours straightened out mate. I was thinking it was a once off this problem registering this product of theirs I just didn't count on any problems since a lot of comparisons done had rated Avast damn nye the best of all free version antivirus programs so one thought it would go along a lot easier. I've been running it for a couple weeks now so quite happy with it. Now I watch with interest with this new build 5.0.415.
Have yerself agood one


  • Guest
Re: Can't register my free Avast 5
« Reply #18 on: February 11, 2010, 06:24:41 AM »
so are you saying that if you fill out the online reg form that the sent code will work even though its meant for Avast 4.x ? hope so but no harm in trying.
I used the page listed above by Rednose, which was
It worked fine.   I don't know that it's meant for the old 4.x registration like that page you listed though, because it has the new look (with that funky 4 legged orange thing that version 5 is sporting now).   Whatever it's meant for, yeah, that one worked finally last night.   Like I said, took an hour and a half to get the email, but it worked when it finally came through.   I'm guessing either they had a server down or possibly the registration servers are just getting hammered by everyone switching over to version 5 all at the same time.   Who knows though?

Overall though, now that it's registered, I like it.   My main complaint before was that the GUI wasn't real noobie friendly with just the icons and nothing really written out to go off of, and people I'd recommend it to would seem to have the same first question...."How do I scan with this thing?!".   Looks like that's solved with version 5 though.   Nice layout.   Yeah, I'll miss my skins that 4.8 had, but I'll get used to it.   So far seems like a good upgrade.    Nice job to all the folks at Alwil.  ;)
« Last Edit: February 11, 2010, 06:30:35 AM by Juppy »

Chief Suspect

  • Guest
Re: Can't register my free Avast 5
« Reply #19 on: February 11, 2010, 09:06:10 AM »

I've got 18 days to register my Avast 5 (free) remaining.
I like what I've seen so far with this Free Antivirus so been trying to register it and I can't.

Likewise .. I've got 18 days remaining from my initial install of Avast 5 Free.  On the Maintenance/Registration
Page I get the cryptic notification that my registration will expire in 18 days, but I see NO place to enter a new
key for the FREE Avast 5.  There is a place to enter a PAID *.avastlic key, but nothing apparent for entering
for the FREE Avast 5.  Am I supposed to just wait until I am notified somehow?  Will I be notified in time before

I've got a BAD feeling about Avast 5.  Been reading post after post of headaches and miserable failures. 
We'll see what happens before 18 days are up, but I have AVG on hand .. and it looks like AVAST5 is going to
be a bad word in the world.  Too bad.  I had been using AVAST 4.8 successfully for a long time.


  • Guest
Re: Can't register my free Avast 5
« Reply #20 on: February 11, 2010, 04:02:43 PM »
Chief Suspect
Read closer as my reply #10 on the first page on this thread and you'll see how I got it sorted.
An I'm very pleased with avast 5.


  • Guest
Re: Can't register my free Avast 5
« Reply #21 on: February 24, 2010, 01:20:03 AM »
I don't see any reason to leave this thread. First off, I'm not to installations, registering, etc. I can read a screen. I've been running Avast for a while. Recently upgraded to Avast 5. Newest version off the web. My update worked flawlessly, however I need to re-register my wife's computer.

When I click on the register area where it says I need to re-register, it comes up with the registration screen. ANY button I click on and the program window lightens a shade and that's it... the Avast program is locked (I've left it up once for two hours with no change in the program).

Rebooted several times. Tried (and failed) to re-register several times. Oh, I'm sorry, there is a button that does work as long as the program is restarted and that is the Registration Form button. I DO have a key.

Problem is that I cannot open the Insert The License Key button. Let me reiterate... ANY button other than the "Registration Form" button just  makes the Avast! User Interface lighten and program is no longer responsive.

James :(

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Can't register my free Avast 5
« Reply #22 on: February 24, 2010, 03:04:03 AM »
pirahnya, are you logged as an administrator?
Any other antivirus installed?
Did you use the trial period?
The best things in life are free.


  • Guest
Re: Can't register my free Avast 5
« Reply #23 on: March 01, 2010, 09:04:06 PM »
I'm in the same boat as pirahnya.
I had 4.8 installed on my brother's computer. Upgraded to 5. Had issues with registering, but figured I'd deal with it later.
The trial period expired today, tried all four buttons (Registster now, Insert avast! Pro..., Registration form, Insert the license key) and only the "avast! Pro" button did anything but lock up the interface, and all it did was open a web page with an option to buy the program. I had to use task manager to kill the UI task, tried rebooting a few times. No dice.

I uninstalled avast 5, rebooted, reinstalled avast. I have a fresh 30 day trial period, but I am still unable to register the product. The behavior is the same. I DO see some window flash up and immediately disappear, but it's too fast for my eyes. I suspect (as a developer) that it is a modal window that is behind the avast UI window and won't let me click in it...

Testing... I can hit "ESC" and the avast UI becomes active again.

NEWS! Oh my, I got it to work... Avast, this is a bug.
The registration window comes up NOT VISIBLE! If this isn't a bug, then there is some malware out there hiding your registration windows...

I have a registration key that was emailed to me offline, which I copied to my clipboard. I clicked "Insert the license key" and the interface ghosted a little. Without a visible registration window, I hit Ctrl-V to paste the license key, hit TAB to move to the "OK" button, and hit the space bar. It registered!

Also, before that, I tried to register and found that clicking around the window resulted in things like a drop down list for countries appearing apparently out of nowhere.
« Last Edit: March 01, 2010, 09:07:05 PM by scrib »


  • Guest
Re: Can't register my free Avast 5
« Reply #24 on: February 21, 2011, 11:23:17 PM »
Had problem registering with the in program registration. Retrieving info would pop up then disappear. Then noticed that date and time was set wrong on the computer. Corrected that and it worked.