Author Topic: Firewall Change Profile Pop Up In Avast 5 Internet Security  (Read 11214 times)

0 Members and 1 Guest are viewing this topic.

Golfjunky

  • Guest
Firewall Change Profile Pop Up In Avast 5 Internet Security
« on: February 10, 2010, 09:43:44 AM »
I'm using the trial version of Avast 5 IS. Is anyone else experiencing this.

Every time I do a startup or re-start, I get a Firewall Change Profile pop up. It tells me that it detected a new network, and has changed the profile to Work/Medium Risk Zone. That is the profile I set it to when I first installed AIS. It's driving me crazy. Why do I keep getting this pop up, and how do I stop it?

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37191
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #1 on: February 10, 2010, 12:12:38 PM »
jepp, same thing here

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9404
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #2 on: February 10, 2010, 12:14:18 PM »
Yeah, it's quite annoying.
Visit my webpage Angry Sheep Blog

Hermite15

  • Guest
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #3 on: February 10, 2010, 12:30:55 PM »
agreed, that's really annoying; I posted about this already a while ago and Lukor replied saying that he thought after all it would be more secure to have the pop up each time, referring to mobile devices, and there would be later an option to deactivate that; he asked me if that was a good compromise...don't know why I said OK but realized almost immediately this was no solution, because deactivating it could lead to having no info about new detected networks however it happens, even at home...not mentioning that if you forget to turn it back on (the notification) you'll get surprises in public places, if you don't want to connect for instance.
 Best behavior is how it works with most other firewalls, one notification each time a new network is detected, and never again, unless you've switched to another one in the meantime, and come back to one you already used. So as far as I'm concerned, the recurring pop up each time you reboot is a bug, and there shouldn't be an option for that, it just shouldn't happen.

Offline Rednose

  • Pirate Party Member
  • Avast √úberevangelist
  • Massive Poster
  • *****
  • Posts: 3737
  • Bits of Freedom : https://www.bof.nl
    • Nederlandstalig Avast! forum
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #4 on: February 10, 2010, 12:54:17 PM »
I agree :)

Greetz, Red.
OS: Win 10 / iOS 15 / Debian 11 / Tails 4
Real Time: Avast Premium Security
On Demand: Malwarebytes
VPN: NordVPN ( NordLynx ) with CyberSec

coaster

  • Guest
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #5 on: February 10, 2010, 01:33:01 PM »
Yes the same for me. I also noticed that the firewall creates rules only for .exe files. I have an application webshots.scr that  access the net and I had to manually create the rule to make the permission popup disappear (avast firewall doesn't remember my answer even if "remember my answer"  was flagged.

Golfjunky

  • Guest
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #6 on: February 10, 2010, 07:06:27 PM »
Thanks everyone.  At least now I know it's not just me.  It is annoying, and at this time I'm not sure if I will continue using AIS, or go back to using Avast free and a separate firewall.  Something for me to think about.  :-\

Hermite15

  • Guest
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #7 on: February 10, 2010, 07:11:37 PM »
check in rules.xml if your rule wasn't remembered there, even if it doesn't appear in the UI (the file is in program data in the alwil folder)

krgoodwin

  • Guest
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #8 on: February 12, 2010, 01:12:35 PM »
Well I am lost on this thread and the associated problem.  Everytime I turn on my computer, I get a Firewall Profile Change. What has changed?  Nothing. Why isn't selecting the Work/Medium Risk Zone remembered from the installation and this continuous pop-up disabled?

Golfjunky

  • Guest
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #9 on: February 13, 2010, 09:54:37 AM »
Well I am lost on this thread and the associated problem.  Everytime I turn on my computer, I get a Firewall Profile Change. What has changed?  Nothing. Why isn't selecting the Work/Medium Risk Zone remembered from the installation and this continuous pop-up disabled?


As Logos said, it's a bug.   This should be taken notice by the Avast team and fixed. It's very annoying.  I was planning on purchasing AIS 5 as soon as the trial was up, but now, I think I will just go back to using Avast 5 free.  Shame, I really like AIS except for the zone pop ups.

Offline Rednose

  • Pirate Party Member
  • Avast √úberevangelist
  • Massive Poster
  • *****
  • Posts: 3737
  • Bits of Freedom : https://www.bof.nl
    • Nederlandstalig Avast! forum
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #10 on: February 13, 2010, 10:23:59 AM »
Well, Lukas is in Thailand now, so we will have to wait untill he is back I am afraid ;)

Greetz, Red.

OS: Win 10 / iOS 15 / Debian 11 / Tails 4
Real Time: Avast Premium Security
On Demand: Malwarebytes
VPN: NordVPN ( NordLynx ) with CyberSec

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #11 on: February 13, 2010, 11:22:43 AM »
For desktop use, you can just disable the Automatic profile switching (which is not very useful anyway if you don't change networks). Firewall -> Expert settings -> Network profiles page.

This assumes you're running the latest version (5.0.418).

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Golfjunky

  • Guest
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #12 on: February 15, 2010, 09:27:46 AM »
For desktop use, you can just disable the Automatic profile switching (which is not very useful anyway if you don't change networks). Firewall -> Expert settings -> Network profiles page.

This assumes you're running the latest version (5.0.418).

Thanks
Vlk


Hello Vlk.   I tried disabling automatic profile switching before, but for some reason it didn't work.  I uninstalled AIS a couple of days ago, and then saw your suggestion here today.  So I decided to give it one more try. I reinstalled AIS, and disabled automatic profile switching. This time it worked. No more pop ups at startups. ;D   I don't know why it didn't work the first time, but I'm just happy it worked this time.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #13 on: February 15, 2010, 09:31:58 AM »
Hello Vlk.   I tried disabling automatic profile switching before, but for some reason it didn't work.  I uninstalled AIS a couple of days ago, and then saw your suggestion here today.  So I decided to give it one more try. I reinstalled AIS, and disabled automatic profile switching. This time it worked. No more pop ups at startups. ;D   I don't know why it didn't work the first time, but I'm just happy it worked this time.

That's why I said "This assumes you're running the latest version (5.0.418)" ;). In the previous versions, there was a bug that prevented this feature from working correctly.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Golfjunky

  • Guest
Re: Firewall Change Profile Pop Up In Avast 5 Internet Security
« Reply #14 on: February 15, 2010, 09:39:43 AM »
Hello Vlk.   I tried disabling automatic profile switching before, but for some reason it didn't work.  I uninstalled AIS a couple of days ago, and then saw your suggestion here today.  So I decided to give it one more try. I reinstalled AIS, and disabled automatic profile switching. This time it worked. No more pop ups at startups. ;D   I don't know why it didn't work the first time, but I'm just happy it worked this time.

That's why I said "This assumes you're running the latest version (5.0.418)" ;). In the previous versions, there was a bug that prevented this feature from working correctly.

Thanks
Vlk

Ahh.  I was running the previous version.  After reading your post, I installed the latest version from the Avast web site.  Thanks for the help Vlk.   :)