Author Topic: Avast! files conflict with System Restore  (Read 4038 times)

0 Members and 1 Guest are viewing this topic.

Offline teedoff087

  • Newbie
  • *
  • Posts: 15
  • Wagga-Wagga!!
Avast! files conflict with System Restore
« on: June 27, 2004, 04:29:41 AM »
I don't know why this would ever happen, but for some reason two .dll's in the WINDOWS\System32 directory on my hard disk called aswCmnOS.dll and aswCmnB.dll made me panic when they gave an error for System Restore. When the two files are stored in the System32 directory, I open System Restore and an error occurs. It loads System Restore with a blank screen. Can anyone else confirm this? I have the latest version of Avast Professional (4.1.418) and VPS version 0426-1 (if it really matters). I am running XP Home. When I removed them from that directory, System Restore worked fine.
« Last Edit: June 27, 2004, 08:22:14 AM by teedoff087 »

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31311
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:Avast! files conflict with System Restore
« Reply #1 on: June 27, 2004, 04:41:12 AM »
I never saw this before, but I'm sure one of the other members will jump into it soon. In the mean time, check your systems log files for error and try to solve them. That may help/solve it. If not, ah well it won't hurt to do so either  ;D

Offline bob3160

  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 45149
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re:Avast! files conflict with System Restore
« Reply #2 on: June 27, 2004, 04:49:02 AM »
teedoff087
Amazing, same operating system and same avast!

Only one problem, the two files you mentiond, are not in my Windows\System32 Folder.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v20H2 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline teedoff087

  • Newbie
  • *
  • Posts: 15
  • Wagga-Wagga!!
Re:Avast! files conflict with System Restore
« Reply #3 on: June 27, 2004, 04:56:53 AM »
Do you mean you have the same problem and they aren't in the same directory or are you just amazed that we have the same avast! version?
« Last Edit: June 27, 2004, 08:23:04 AM by teedoff087 »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Avast! files conflict with System Restore
« Reply #4 on: June 27, 2004, 10:20:56 AM »
I wonder how these files got to your Windows\System32. They should not (in fact they MUST NOT) be there...

Can you post the file <avast>\setup\setup.log? (rename it to .txt first to be able to post to the forum).

Thx.
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline bob3160

  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 45149
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re:Avast! files conflict with System Restore
« Reply #5 on: June 27, 2004, 01:34:07 PM »
teedoff087
No, I was amazed at the fact that those files where in your windows\system32 Folder because as VLK stated, they don't belong there and that's why you're having the problems you do.
I'm sure VLK will have you smiling again soon. :)
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v20H2 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline teedoff087

  • Newbie
  • *
  • Posts: 15
  • Wagga-Wagga!!
Re:Avast! files conflict with System Restore
« Reply #6 on: June 28, 2004, 04:42:33 AM »
I have already removed those files from the system32 directory and System Restore works fine. I looked in setup.log and there was no mention of those two files being placed in the system32 directory. If it still helps, the file is attached.

EDIT: Also, something to note, the versions were different on the ones placed in the system32 directory. The versions of the ones in the program directory and the ones in the system32 directory are as follows:
system32: aswCmnB.dll - 4.1.259.0
                 aswCmnOS.dll - 4.0.211.0
Avast4: aswCmnB.dll - 4.1.389.0
             aswCmnOS.dll - 4.1.415.0
« Last Edit: June 28, 2004, 06:01:03 AM by teedoff087 »