Author Topic: puppylinux431  (Read 5027 times)

0 Members and 1 Guest are viewing this topic.

pupuser431

  • Guest
puppylinux431
« on: April 16, 2010, 08:54:47 AM »
any one using puppylinux and avast?
seems like im having the same probs as other linux distro users.
updateing the virus defs makes the avast non-startable...(400.vps=36mb)
is the a fix-igive it one week if no fix i will use another av-clam/fprot.
any help/advice would be nice...linux kernal= 2.6.30.5(i686)

Mike Buxton

  • Guest
Re: puppylinux431
« Reply #1 on: April 16, 2010, 10:10:17 AM »
Hi,

Please see the first sticky (with some 25 posts) at the very top of the page.

There are also two similar threads a little below below this one of yours.

Cheers

pupuser431

  • Guest
Re: puppylinux431
« Reply #2 on: April 16, 2010, 10:35:32 AM »
i know the are other posts about this-BUT i use puppy not whobuntu.
so they are not specific- to pup431...
this is why i posted a new thread-hopeing to find pup or slax users.
but tx all the same.

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: puppylinux431
« Reply #3 on: April 16, 2010, 11:14:59 AM »
i know the are other posts about this-BUT i use puppy not whobuntu.
so they are not specific- to pup431...
this is why i posted a new thread-hopeing to find pup or slax users.
but tx all the same.

modifying rcS in /etc/init.d using

/sbin/sysctl -w kernel/shmmax=200000000

somewhere near the beginning of the file would work on most distribution (assuming they aren't heavily customised/don't use non-standard init).
regards,
pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)

pupuser431

  • Guest
Re: puppylinux431
« Reply #4 on: April 16, 2010, 11:46:49 AM »
ahoy, thanks for the info-im waiting for one of the "gurus" to wake up at murga-linux.com forum(puppylinux forum)
or some one over at irc freenode #puppylinux befor i try to work this out...
i put the puppy relavant info in here for other puppy users benafit..
will return +post results of of this "fix" if it works...he he :D
thanks again 10/10

pupusse

  • Guest
Re: puppylinux431
« Reply #5 on: April 16, 2010, 03:19:40 PM »
quite easy for those who are " afraid"  ??? to modify an .ini script :

if you want to launch avast for the first time in your session :
  type as root : "sysctl -w kernel.shmmax=128000000 ; avastgui "

If you want to launch avast again (in the same session)  just type "avastgui".


 :)

But the moderator is right , the best way is to modify the init script.

pupuser431

  • Guest
Re: puppylinux431
« Reply #6 on: April 18, 2010, 06:46:29 PM »
all's well.
adding the line in the .ini worked like a treat.
update went well no problems there either.
only thing i did see was a slower start time before the GUI showed.
this is maybe because the 400.vps is 36mb(my original 20mb.)
i also lowered the value to 128M from 200M-seemed to speed start up a little,
will try with 64M see how that goes...
would like to say thanks to all for the help+understanding-10/10.
good learning curve for me,
live long+prosper.