Author Topic: Avast not deleting all virus: only one at the time...  (Read 4519 times)

0 Members and 1 Guest are viewing this topic.

Offline big_gie

  • Jr. Member
  • **
  • Posts: 49
Avast not deleting all virus: only one at the time...
« on: July 17, 2004, 08:31:16 PM »
Hi,

try to scan this file:
*link removed*

When using the mouse context menu's scan, avast detect ONE virus in ONE file. I delete it, and the file shrink in size. But if I run the scan again, avast detects another virus, delete it, but keep all the others...

Whats wrong??
« Last Edit: July 17, 2004, 08:55:42 PM by igor »

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11808
    • AVAST Software
Re:Avast not deleting all virus: only one at the time...
« Reply #1 on: July 17, 2004, 08:54:28 PM »
Check the program settings, in particular the page "Common".
There is a setting for the Explorer Extension that it should quit after the first virus is found. Is it checked?

Offline big_gie

  • Jr. Member
  • **
  • Posts: 49
Re:Avast not deleting all virus: only one at the time...
« Reply #2 on: July 17, 2004, 10:39:37 PM »
This checkbox is uncheck.

I'm checking it, with the "show report" also.

Result:
Even with the checkbox checked, it did the same!!!

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11808
    • AVAST Software
Re:Avast not deleting all virus: only one at the time...
« Reply #3 on: July 17, 2004, 10:56:09 PM »
Well, the checkbox shouldn't be checked (otherwise, it should quit after the first virus).
I will check the code on Monday to see if there's anything wrong there.

Offline big_gie

  • Jr. Member
  • **
  • Posts: 49
Re:Avast not deleting all virus: only one at the time...
« Reply #4 on: July 17, 2004, 11:13:28 PM »
thanx :)

I'll try on another computer to see...

Doing the same thing with the other computer. The checkbox doesn't seems to do a thing...:/

Using avast pro 4.1 Jun2004 (4.1.418) awith virus database v0429-2  (16.07.2004)

Offline big_gie

  • Jr. Member
  • **
  • Posts: 49
Re:Avast not deleting all virus: only one at the time...
« Reply #5 on: July 17, 2004, 11:19:16 PM »
Also their was 15 virus not found in the file:
646.exe
1226b-dr.exe
4907.exe
balooch.exe
config12.exe
courier.exe
cvirus.2.1.exe
cvirus.exe
dvir1701.exe
fattable.exe
hllo.cvirus_1.9.exe
hllo.cvirus_2.0.exe
rpart_c.exe
run.exe
voodoo.exe

Shouldn't those virus be detected?  ???

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31301
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:Avast not deleting all virus: only one at the time...
« Reply #6 on: July 17, 2004, 11:53:08 PM »
I tested it here also. Indeed only 1 file is removed at a time. The window closes after that. It doesn't matter if the explorer extensions are enabled or not, the behaviour is the same. But one thing is different. Avast pickedup everything as virus except for the following files:
1226b-dr.exe
4907.exe
balooch.exe
config12.exe
courier.exe
dvir1701.exe
rpart_c.exe
run.exe

I think big_gie is using a old vps. I used Avast pro (4.1.418) with vps 429-2

Offline big_gie

  • Jr. Member
  • **
  • Posts: 49
Re:Avast not deleting all virus: only one at the time...
« Reply #7 on: July 17, 2004, 11:57:02 PM »
I think big_gie is using a old vps. I used Avast pro (4.1.418) with vps 429-2
As I posted just above, I'm using the same vps as you...

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31301
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:Avast not deleting all virus: only one at the time...
« Reply #8 on: July 18, 2004, 12:13:35 AM »
Strange since only the files I mentioned in my previous respond, are not detected as infected by Avast. Online scan of the files at RAV detected the following:

1226b-dr.exe < Phoenix.1266.dr
run.exe < Trojan:Loader.TCS

the others where reported as clean.