Author Topic: not detecting all viruses  (Read 2824 times)

0 Members and 1 Guest are viewing this topic.

Offline R_John

  • Newbie
  • *
  • Posts: 2
not detecting all viruses
« on: July 25, 2004, 11:30:18 AM »
I'm running Avast on my home machine with other stuff like ZoneAlarm also installed.  I was satisfied until I went to try to clean up my mom's computer - Avast failed to identify multiple problems including msblast.exe, skynetave.exe, and the very incidious avserve2.exe.  I only found these using HijackThis! - so what is the deal - why doesn't Avast find these files???????????

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31302
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:not detecting all viruses
« Reply #1 on: July 25, 2004, 11:40:37 AM »
Avast detects the blaster and sasser worm without problems, also the bored/guru infection is detected by Avast without problems. So why it doesn't on your moms comp (which should have been patched in the first place a long time ago!) is a little riddle we have to solve.

Both with blaster and sasser there was a patch released prior to the release of the worm, so if a system still gets infected it is the users own fault imo.

Hijackt this doesn't find any virus, spyware, adware, malware. It just displays a list of items from which YOU have to find out what they are and what should be kept/removed.

Some infections disable the AV software. Not saying this happened here, but it could be.

Please answer the following questions, lets see if we can find out what went wrong.
1) What version of Avast?
2) What version of the vps?
3) What os?
4) What settings of Avast?

In the mean time I suggest you click on the link in my signature and follow the instructions on that page to clean the system.

Offline R_John

  • Newbie
  • *
  • Posts: 2
Re:not detecting all viruses
« Reply #2 on: July 26, 2004, 09:00:27 AM »
Thanks Artras for the info and here is some info that might help - the virus(es) were totally disabling many of the features that would allow me to detect the virus.  ZoneAlarm would not execute when installed, Windows Task Manager would close when launched, and I had some doubts about Avast being able to update properly.  This machine was running Windows XP with the very most recent Avast version and virus file from 7/23/04.  I basically had to launch the computer in Safe Mode and do some detective work.  Avast DID catch a large number of the viruses present initially, but several including the avserve2.exe, msblast.exe, and smsc.exe where not discovered.  There were a few others as well that I cannot remember off hand.  Anyway, I finally got the machine cleaned and updated.  


Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31302
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:not detecting all viruses
« Reply #3 on: July 26, 2004, 12:26:23 PM »
See what you can do with a little help of a friend  ;D

Now keep it up to date ! At least check for patches/updates once a week at http://windowsupdate.microsoft.com