Author Topic: Your Email Client Has SSL Connection - Disable it.  (Read 4050 times)

0 Members and 1 Guest are viewing this topic.

Offline Canopus

  • Jr. Member
  • **
  • Posts: 23
Your Email Client Has SSL Connection - Disable it.
« on: November 23, 2010, 12:47:13 AM »
Argh! How do I stop this notification.  It's telling me that Avast has detected that an email account it has detected in MailWasher uses an SSL connection and it cannot check it so change the connection so it can check it as Avast will give all the protection necessary.  Well my server requires it and whenever I try to change it to non SSL then Mailwasher can't send spam reports to SpamCop through that mail server.  It is not doing this with my actual mail client, just mail washer.  Is there no way to stop this annoying notification that I have never had with previous versions of Avast. It's getting to the point where I am seriously thinking of uninstalling Avast and using something else. :-\

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86949
  • No support PMs thanks
Re: Your Email Client Has SSL Connection - Disable it.
« Reply #1 on: November 23, 2010, 01:02:38 AM »
- avast's Mail Shield would scan the email traffic to MailWasher (previous versions of avast couldn't handle SSL so didn't check it):
- Personally as a mailwasher pro user I have avast IgnoreProcess for mailwasher.exe. Since MailWasher doesn't download the complete email to do its analysis, it only downloads the headers, a small part of the body, it doesn't download images or attachments and it views what is downloaded in text only. Based on this I personally don't feel that any negligible risk worth scanning duplication, but the choice is yours.

By editing the EmailShield.ini file, [MailScanner] section using notepad. C:\Documents and Settings\All Users\Application Data\Alwil Software\Avast5\EmailShield.ini

[MailScanner]
IgnoreProcess=MailWasher.exe add this line if you don't already have an IgnoreProcess line.

Save the changes to EmailShield.ini and exit, the avast self-defence module will ask are you sure about the changes, etc. answer Yes.

The above file location is for XP so you might need to find it on Vista, etc.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.9.6034 (build 22.9.7554.734) UI 1.0.728/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Canopus

  • Jr. Member
  • **
  • Posts: 23
Re: Your Email Client Has SSL Connection - Disable it.
« Reply #2 on: November 23, 2010, 01:18:48 AM »
Ahhh, thanks David. I kept trying to figure how to ignore mailwasher.exe and never thought of the ini file.  Maybe some peace at last :)

Oh, and as a pluss I just noticed that MailWasher seems to be now working quicker :)
« Last Edit: November 23, 2010, 01:23:34 AM by Canopus »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86949
  • No support PMs thanks
Re: Your Email Client Has SSL Connection - Disable it.
« Reply #3 on: November 23, 2010, 03:05:52 AM »
You're welcome.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.9.6034 (build 22.9.7554.734) UI 1.0.728/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Canopus

  • Jr. Member
  • **
  • Posts: 23
Re: Your Email Client Has SSL Connection - Disable it.
« Reply #4 on: April 08, 2011, 12:37:42 AM »
This is odd, the issue has come back again. Just checked and EmailShield.ini still has the entry IgnoreProcess=MailWasher.exe in it, yet, it is once again trying to scan MailWasher and coming up with the secure connection not needed error.  :(

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86949
  • No support PMs thanks
Re: Your Email Client Has SSL Connection - Disable it.
« Reply #5 on: April 08, 2011, 01:11:31 AM »
If you have the latest version of MailWasher (2011 1.0.67 then the executable has changed, it is now MailWasherPro.exe or MailWasherProApp.exe, I think the latter is the correct one though.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.9.6034 (build 22.9.7554.734) UI 1.0.728/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Canopus

  • Jr. Member
  • **
  • Posts: 23
Re: Your Email Client Has SSL Connection - Disable it.
« Reply #6 on: April 08, 2011, 11:53:57 AM »
I still have 5.3.0.1 which is MailWasher.exe.  When I first got MailWasher it was still in development stage and bought the Pro version when it came out. The agreement was that all paid for versions would have lifetime upgrades which Firetrust honoured up to the latest version as it was terms of sale to them. When they broke the agreement I refused to pay for an upgrade as it worked perfectly and I didn't need any extra bells and whistles :)

Could perhaps the position of the entry on the file affect Avast from reading it now and again?  At present it is the last of the entries in the file.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86949
  • No support PMs thanks
Re: Your Email Client Has SSL Connection - Disable it.
« Reply #7 on: April 08, 2011, 04:10:38 PM »
Being the last entry in the file is incorrect as it isn't between the [MailScanner] section heading and the next section heading, [Common].
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.9.6034 (build 22.9.7554.734) UI 1.0.728/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Canopus

  • Jr. Member
  • **
  • Posts: 23
Re: Your Email Client Has SSL Connection - Disable it.
« Reply #8 on: April 08, 2011, 08:04:54 PM »
Thanks, inserted it into the right location.  Seemed it worked most of the time in wrong location, but, was beginning to ignore it.  Peace of mind again  :)

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86949
  • No support PMs thanks
Re: Your Email Client Has SSL Connection - Disable it.
« Reply #9 on: April 08, 2011, 08:17:11 PM »
You're welcome.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.9.6034 (build 22.9.7554.734) UI 1.0.728/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security