Author Topic: Win 7 Pro only view HTTPS sites  (Read 2637 times)

0 Members and 1 Guest are viewing this topic.

Tokyo Jim

  • Guest
Win 7 Pro only view HTTPS sites
« on: February 03, 2011, 02:10:14 AM »
Here is the situation, I have 2 machines running Windows 7 Pro. I've run Avast on them for quite sometime now and everything worked fine until the morning of Jan 28th 2011. I could not go to any websites that were not secure sites. HTTPS/yes HTTP/no. I tried everything in the book and the only thing that fixed my problem was disableing Avast. Is this a known issue? I didn't see anything in these forums about it. Anyone else having this problem? It must have been an update.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 88132
  • No support PMs thanks
Re: Win 7 Pro only view HTTPS sites
« Reply #1 on: February 03, 2011, 02:28:22 AM »
What version of avast free/pro/ais and what build version (5.1.889, etc.) ?

What is everything in the book, so we don't repeat what you tried ?

Have you recently updated the program ?

What is your firewall ?
Don't disable avast, as that leaves you completely unprotected, start by disabling the web shield and see if that works.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Tokyo Jim

  • Guest
Re: Win 7 Pro only view HTTPS sites
« Reply #2 on: February 03, 2011, 03:53:48 AM »
Free/5.1.889, The Book = resetting winsoc/tcp, turning off windows firewall, restore points, tried using firefox.
« Last Edit: February 03, 2011, 03:57:01 AM by Tokyo Jim »

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 88132
  • No support PMs thanks
Re: Win 7 Pro only view HTTPS sites
« Reply #3 on: February 03, 2011, 04:44:10 AM »
Well, the Windows firewall doesn't have outbound protection enabled by default, so unless you enabled it, that shouldn't be the problem.

Whilst resetting the winsock/tcp is a good idea I'm not sure that would have been the problem if it were I wouldn't have expected you to be able to connect to https sites either if it were corrupt/broken.

Are you using any sort of proxy to connect to the Internet ?

-  also see Cause for apparent Web Shield blocking internet connection, http://forum.avast.com/index.php?topic=57443.0.

Having used system restore that may also have brought unexpected results, I have never had much confidence in it.

So if none of the above apply it may be best to do a reinstall of avast and possibly a clean reinstall having used system restore.
- Download the latest version of avast, 5.1.889 http://files.avast.com/iavs5x/setup_av_free_eng.exe (English only) and save it to your HDD, somewhere you can find it again (if you didn't save your last download). Use that when you reinstall.

- Download the avast! Uninstall Utility, aswClear5.exe find it here and save it to your HDD (it has uninstall tools for both 4.8 and 5.x).
  • 1. Now uninstall avast! (using add remove programs, if you can't do that start from the next step), reboot.
  • 2. run the avast! Uninstall Utility from safe mode, first for 4.8 if previously installed and then for 5.x, once complete reboot into normal mode.
  • 3. install the latest version, reboot.

That's me for the night 3:45am here.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security