Author Topic: Port 80 not working  (Read 3382 times)

0 Members and 1 Guest are viewing this topic.

Offline ozna

  • Newbie
  • *
  • Posts: 3
Port 80 not working
« on: March 19, 2011, 07:57:30 PM »
Hi guys,

I'm using Avast! Free with Windows XP for some times without having problem accessing Internet through a cable modem.
Recently, I've installed a broadband router Planet XRT-401D and connected another PC, protected by NOD32.
After the automatic router setup, PC with NOD32 had no problem to access internet and one with Avast! was blocked.
When I disabled Avast! shields, internet explorer worked fine.
Of course, that was not acceptable permanent solution, so I turned shields on and changed Web http port from 80 to 8080.
Internet explorer works again but slower then the other PC with NOD32.

What's the catch?
 

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 4562
  • Whatever will be, will be.
Re: Port 80 not working
« Reply #1 on: March 20, 2011, 06:55:57 AM »
Hello ozna,

What version of avast are you using? Current stable version is 6.0.1000.
Is there any other security software (Norton, McAfee etc.) now and before installing avast?
And, what do you mean "changed Web http port from 80 to 8080"? Are you using proxy, or changing WebSheild's redirection settings?

Try repair of avast! You can do this by following process:
1. Go to Control-Panel and open "Add/Remove Programs"
2. Choose "avast! Free Antivirus" and click "Remove"
3. Then choose "Repair" and click next.
4. Reboot your computer.

Thanks.
Main: Win10 Pro 2004 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 20 Premier Beta / Comodo Firewall 12
Mobile: Win10 Pro 2004 32bit, Vista SP2 32bit / Core 2 Duo SU9300 1.2GHz / 4GB RAM / Avast 20 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。

Offline ozna

  • Newbie
  • *
  • Posts: 3
Re: Port 80 not working
« Reply #2 on: March 20, 2011, 10:49:51 AM »
Hi NON!
Thanks for reply.

It is Avast! Free ver. 6.0.1000.
NOD32 and AVG Free were installed before and uninstalled properly.
I entered settings/troubleshooting/redirect setings and changed Web http port to 8080.
Also tried to repair Avast as described, fresh installation and always the same problem appears.

Avast! worked fine before I installed the Planet XRT-401D router. Even now, when I connect PC directly to the cable modem it works fine with Avast! factory settings restored.

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 4562
  • Whatever will be, will be.
Re: Port 80 not working
« Reply #3 on: March 20, 2011, 04:24:25 PM »
I entered settings/troubleshooting/redirect setings and changed Web http port to 8080.
This means Web Shield is not scanning most traffics...

Avast! worked fine before I installed the Planet XRT-401D router. Even now, when I connect PC directly to the cable modem it works fine with Avast! factory settings restored.
Then it seems this is some kind of conflict with router settings... please check router settings, such as SPI firewall, virtual-server functionality etc.
Could you re-setup this router manually: without using automatic setup utility?

When you set "localhost:12080" to IE's proxy settings with "changed Web http port to 8080" setting, can you connect to the Internet?

Thanks.
Main: Win10 Pro 2004 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 20 Premier Beta / Comodo Firewall 12
Mobile: Win10 Pro 2004 32bit, Vista SP2 32bit / Core 2 Duo SU9300 1.2GHz / 4GB RAM / Avast 20 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。

Offline ozna

  • Newbie
  • *
  • Posts: 3
Re: Port 80 not working
« Reply #4 on: March 20, 2011, 11:30:00 PM »
Thanks for assistance, NON.
Whatever it was, it's gone now.
System restore to the previous functional point (before router installation) helpped.

Best regards