Author Topic: Control Centre won't recognise Avast  (Read 8090 times)

0 Members and 1 Guest are viewing this topic.

Offline justinlee

  • Poster
  • *
  • Posts: 400
Control Centre won't recognise Avast
« on: May 19, 2011, 08:26:17 PM »
I know this has been discussed before and i have followed in the instructions in the link below...

https://support.avast.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=580&nav=0,2

After following those instructions Avast is still not recognised in Control Centre. Help!

Btw, i am using Avast v6.0.1125
Windows 7 Home Premium (64-bit) SP1,
Intel Core i5-2410M @2.30GHz, 6GB RAM
AvastFree Antivirus & ZoneAlarm Free.

SafeSurf

  • Guest
Re: Control Centre won't recognise Avast
« Reply #1 on: May 20, 2011, 10:38:53 AM »
You can try this:

Sometimes, Windows Action Center stops recognizing your antivirus or firewall... The fix could be fairly easy for the most part.

1. Go to Control Panel and open Administrative tools.
2. Click on Services.
3. Go down to Windows Management Instrumentation.
4. Stop this service. Stop the Action Center service too.
    Let them Automatically start.
5. Exit out of this area to your desktop.
6. Right click Start and choose Explore.
7. Go to C:\windows\system32\wbem\repository.
    Delete this subdirectory ONLY.  Leave the others there.
    Sometimes, only using Unlocker http://www.filehippo.com/download_unlocker/, Delete FXP http://www.jrtwine.com/ or KillBox http://killbox.net/ you can delete these files.
8. Exit back to your desktop and reboot your computer (you might need to boot twice).

This will rebuild the deleted folder and the database.  Once restarted, Windows Action Center should show the correct information, and antivirus and firewall should now be recognized.

If not, I know Tech will have more to offer on this.  ;)

Offline justinlee

  • Poster
  • *
  • Posts: 400
Re: Control Centre won't recognise Avast
« Reply #2 on: May 20, 2011, 12:13:31 PM »
You can try this:

Sometimes, Windows Action Center stops recognizing your antivirus or firewall... The fix could be fairly easy for the most part.

1. Go to Control Panel and open Administrative tools.
2. Click on Services.
3. Go down to Windows Management Instrumentation.
4. Stop this service. Stop the Action Center service too.
    Let them Automatically start.
5. Exit out of this area to your desktop.
6. Right click Start and choose Explore.
7. Go to C:\windows\system32\wbem\repository.
    Delete this subdirectory ONLY.  Leave the others there.
    Sometimes, only using Unlocker http://www.filehippo.com/download_unlocker/, Delete FXP http://www.jrtwine.com/ or KillBox http://killbox.net/ you can delete these files.
8. Exit back to your desktop and reboot your computer (you might need to boot twice).

This will rebuild the deleted folder and the database.  Once restarted, Windows Action Center should show the correct information, and antivirus and firewall should now be recognized.

If not, I know Tech will have more to offer on this.  ;)


C:\windows\system32\wbem\repository
When you say delete this subdirectory only do you mean only delete the repository folder? but leave the wbem folder etc??
Windows 7 Home Premium (64-bit) SP1,
Intel Core i5-2410M @2.30GHz, 6GB RAM
AvastFree Antivirus & ZoneAlarm Free.

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11248
  • No support PM's thanks
Re: Control Centre won't recognise Avast
« Reply #3 on: May 20, 2011, 12:21:13 PM »
Yes just the repository.

Offline justinlee

  • Poster
  • *
  • Posts: 400
Re: Control Centre won't recognise Avast
« Reply #4 on: May 20, 2011, 03:56:05 PM »
Tried all of this and even repeated the /verify /salvage commands in command prompt but Control Center still does not recognise Avast. I should also note that this problem only occured after i used system restore to restore to an earlier point.

Am i correct in saying the repository is rebuilt every time your system is booted?
« Last Edit: May 20, 2011, 03:59:38 PM by justinlee »
Windows 7 Home Premium (64-bit) SP1,
Intel Core i5-2410M @2.30GHz, 6GB RAM
AvastFree Antivirus & ZoneAlarm Free.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Control Centre won't recognise Avast
« Reply #5 on: May 20, 2011, 04:02:07 PM »
Using system restore could unfortunately brings avast (and windows repository) to an inconsistent state.
If the avast support article does not help, I'll suggest an installation from scratch:

1. Download the latest version of avast! Uninstall Utility and save it.
2. Download the latest avast! version and save it.
3. Uninstall avast from Control Panel (if possible). If, for any reason, you can't run it, try booting in Safe Mode and doing it from there. Anyway, boot after that.
4. Run the avast! Uninstall Utility saved on 1. If, for any reason, you can't run it, try booting in Safe Mode and doing it from there. Anyway, boot after you've run it.
5. Install avast! using the setup saved on 2. Boot.
6. Register your free copy or add the license key for Pro. Or even upgrade your key from old versions.
7. Check and post the results. If, for any reason, you did not solve, try doing the step 3 in Safe Mode anyway.
The best things in life are free.

Offline justinlee

  • Poster
  • *
  • Posts: 400
Re: Control Centre won't recognise Avast
« Reply #6 on: May 20, 2011, 07:30:04 PM »
I did what you suggested and Avast is now recognised but Control Center is saying Avast is out of date. I click on 'update now' and a pop up window asks if i trust this program and wish to allow it to run so i click yes and nothing happens after that. This has happened to me before and after a day or 2 seems to rectify itself? Any more ideas?
Windows 7 Home Premium (64-bit) SP1,
Intel Core i5-2410M @2.30GHz, 6GB RAM
AvastFree Antivirus & ZoneAlarm Free.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Control Centre won't recognise Avast
« Reply #7 on: May 20, 2011, 07:42:20 PM »
Maybe it's just boot. Seems some glitch in the update/GUI.
If you want to be sure, please, upload (attach) the avast log:
C:\ProgramData\AVAST Software\Avast\log\Setup.log
or C:\Program Files\Alwil Software\Avast5\Setup\setup.log

If the file is too big for the forum, post the last 400-500 lines of it.
The best things in life are free.

Offline justinlee

  • Poster
  • *
  • Posts: 400
Re: Control Centre won't recognise Avast
« Reply #8 on: May 20, 2011, 07:54:26 PM »
Here is the log file. I had to delete the first few hundred lines.
Windows 7 Home Premium (64-bit) SP1,
Intel Core i5-2410M @2.30GHz, 6GB RAM
AvastFree Antivirus & ZoneAlarm Free.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Control Centre won't recognise Avast
« Reply #9 on: May 20, 2011, 08:23:48 PM »
Your log seems ok :)
The best things in life are free.

Offline justinlee

  • Poster
  • *
  • Posts: 400
Re: Control Centre won't recognise Avast
« Reply #10 on: May 20, 2011, 08:31:40 PM »
Avast just performed an automatic update and at that moment i saw the red cross on the action centre flag in the system tray disappear. Problem solved!  :)

One thing i must say though, this is not the first time i have had to uninstall and reinstall Avast because of a problem. Each time i have not had a virus in the chest so it has been ok, but what if there was a virus being held in the chest? Deleting Avast would release it into the computer's system. This is quite worrying!
Windows 7 Home Premium (64-bit) SP1,
Intel Core i5-2410M @2.30GHz, 6GB RAM
AvastFree Antivirus & ZoneAlarm Free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89357
  • No support PMs thanks
Re: Control Centre won't recognise Avast
« Reply #11 on: May 20, 2011, 08:37:21 PM »
The problem is squarely at the door of the Windows Control Center. This was a problem with the XP and Vista WSC Windows Security Center, which was flaky at best.

It seems to suffer quite a lot from data corruption. Doesn't seem to have improved much in win7 other than changing the name.

Uninstall clears the virus chest also, it isn't restored, the contents of the chest are history.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.5.6116 (build 24.5.9153.762) UI 1.0.808/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline justinlee

  • Poster
  • *
  • Posts: 400
Re: Control Centre won't recognise Avast
« Reply #12 on: May 20, 2011, 08:44:51 PM »
This is good to know. I really like Avast so stick with it.
Windows 7 Home Premium (64-bit) SP1,
Intel Core i5-2410M @2.30GHz, 6GB RAM
AvastFree Antivirus & ZoneAlarm Free.

Offline justinlee

  • Poster
  • *
  • Posts: 400
Re: Control Centre won't recognise Avast
« Reply #13 on: May 20, 2011, 08:50:44 PM »
Am i correct in saying that the repository folder updates on every boot?
Windows 7 Home Premium (64-bit) SP1,
Intel Core i5-2410M @2.30GHz, 6GB RAM
AvastFree Antivirus & ZoneAlarm Free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89357
  • No support PMs thanks
Re: Control Centre won't recognise Avast
« Reply #14 on: May 20, 2011, 10:00:41 PM »
Which repository folder would this be ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.5.6116 (build 24.5.9153.762) UI 1.0.808/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security