Author Topic: Allow Port Forwarding to enable VPN connection  (Read 16493 times)

0 Members and 1 Guest are viewing this topic.

davidizod

  • Guest
Allow Port Forwarding to enable VPN connection
« on: June 07, 2011, 06:45:16 PM »
I am trying to set up a VPN connection using standard Microsoft host and client.  I am using Windows XP on both machines and have Avast Internet Security.

The port I need to use is 1723 for a PPTP VPN server.

It works fine when Avast is disabled but doesn't work when Avast is enabled.

What do I need to do?

David

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: Allow Port Forwarding to enable VPN connection
« Reply #1 on: June 07, 2011, 07:35:00 PM »
What product are you using? You're posting in the Business Protection forum, but the business side of Avast is still running 4.8, which doesn't include a firewall.

For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

davidizod

  • Guest
Re: Allow Port Forwarding to enable VPN connection
« Reply #2 on: June 08, 2011, 06:36:16 PM »
I am using Avast Internet Security 6. which does have a firewall.
Where should I have posted this? I couldn't find a slot for Avast Internet Security 6

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: Allow Port Forwarding to enable VPN connection
« Reply #3 on: June 08, 2011, 06:40:49 PM »
This board would be more appropriate: http://forum.avast.com/index.php?board=2.0
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 89011
  • No support PMs thanks
Re: Allow Port Forwarding to enable VPN connection
« Reply #4 on: June 08, 2011, 07:21:47 PM »
It has now been moved to that board.

@ davidizod
Unfortunately I don't use the AIS version, so I can't comment on your problem.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Allow Port Forwarding to enable VPN connection
« Reply #5 on: June 08, 2011, 10:46:19 PM »
Hi, do I understand you correctly, that you run VPN server on the computer protected with avast? Go to the packet rules dialog, and create a rule there allowing 1723 port for incoming traffic. Then forward the port on your router.

davidizod

  • Guest
Re: Allow Port Forwarding to enable VPN connection
« Reply #6 on: June 09, 2011, 03:40:54 PM »
Thanks for your reply Lukor.
In Firewall - Expert Settings - Packet Rules I have inserted the following
Name- MS VPN, Action - Allow, Protocol - TCP(6), Direction - in/out, Address - my static IP, Local - Port 1723

But it still blocks access from the remote computer.

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: Allow Port Forwarding to enable VPN connection
« Reply #7 on: June 09, 2011, 03:55:46 PM »
I don't think that you're supposed to put *your* static IP in the Packet Rule, I think it's supposed to be the addresses that you're allowing to use that port.

So, the IP of the other computer, or all IP addresses if that number is dynamic and can change at any time.
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

davidizod

  • Guest
Re: Allow Port Forwarding to enable VPN connection
« Reply #8 on: June 09, 2011, 07:18:11 PM »
So should I leave that column blank as I won't know the IP addresses of the remote computers?

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: Allow Port Forwarding to enable VPN connection
« Reply #9 on: June 09, 2011, 10:13:07 PM »
Sorry, I can't answer that because I don't have AIS either, I just have the free version.

Maybe keep it blank, or put a star in for the value (*).  Maybe it lets you put 0.0.0.0 - 255.255.255.255?  I'm not sure what you can put in for the values.
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

Nesivos

  • Guest
Re: Allow Port Forwarding to enable VPN connection
« Reply #10 on: June 09, 2011, 10:27:53 PM »
So should I leave that column blank as I won't know the IP addresses of the remote computers?

If you haven't already you might want to take a look at the stuff on this link.  Even though it may have been working before maybe there is something that you missed that is addressed on the link that will help in this case.
Quote
HowTo: Windows XP VPN Server Setup

http://www.aeonity.com/frost/howto-windows-xp-vpn-server-setup

davidizod

  • Guest
Re: Allow Port Forwarding to enable VPN connection
« Reply #11 on: June 10, 2011, 09:52:52 AM »
Thanks for all the suggestions.  I am afraid none of them seem to work.
So at the moment I have Avast firewall turned off (but Windows firewall is still on) and everything works fine.

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: Allow Port Forwarding to enable VPN connection
« Reply #12 on: June 10, 2011, 03:39:31 PM »
Sorry to hear that. If I get some time I'll load up a trial of AIS on a computer and see if I can poke through the settings for you.
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum