Author Topic: File System Shield Provider not found  (Read 29957 times)

0 Members and 1 Guest are viewing this topic.

Offline twmills

  • Newbie
  • *
  • Posts: 1
File System Shield Provider not found
« on: November 14, 2011, 12:10:01 AM »
Can anyone tell me how to reactivate Avast! When I try to re-start Avast I am getting the message "File System Shield Provider not found." I have tried to simply "start" the Avast program from the Action Center, and also tried to reload Avast twice from the download site.

Offline Pondus

  • Avast Überevangelist
  • Maybe Bot
  • *****
  • Posts: 27324
Re: File System Shield Provider not found
« Reply #1 on: November 14, 2011, 12:29:19 AM »
try avast repair

For a repair of avast. Windows, Add Remove programs, select 'avast! Anti-Virus,' click the Change/Remove button from the pop-up window, scroll down to Repair, click next and follow.




Chief Wiggum: Uh, no, you got the wrong number. This is 9-1…2.


Offline themackae

  • Newbie
  • *
  • Posts: 1
Re: File System Shield Provider not found
« Reply #2 on: January 25, 2012, 11:49:47 PM »
I have just had the same problem. I have run repair. I have uninstalled and reinstalled. All to no avail ... same problem. I have current copy of AIS. How do I get AIS running on my computer again?

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 37740
  • Dragons by Sasha
    • Malware fixes
Re: File System Shield Provider not found
« Reply #3 on: January 25, 2012, 11:52:35 PM »
http://www.avast.com/download-update

Download and install the update from the link above and all should be well

Offline mary salvador

  • Newbie
  • *
  • Posts: 2
Re: File System Shield Provider not found
« Reply #4 on: January 26, 2012, 12:07:04 AM »
Hi, I'm having ther same problem....did a virus cause this?  I'm downloading the update right now...keeping my fingers crossed.
Mary Salvador

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 65977
Re: File System Shield Provider not found
« Reply #5 on: January 26, 2012, 01:32:28 AM »
did a virus cause this?
No. Seems on avast virus definitions side.
The best things in life are free.

Offline beatle

  • Newbie
  • *
  • Posts: 1
Re: File System Shield Provider not found
« Reply #6 on: January 26, 2012, 02:13:40 AM »
I've tried both repair and the download from avast.  Still having the same problem. :'(

Offline mary salvador

  • Newbie
  • *
  • Posts: 2
Re: File System Shield Provider not found
« Reply #7 on: January 26, 2012, 02:33:47 AM »
Thank you for your reply, :D  I am very happy that the problem was not a virus or worm.  I finally fixed my problem, I have the Internet Security version and had to download that version and reinsert the license code.  All is well now and I am almost finshed running my daily ful system scan.
thank you for your help
Mary Salvador

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 65977
Re: File System Shield Provider not found
« Reply #8 on: January 26, 2012, 02:45:28 AM »
Test an installation from scratch then.
Did you use Windows System Restore lately?
The best things in life are free.

Offline chuchi

  • Newbie
  • *
  • Posts: 3
Re: File System Shield Provider not found
« Reply #9 on: January 27, 2012, 02:29:12 PM »
http://www.avast.com/download-update

Download and install the update from the link above and all should be well

This actually worked! Thank you essexboy  ;)

Offline kyrene

  • Newbie
  • *
  • Posts: 1
Re: File System Shield Provider not found
« Reply #10 on: January 30, 2012, 01:30:02 AM »
Test an installation from scratch then.
Did you use Windows System Restore lately?

I have the same problem with my avast! pro and i think it started when i restored my system. when i saw that my avast is not working, i tried to undo the restore but it still didnt start.

i tried repairing and downloading the updates but it didnt work. i cant reinstall since i dont have the licence anymore.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72268
  • No support PMs thanks
Re: File System Shield Provider not found
« Reply #11 on: January 30, 2012, 01:56:18 AM »
System Restore can have unforeseen consequences one seems it messes with avast as it ends up with old files.

You can have the license resent:
Resend avast License http://www.avast.com/resend-license-paid.php, you will need to enter the email that you used when purchasing the license, e.g. the one that the original email with the link was sent.

So you should be able to reinstall, but you really should backup your data and that would include things like your avast license file license.avastlic and other registration keys, etc.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2015 10.3.2225 R3 SP1/ Outpost Firewall Pro9.1/ Firefox 39.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.1.8/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 65977
Re: File System Shield Provider not found
« Reply #12 on: January 31, 2012, 01:17:23 AM »
kyrene, I suggest an installation from scratch:

1. Download the latest version of avast! Uninstall Utility and save it.
2. Download the latest avast! version and save it.
3. Uninstall avast from Control Panel (if possible). If, for any reason, you can't run it, try booting in Safe Mode and doing it from there. Anyway, boot after that.
4. Run the avast! Uninstall Utility saved on 1 in Safe Mode. Boot after you've run it. Repeat this for any major avast! version you have ever installed/upgraded in your computer.
5. Install avast! using the setup saved on 2. Boot.
6. Register your free copy or add the license key for Pro. Or even upgrade your key from old versions.
7. Check and post the results. If, for any reason, you did not solve, try doing the step 3 in Safe Mode anyway.

And the license could be received as David posted.
The best things in life are free.

Offline newgirl54

  • Newbie
  • *
  • Posts: 1
Re: File System Shield Provider not found
« Reply #13 on: February 28, 2012, 08:09:48 PM »
HELP................................. I have read through all the posts and tried everything suggested but my avast still will not switch on it keeps saying file system shield provider not found. It was working perfectly until i done a system restore then i tried to undo the system restore but it wouldn't do it. I have even tried to uninstall avast off my laptop and it will not uninstall, i have also tried to download avast again but it wont download. I am working windows 7 and know nothing about computers whatsoever. I need HELP PLEASE big time.  THANK YOU.........

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 65977
Re: File System Shield Provider not found
« Reply #14 on: February 28, 2012, 09:15:42 PM »
System restore has its issues with avast.
I suggest an installation from scratch as posted before.
The best things in life are free.