Author Topic: Both my XP systems hang after update to 6.0.1367 - Again !!! :-(  (Read 3307 times)

0 Members and 1 Guest are viewing this topic.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Both my XP systems hang after update to 6.0.1367 - Again !!! :-(
« on: December 04, 2011, 05:27:25 PM »
Got a message about a program update and choose to install that.
After reboot none of the programs in the tray started and the system hanged.
Not even emergency shutdown (shift + [shutdown]) worked.
Need to power off and start in "safe mode" to get things working.
Same thing happended both my PC (a stationary and a laptop).

If I disable the avast service then things work as normal (without avast of course).

If I set the avast service to "manual" and reboot everything startes up ok.
But if I then start the avast service the system hangs on the fist .exe file I run.

This happened the last time I got a program update as well.
And then I had to uninstall avast, clean up (manually) and reinstall avast.
But that is very time consuming (have to enter all settings over again).

A anti-virus like avast should be able to update without messing up things :-(

Anyone else experienced this?  Any idea on how to get it working w/o a reinstall?
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: Both my XP systems hang after update to 6.0.1367 - Again !!! :-(
« Reply #1 on: December 04, 2011, 06:24:00 PM »
According to your post, it seems like something in the start up items. I have seen reported problems about 1367, but not that it would affect all the other "autorun" items too.

It is not so clear to me what is happening in your tray. This "may" be related to autorun items, but it may also be related to tray notification icons. Have you tried deleting the tray notifications icons cache? (you may use the respective item in CCleaner to do that, or manually apply the relevant registry keys.)
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: Both my XP systems hang after update to 6.0.1367 - Again !!! :-(
« Reply #2 on: December 04, 2011, 06:50:43 PM »
OK, now I have reinstalled both my PCs trying to find the easiest way...

On my stationary PC I did this:
1) Boot into safe mode (else thing hangs)
2) Disable the avast service
3) Boot normal (avast won't start now)
4) Uninstall avast (normal uninstall, no extra cleaning etc)
5) Reinstall the newest avast download
6) Go through all options and setting (they are lost during uninstall).
Result: Worked OK (as always), but all settings are lost (as always).

THEN, on my laptop I tried to see if I could find an easier solution:
1) Boot into safe mode (else thing hangs)
2) Disable the avast service
3) Boot normal (avast won't start now)
4) Reinstall the newest avast download (without uninstalling at all)
Result: Worked OK, and ALL SETTINGS ARE KEPT :-)

OK, so for me I now have a big note on the wall :-)
"When avast askes to update program, click NO!!!!,
then download the full latest version and install
that on top manually (not as an upgrade)"

Note:  As a full new install on top of the old work there must be something the update does wrong. If the update does the same thing as a "full install on top" why does it hang :-)
« Last Edit: December 04, 2011, 06:55:54 PM by Lars-Erik »
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: Both my XP systems hang after update to 6.0.1367 - Again !!! :-(
« Reply #3 on: December 04, 2011, 08:16:49 PM »
While I can't answer your question, I still don't understand why you are specially disabling avast service just to go back to Windows Normal Mode to uninstall it.

If you want to download the complete setup.exe to update, and for some reason you find that this method is working better for you, that's fine. The "problem" "could" be in the active avast service and defense module, but it may also be related to something else in your particular system.

But avast can be uninstalled from Windows Safe Mode, and the Removal utility http://www.avast.com/uninstall-utility also works better from Windows Safe Mode.

In addition, you have not tried to delete the firewall rules of ZA, which is particularly known to have some conflicts with Avast.

So, I'm glad you simplified your update procedures for your specific systems, but keep in mind that,

A_ it can be simplified even a little more; and
B_ the normal built in (from Avast main GUI) update procedures are working correctly for other users.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: Both my XP systems hang after update to 6.0.1367 - Again !!! :-(
« Reply #4 on: December 04, 2011, 09:16:43 PM »
I tried to disable ZA (all services and tray programs).
Have earlier tried to uninstall it completly.

But as you see, avast works like it should when you run a complete new install on top of the update that causes it to fail. Without uninstalling it. So there is something with the updates.
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: Both my XP systems hang after update to 6.0.1367 - Again !!! :-(
« Reply #5 on: December 04, 2011, 10:53:40 PM »
I tried to disable ZA (all services and tray programs).
Have earlier tried to uninstall it completely.

But as you see, avast works like it should when you run a complete new install on top of the update that causes it to fail. Without uninstalling it. So there is something with the updates.

I want to be clear, again. This is, for some reason, not working for your system. It should not be a recommendation for any and all systems.

In addition, I already said that "updating" using the full installer and rebooting immediately is fine with me, but yet in your list of procedures there are a couple of steps that are unnecessary, even for such type of "update".

That was my intention in my previous post.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: Both my XP systems hang after update to 6.0.1367 - Again !!! :-(
« Reply #6 on: December 05, 2011, 02:21:52 PM »
I posted the "solution" to help all those others in these forums that have the same problem.

If all hangs after an update on XP it WILL work to boot in safe mode and disable avast service, and then download and install the full latest avast and install that on top of the existing.

This "Work-a-round" will keep you settings, and fix whatever went wrong in the update.

But still, I think someone should investigate why update fails on so many XP systems.
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72973
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Win 8.1 [x64] - Avast PremSec 21.11.6787.IBC [UI.683] - EEK - Firefox ESR 91.4 [NS/uBO/PB] - TB 91.4
Avast-Tools: Secure Browser 96.1 - Cleanup 21.4 - SecureLine 5.14 - Driver Updater 21.4 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0