Author Topic: 5 minutes to scan 4 mails........ :-(  (Read 20664 times)

0 Members and 1 Guest are viewing this topic.

eric37200

  • Guest
Re:5 minutes to scan 4 mails........ :-(
« Reply #30 on: November 27, 2004, 11:41:38 PM »
yep   8)
wait & see

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re:5 minutes to scan 4 mails........ :-(
« Reply #31 on: November 28, 2004, 02:35:48 PM »
I do understand that proxy setting can affect updates, but once again it is not the question. Neither Eric nor me have problem with updates. No offense there, you answer to so many questions and your devotion to help users is priceless.

Thanks and sorry to mess my answers...  :-[
Eric, in fact, when a virus is found avast could enter in paranoid behavior, I mean, all security levels are set to high in order to avoid infection spread.
Anyway, it should not freeze or take that time to process the emails... you're right.

Can't anybody from Alwil say anything about this?  ;D
The best things in life are free.

farfouille

  • Guest
Re:5 minutes to scan 4 mails........ :-(
« Reply #32 on: November 28, 2004, 04:24:54 PM »
I think I've solved the problem...

What I did :
- uninstall avast 4.5.536 + reboot + delete remaining files/directories
- install avast 4.5.523 (the last official release) + avast automatically updates the vps to 0448-1
- test with the eicar stuff : OK :  no time delay to deal with the infected mail
- I then restore avast parameters : silent mode + send alert mail on infection
- reboot
- test with aicar stuff : KO : long delay (3min.) to handle infected mail
- I then removed the send alert mail on infection and everything  run smooth again
(all test using dialup connection)

Conclusion : It seems that the send alert mail is the problem...

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re:5 minutes to scan 4 mails........ :-(
« Reply #33 on: November 28, 2004, 06:18:59 PM »
Thanks for debugging it, Farfouille.

What is set for your default smtp server into avast4.ini file?
« Last Edit: November 28, 2004, 08:05:36 PM by Technical »
The best things in life are free.

eric37200

  • Guest
Re:5 minutes to scan 4 mails........ :-(
« Reply #34 on: November 28, 2004, 06:51:37 PM »
I think I've solved the problem...

What I did :
- uninstall avast 4.5.536 + reboot + delete remaining files/directories
- install avast 4.5.523 (the last official release) + avast automatically updates the vps to 0448-1
- test with the eicar stuff : OK :  no time delay to deal with the infected mail
- I then restore avast parameters : silent mode + send alert mail on infection
- reboot
- test with aicar stuff : KO : long delay (3min.) to handle infected mail
- I then removed the send alert mail on infection and everything  run smooth again
(all test using dialup connection)

Conclusion : It seems that the send alert mail is the problem...
maybe maybe.... :)
for me when i test my smtp...."unknown error"...
i dont know why...i used always same smtp server (smtp.free.fr)...::)
i prefer this...actually avast work well... 8)

farfouille

  • Guest
Re:5 minutes to scan 4 mails........ :-(
« Reply #35 on: November 28, 2004, 08:37:27 PM »
Thanks for debugging it, Farfouille.

What is set for your [/i]default[/i] smtp server into avast4.ini file?

Technical, it is very cute to thank me but I have to confess that I'm a software developper and that kind of problem always ring my professional bell...   ;)

Well the laptop I used to make the test is now far away from home (it is not mine, i had it to ... install avast). So I can't look into the avast4.ini but I remember well that when I configured the smtp alert avast asked me for the smtp server and the originator mail. I entered the same smtp server as the ISP which is  'free' (smtp.free.fr).

If you guess that it can be a configuration problem with the smtp server or mail adresses set up for the alert, let me tell you that you are right to think of such a problem but  I've double checked that and it was ok. Btw when an infected mail was detected (and take a long time to be processed), I received the alert (I am the receiver). If I can find some time I will make some further test with my adsl connection using the smtp alert.

Eric do you use the smtp alert feature of avast when an infected mail is received ?

Farfouille
« Last Edit: November 28, 2004, 08:37:45 PM by Farfouille »

eric37200

  • Guest
Re:5 minutes to scan 4 mails........ :-(
« Reply #36 on: November 28, 2004, 08:59:45 PM »
yep i used smtp alert....but now as i say in my lat message, i cant...
...its not very important....but i cant : when i test, i've got error message....

...but avast work well actually... :)

farfouille

  • Guest
Re:5 minutes to scan 4 mails........ :-(
« Reply #37 on: November 29, 2004, 08:37:35 AM »
Thank you Eric.

It appears that we both have problem with stmp alert.

I think we can reasonably pass the baby to alwil team.  :D


Farfouille

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:5 minutes to scan 4 mails........ :-(
« Reply #38 on: November 29, 2004, 09:38:41 AM »
Thanks, acknowledged, will fix asap. Good work guys! :)
If at first you don't succeed, then skydiving's not for you.

eric37200

  • Guest
Re:5 minutes to scan 4 mails........ :-(
« Reply #39 on: November 29, 2004, 12:18:44 PM »
Just another little thing : when i re-installed avast, i made a boot scan (avast found nothing...like always...  :)).
when i've got problems, the other time, i do not made a boot scan...
...maybe another reason...      ::)

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:5 minutes to scan 4 mails........ :-(
« Reply #40 on: November 29, 2004, 01:59:46 PM »
Oddly enough, this was only problem on single-processor machines. Dual or more (or hyperthreading-enabled) machines did not have this problem :)

Anyway, we've isolated and fixed the problem now.

Thanks!
Vlk
If at first you don't succeed, then skydiving's not for you.

farfouille

  • Guest
Re:5 minutes to scan 4 mails........ :-(
« Reply #41 on: November 29, 2004, 02:37:54 PM »

Anyway, we've isolated and fixed the problem now.

Good news for all of us

eric37200

  • Guest
Re:5 minutes to scan 4 mails........ :-(
« Reply #42 on: November 29, 2004, 08:46:43 PM »
to close this topic....  8)
i've clean my registry with avast bart demo version and after that my problem re-appeared.....   :(
...i made update for my preferred antivirus  ;D
....and my problem is solved !
great !
thanx !  ;)

cheers
ERIC

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re:5 minutes to scan 4 mails........ :-(
« Reply #43 on: November 30, 2004, 01:34:04 AM »
...i made update for my preferred antivirus  ;D
....and my problem is solved !

Which one (antivirus) are you talking about?  ???

Did you have time to test the last program update (official release, not a beta) is 4.5.542 and fixes many of the earlier problems  ::)
« Last Edit: November 30, 2004, 01:35:27 AM by Technical »
The best things in life are free.

eric37200

  • Guest
Re:5 minutes to scan 4 mails........ :-(
« Reply #44 on: November 30, 2004, 02:09:52 AM »
...i made update for my preferred antivirus  ;D
....and my problem is solved !

Which one (antivirus) are you talking about?  ???
AVAST of course !!! :D