Author Topic: Problem with gmail account!!  (Read 7107 times)

0 Members and 1 Guest are viewing this topic.

200011

  • Guest
Problem with gmail account!!
« on: November 25, 2004, 01:48:17 PM »
Hello!
I have a problem with gmail account because avast! doesn't scan this pop account.
Help me please!!!
I have read avast's guide, but I haven't found anything.
I suppose that the problem is generated by the different configuration of pop3 of gmail
I report the pop configuration:

pop.gmail.com   port 995  protection ssl enabled!!
smtp.gmail.com port 465 protection ssl enabled!!

I have tried to uninstall the software and reinstall it, but the situation has not changed.
If possible help me!!!!
Bye!!!!! :'(

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re:Problem with gmail account!!
« Reply #1 on: November 25, 2004, 02:59:20 PM »
In short, the avast mail scanner doesn't support SSL (it has never had).

1. interception of the traffic by avast
2. actual scanning of the traffic

Unchecking the SMTP box in Internet Mail provider's settings disables 2 but not 1. This is what you're experiencing.

To prevent avast from doing 1 (which makes sense in your case as you're using SSL), please open the file <avast>\data\avast4.ini, and to the [MailScanner] section, add the following line:

StartSMTP=0

Besides using Outllook and The Bat! for SSL, here is a workaround for SSL and POP3 accounts:
http://forum.avast.com/index.php?board=2;action=display;threadid=8775
to use SSL with other clients and also have the protection of avast.
The best things in life are free.

peterfu

  • Guest
Re:Problem with gmail account!!
« Reply #2 on: November 25, 2004, 03:00:46 PM »
Hi 200011,
it would realy help if You provide us with more detials of Your setup
- Which OS are You using
- Mail Client
- Avast Version
- any othe Application for Spam filtering
- .........

In general Avast does not support SSL connections, except You use as e-mail client Outlook (not Outlook Express) or The Bat - for these clients special Plugin's are used.

How Avast can be used with other mail clients and SSL can be found in this thread:
http://forum.avast.com/index.php?board=2;action=display;threadid=8775

hope it helps
br
Peter

Edited : UPS - technical was quicker - as usual  ;)
« Last Edit: November 25, 2004, 03:02:03 PM by peterfu »

200011

  • Guest
Re:Problem with gmail account!!
« Reply #3 on: November 25, 2004, 03:48:37 PM »
In short, the avast mail scanner doesn't support SSL (it has never had).

1. interception of the traffic by avast
2. actual scanning of the traffic

Unchecking the SMTP box in Internet Mail provider's settings disables 2 but not 1. This is what you're experiencing.

To prevent avast from doing 1 (which makes sense in your case as you're using SSL), please open the file <avast>\data\avast4.ini, and to the [MailScanner] section, add the following line:

StartSMTP=0

Besides using Outllook and The Bat! for SSL, here is a workaround for SSL and POP3 accounts:
http://forum.avast.com/index.php?board=2;action=display;threadid=8775
to use SSL with other clients and also have the protection of avast.


I understand that avast doen't work with ssl but, since I use Avast 4.5, in the avast4.ini there isn't  the section [mail scanner].
What's the way to solve this problem?

My pc configuration is:
Windows xp sp2
outlook express 6.0
Avast 4.5.

I use Outlook express with 5 accounts and only gmail's accout requires ssl protection!

If I change Outlook express with Thunderbird Can I solve the problem?
Thanks for your help
Bye!!  ;D

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re:Problem with gmail account!!
« Reply #4 on: November 25, 2004, 05:28:45 PM »
I understand that avast doen't work with ssl but, since I use Avast 4.5, in the avast4.ini there isn't  the section [mail scanner].
What's the way to solve this problem?

Add it... It's written in my first post there (click on 'Settings' in my signature)
But, did you install the provider? Why don't you have the [MailScanner] section?  ???  ???

If I change Outlook express with Thunderbird Can I solve the problem?

Maybe. It's a workaround for SSL connections. Oh, better than this, you will be with a much better email program than OE  ;D
The best things in life are free.

200011

  • Guest
Re:Problem with gmail account!!
« Reply #5 on: November 26, 2004, 01:51:06 AM »
[MailScanner]
DefaultPopServer=pop.mail.yahoo.it
DefaultSmtpServer=smtp.mail.yahoo.it
ShowTrayIcon=1
UseDefaultSmtp=0
AutoSetProtection=1
PopListen=127.0.0.1:110
SmtpListen=127.0.0.1:25
ImapListen=127.0.0.1:143
StartSMTP=0

I change in this way the avast4.ini is right?
thanks for the help bye!!

or in this way?
[MailScanner]
StartSMTP=0
« Last Edit: November 26, 2004, 02:00:19 AM by 200011 »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re:Problem with gmail account!!
« Reply #6 on: November 26, 2004, 12:20:25 PM »
PopListen=127.0.0.1:110
SmtpListen=127.0.0.1:25
ImapListen=127.0.0.1:143

I think this won't work in Outlook Express if you're using SSL connection...
I'm not sure but do you really use the common ports 25 and 143 to a SSL connection?

Can you see if this thread will help you?
http://forum.avast.com/index.php?board=2;action=display;threadid=8775;start=15
« Last Edit: November 26, 2004, 12:22:15 PM by Technical »
The best things in life are free.

200011

  • Guest
Re:Problem with gmail account!!
« Reply #7 on: November 26, 2004, 03:36:22 PM »
The easy solution of my problem is scan e-mail after the arrive!!
thanks for all
BYE!!! ;D