Author Topic: Avast service can't start  (Read 40780 times)

0 Members and 1 Guest are viewing this topic.

Offline rghthndsd

  • Newbie
  • *
  • Posts: 10
Avast service can't start
« on: January 16, 2012, 07:04:10 PM »
I've been running Avast Free Protection on my Windows XP Professional SP3 computer for several months now.  Previously I've had Malware Bytes and AVG installed on this computer, however both are removed now.

Two days ago I realized that I had auto-updates turned off for a long time, and I restarted it.  It took several cycles to download all the updates from Microsoft, but when it was finished, the avast service was not able to start (Note: SP3 was already on my computer before doing this update).  I can not manually start it, and each time it tries to start the service I get this error in my event viewer: "The avast! Antivirus service terminated unexpectedly.  It has done this 3 time(s)."

I have since tried many times to reinstall (as this was the only suggestion I could find on the forums).  I've downloaded the cleanup program provided by avast, and have run this in safe mode before reinstalling.  I've also run CCleaner to try to clean up the registry before installing, if that makes any difference.

The problem has to do with the Microsoft updates, is there anything I can try to get avast working?

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2671
Re: Avast service can't start
« Reply #1 on: January 16, 2012, 07:51:58 PM »
You could run the removal utility for avast several times; each time selecting previous versions of avast (avast 4 / 5 / 6 ...). Be sure to select the correct path to the installation folder.

You can also search for any (hidden) folders that could be left after the removal, like "avast*" or "alwil*".

You can also run the respective removal utility for previous security tools you had before. Sometimes just "uninstalling" is not enough. For removal utilities, see my signature.

Please report back.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline rghthndsd

  • Newbie
  • *
  • Posts: 10
Re: Avast service can't start
« Reply #2 on: January 16, 2012, 10:07:00 PM »
I've run the remove programs for AVG and Malware Bytes as you indicated, and also ran the avast removal for the different versions (all in safe mode).

Upon reinstall, the service still doesn't start.  Instead, it hangs on the "Starting" status (Edited to add: It should be on the status "Started").  But avast seems to be ok with this: the updates, scans, and real time shields all appear functional. 

I've seen this before with my previous installation attempts.  It is usually not dependable: some times the service will hang like this, and sometimes it will outright crash.  I will post back if the service stops and I can't use avast in the future.

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2671
Re: Avast service can't start
« Reply #3 on: January 16, 2012, 10:36:35 PM »
After the installation, have you rebooted before checking the status of the service?


In addition, ONLY if the problem returns back, you may want to try:

Avast main GUI -> settings -> troubleshooting -> "load avast service only after other system services". Save the changes. Reset the service to what it is supposed to be in the start up type, save and reboot. Test if this solves the problem.

If you find any problems, let us know so avast developers could try to narrow down the source of it.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5214
Re: Avast service can't start
« Reply #4 on: January 17, 2012, 11:41:07 AM »
Can you give us some information about your system OS?  You mentioned that you updated to SP3, so I'm assuming you have XP.  How much RAM do you have?

We have seen people run the MS/Windows Updates then for some reason additional updates show up or the updates didn't take.  You may want to see if you have any other updates needed for MS/Windows and if so install them then reboot your machine.

In addition to the other suggestions made here in the posts, what do you have under Avast Settings > Updates > Update Parameters?  How do you connect to the Internet? 

Also make sure your firewall is not blocking anything for Avast to run properly.  What are you using for a firewall?

Let us know how this goes.  Thanks.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline rghthndsd

  • Newbie
  • *
  • Posts: 10
Re: Avast service can't start
« Reply #5 on: January 17, 2012, 02:56:00 PM »
I booted my computer this morning, and the avast service failed to start.

Quote
Avast main GUI -> settings -> troubleshooting -> "load avast service only after other system services". Save the changes. Reset the service to what it is supposed to be in the start up type, save and reboot. Test if this solves the problem.

After trying this, my avast service is back in "Starting" mode, but not "Started".

Can you give us some information about your system OS?  You mentioned that you updated to SP3, so I'm assuming you have XP.

Quote from: rghthndsd
I've been running Avast Free Protection on my Windows XP Professional SP3 computer for several months now.

Quote
How much RAM do you have?

2Gb

Quote
We have seen people run the MS/Windows Updates then for some reason additional updates show up or the updates didn't take.  You may want to see if you have any other updates needed for MS/Windows and if so install them then reboot your machine.

No updates available.

Quote
In addition to the other suggestions made here in the posts, what do you have under Avast Settings > Updates > Update Parameters?  How do you connect to the Internet?

Wireless DSL modem.  Update parameters: Both boxes (I only connect to the internet using a dialup modem, My computer is permanently connected to the internet) are unchecked.

Quote
Also make sure your firewall is not blocking anything for Avast to run properly.  What are you using for a firewall?

Windows firewall.  I disabled it and it made no difference.

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2671
Re: Avast service can't start
« Reply #6 on: January 17, 2012, 07:30:27 PM »
After trying this, my avast service is back in "Starting" mode, but not "Started".

I understand your post, but I don't know why the starting mode is not working, specially if you double checked that the service is set correctly AND that avast service is supposed to be delayed. Maybe you should wait a little bit longer after the reboot so to be able to see the service working?

Do you use any "startup manager" or similar tool to edit the startup items? For example, CCleaner includes such feature (CCleaner -> Tools -> Startup). If you use such type of tool (including MSConfig as an example), could you review the items? (It may help us a screenshot too.)
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline freddy12

  • Newbie
  • *
  • Posts: 1
Re: Avast service can't start
« Reply #7 on: January 18, 2012, 11:17:55 AM »
Seems like I am having similar problems with avast not starting, I resubscribed in december last year as i was very happy with avast for the last three years on my pc' os windows xp
I was having problems with slow performance and did a system restore and when restarted i noticed the red cross over the avast icon, on the avast controll panel has system unprotected message displayed with the button fix now that has no effect, I also tried the start program button to no effect, otherwise the pc seems to be operating ok, it just seems to be struggling with any thing avast related, I had to use the cellphone to validate my log on to this forum, any comments suggestions or soloutions will be appreciated

Offline Asyn

  • Avast √úberevangelist
  • Maybe Bot
  • *****
  • Posts: 31520
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast service can't start
« Reply #8 on: January 18, 2012, 11:21:27 AM »
...any comments suggestions or soloutions will be appreciated

Repair avast!:
1. Control Panel -> Add/Remove programs -> avast!
2. Scroll down and click on 'Repair'.
3. Follow instructions.
4. Reboot.
XP SP3 - Avast 10.2.2218 - CIS 3.14 [FW/D+] - MBAM 1.75 [On Demand] - Firefox ESR 31.7 [NS/ABP/EHH/BP/SVC] - Thunderbird 31.7 [EM]
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen und Infos):
https://forum.avast.com/index.php?topic=60523.0

Offline rghthndsd

  • Newbie
  • *
  • Posts: 10
Re: Avast service can't start
« Reply #9 on: January 18, 2012, 09:42:02 PM »
Quote
Maybe you should wait a little bit longer after the reboot so to be able to see the service working?

Computer was running for over three hours with the service still "Starting".  When I boot, about half the time it hangs on "Starting", and half the time it completely fails to start.

Quote
Do you use any "startup manager" or similar tool to edit the startup items?

Only msconfig.  Do you want the services, or the startup programs?  The startup programs are attached in the picture.

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2671
Re: Avast service can't start
« Reply #10 on: January 18, 2012, 10:51:35 PM »
(I hope no one starts now adding irrelevant comments about some "optional" items in your attached picture, as they are not the main issue here; at least for now.)

In your picture, I don't see the line regarding avast service startup. I don't know if it is not there at all, or if it was unintentionally "trimmed" from the screenshot, or I'm simply missing it. Please confirm if it is there at all, and add a new screenshot where we'll be able to see it.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline rghthndsd

  • Newbie
  • *
  • Posts: 10
Re: Avast service can't start
« Reply #11 on: January 19, 2012, 12:53:29 AM »
By "start up", I wasn't sure if you meant programs or services.  Attached is the picture of the services.

Offline bob3160

  • Avast √úberevangelist
  • Maybe Bot
  • *****
  • Posts: 27556
  • 55 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast service can't start
« Reply #12 on: January 19, 2012, 12:56:55 AM »
This only shows a few of the items.....
Free avast! Security Seminar: http://www.authorstream.com/Presentation/bob3160-1425909-protecting-yourself/    -  Important: http://www.organdonor.gov/
My Blog: http://bob3160.blogspot.com/ - Win 8.1 Pro 64bit, 8 Gig Ram, avast!2015.10.2.2218 Free, MBAM, WinPatrol -- How to Successfully Install Avast http://goo.gl/VLXde

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2671
Re: Avast service can't start
« Reply #13 on: January 19, 2012, 03:18:39 AM »
I will say now something that MAY sound strange for some users, but anyway, please don't panic (as there is nothing to panic about).

Are you sure you downloaded a legitimate avast installation? Are you sure the setup and the installation wasn't (or got) corrupted?

Please confirm / double check, which exact edition of avast (Free / Pro / AIS) and which exact version are you using? (The current latest stable is v6.0.1367.)

The reason I have my doubts about the installation package (or the installation result) is because the content of your screenshots are not EXACTLY what are supposed to be. In the first one, avast should be there, listed, active and running. In the second one, "Avast software" should clearly be listed as manufacturer and the status should be "Running".

If the only strange thing would be the status, I would suspect of some kind of incompatibility or some other problem. But since other very typical data is also failing in some way or another, I can't just simply skip over my doubts.

So, if you can double check the exact data of OS (including version, 32/64bits, SP) and exact avast edition and version, it may help us find why those differences are there.

Have you downloaded the latest stable version of avast from the original website?

Please report back.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline rghthndsd

  • Newbie
  • *
  • Posts: 10
Re: Avast service can't start
« Reply #14 on: January 20, 2012, 05:15:14 PM »
This only shows a few of the items.....

I was under the impression that what was requested was to see my Avast entry.  Let me know if you want to see everything.

Quote
Are you sure you downloaded a legitimate avast installation? Are you sure the setup and the installation wasn't (or got) corrupted?

I originally downloaded the program from Cnet (this is where the link on the avast site takes me). I deleted the exe I originally installed and redownloaded it.  This made no difference: Service still can't start, the entries in msconfig are identical to the pictures I posted before.

The version of avast I have is the free version, 6.0.1367.
System: Microsoft Windows XP, Professional, Version 2002, Service Pack 3, 32 bit.