Author Topic: Avast 7 and Walkman Connection Problem  (Read 2096 times)

0 Members and 1 Guest are viewing this topic.

Offline .: L' arc :.

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1780
  • Thinking with Portals
Avast 7 and Walkman Connection Problem
« on: February 28, 2012, 08:02:12 AM »
Whenever I plug in my Walkman into my laptop (Windows 7 Home Basic, 64 bit), it should enter MTP mode--something that is intended for file transfer.

However, after installing avast 7, the computer could no longer detect my Walkman, as an MTP nor as a plain removable media. Even worse, Device Manager does not show anything connected to the USB ports.

There are no driver problems as I confirmed that disabling the shields, solves this issue. But it would mess up my laptop's security if I'll have to disable the shields whenever I connect my Walkman.

Hoping for a quick response.
Windows 7 (64-bit) Home Premium SP1
avast! 9 RC1

ady4um

  • Guest
Re: Avast 7 and Walkman Connection Problem
« Reply #1 on: February 28, 2012, 08:28:02 AM »
Maybe you could narrow down which shield is causing the problem. Instead of pausing all shields at once, pause them one at a time. For example, go to web shield -> stop -> stop for 10 minutes, and during this 10 minutes, test the behavior. Repeat with each shield (even if you already found one that makes problems, there might be more than one involved), and then report back.

This way, it would narrow down where the problem is.

Just to be sure, could you also delete the firewall rules related to avast and to this Walkman connection (if any)? Then the firewall rules are re-created anew.

Offline AntiVirusASeT

  • Poster
  • *
  • Posts: 462
Re: Avast 7 and Walkman Connection Problem
« Reply #2 on: February 28, 2012, 08:41:41 AM »
using walkman here too but is working here (MTP mode)

when i plug in my walkman, the 'content transfer' thing pops up

windows 7 32 bit sp1 here, Avast! 7.0.1407 free (i have only file, web, network, IM, behaviour, script shields)
« Last Edit: February 28, 2012, 08:44:14 AM by AntiVirusASeT »

Offline .: L' arc :.

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1780
  • Thinking with Portals
Re: Avast 7 and Walkman Connection Problem
« Reply #3 on: February 28, 2012, 01:31:21 PM »
There aren't firewall rules that could actually meddle with Walkman's MTP. Furthermore, the problem doesn't seem to go away with just one shield disabled. It has to be all of it.

I'll try tweaking some more and see if I can post back more info about this problem.
Windows 7 (64-bit) Home Premium SP1
avast! 9 RC1

ady4um

  • Guest
Re: Avast 7 and Walkman Connection Problem
« Reply #4 on: February 28, 2012, 01:47:19 PM »
Instead of pausing one by one, you could pause them all, and start one.

Then
 Doesn't work ===>> start that one again. Pause another one...

If the test is not enough after you went through all shields, then choose 2 at a time...

The different combinations should lead you to the "one" making troubles for you.

Strangely, AntiVirusASeT don't have problems, so maybe the issue is with one of the shields he is currently NOT using.