Author Topic: Problemas con Avastsvc.exe  (Read 18604 times)

0 Members and 1 Guest are viewing this topic.

papasito

  • Guest
Problemas con Avastsvc.exe
« on: March 15, 2012, 10:36:04 AM »
Estoy teniendo problemas con Avastsvc.exe ya que el programa "Malwarebytes Anti-Malware" lo detecta como potencialmente peligroso y para el proceso. La verdad es que no se cual es el proceso que realiza, si es importante o no. Por otra parta al ir mirando por internet he leido que consume mucha CPU y la verdad me guataría saber que opinais los usuarios de este fichero y como no entiendo ni "mu" del inglés pues no me entero de lo que se dice en los foros ingleses donde si que hay muchas referencias a este ficherito.
Agradecería ayuda o algún comentario alentador.

Offline Populous

  • Advanced Poster
  • **
  • Posts: 977
Re: Problemas con Avastsvc.exe
« Reply #1 on: March 15, 2012, 04:24:22 PM »
Estoy teniendo problemas con Avastsvc.exe ya que el programa "Malwarebytes Anti-Malware" lo detecta como potencialmente peligroso y para el proceso. La verdad es que no se cual es el proceso que realiza, si es importante o no. Por otra parta al ir mirando por internet he leido que consume mucha CPU y la verdad me guataría saber que opinais los usuarios de este fichero y como no entiendo ni "mu" del inglés pues no me entero de lo que se dice en los foros ingleses donde si que hay muchas referencias a este ficherito.
Agradecería ayuda o algún comentario alentador.

Hola Papasito y bienvenido al foro!  :)

En principio, no existe ningún tipo de incompatibilidad entre Malwarebytes y Avast.

Yo llevo muchos años usando ambos de forma conjunta y no he tenido ni un solo problema.

¿De donde has descargado el Avast? Si lo has descargado de un sitio AJENO a avast desinstalálo según este procedimiento

Descarga Avast desde el sitio oficial y vuelve a instalarlo. Actualiza y reinicia.

En cuanto a Malwarebytes.. ¿De donde lo bajaste?
Desinstálalo y bájalo del sitio web oficial en ESPAÑOL. Una vez lo hayas descargado desde el sitio oficial, reinicia el PC y vuelve a instalarlo.

Estas son las versiones que tengo yo instalada y con las cuales no tengo ningún tipo de problema...

Avast:
Versión instalada: Avast 7.0.1426
Versión de la base de datos de virus: 120315-0

Malwarebytes:
Versión instalada: Malwarebytes Anti-Malware 1.60.1.1000
Versión de la base de datos: v2012.03.15.04

Puede ser debido también a un error de las firmas de malware de tu Malwarebytes.

Actualiza ambos programas y asegúrate que tienes las mismas versiones que yo instaladas y en fin, todo lo que te he comentado anteriormente.
 
Indica por favor información sobre tu PC. Sistema Operátivo, Arquitectura (32/64bits), Versión de Avast instalado, Service Packs instalado, Versión de Malwarebytes instalado, etc...

En definitiva, dar toda la información que puedas para hacernos una idea...

Si sigues teniendo problemas vuelve por aquí y entre todos intentaremos ayudarte.

 Saludos!

Actualizado:

=> He analizado el archivo Avastsvc.exe directamente con el scanner de Avast y no detecta nada, ni como malware ni como programa potencialmente no deseado... Fíjate en la captura que adjunto. También lo he analizado manualmente con Malwarebytes 1.60.1.1000 que es la versión que tengo instalada y tampoco me detecta nada... Te adjunto el log del análisis de Malwarebytes.

También he subido el archivo a virustotal y tras ser analizado por 42 antivirus no ha encontrado ninguna infección tal y como puedes comprobar aquí.


Algunos tipos de malware se camuflan con el nombre de Avastsvc.exe para engañar a los usuarios y que piensen que se trate de algún fichero perteneciente a Avast cuando realmente es un malware.

Es posible que sea tu caso (no lo  sé al 100%) pero vamos a comprobarlo. Asegúrate que el fichero está en la carpeta de Avast y no en C:\Windows\System32 que es donde habitualmente se camufla este tipo de malware con el resto de controladores y librerías del sistema. Si el proceso está aún en memoria, vete a tu administrador de tareas y con el botón derecho selecciona "avastsvc.exe" y selecciona la primera opción de todas, "Abrir ubicación del archivo" para comprobar en qué carpeta está el archivo a que hace referencia el proceso.

De todas formas en caso de que tengas una infección, deberás comunicarlo en el foro específico dedicado a ayudar a los usuarios con infecciones ya que este es un foro de usuarios... Nosotros podemos "orientarte" pero aunque tengamos los conocimientos para ayudarte, por ética profesional, no lo hacemos.  Existe un equipo de Avast altamente cualificado dedicado exclusivamente a ayudar a los usuarios a desinfectar sus ordenadores.  El foro en concreto se llama "Viruses & Worms" y la mala noticia es que está en inglés pero si te lias vuelve pora aquí y te intentaremos echar una mano...

De momento empieza por hacer los pasos que te pedí y si al final resulta que tienes una infección acude al foro que te comenté.

Un saludo y siento no poder ayudarte más...  :-\
« Last Edit: March 15, 2012, 05:38:33 PM by Populous »
Avast Premium Security 20.2.2401 (compilación 20.2.5130.565) |CPU: Intel(R) Core(TM) i7-8700 CPU @ 4,06GHz, 6 procesadores principales, 12 procesadores lógicos | RAM: 32GB -DDR4-2666 | T.Gráfica: GeForce GTX 1060 | SO: Win 10 Pro Versión 1909 Build (18363.752) - 64 Bits

iroc9555

  • Guest
Re: Problemas con Avastsvc.exe
« Reply #2 on: March 15, 2012, 09:09:21 PM »
Solo si haz comprobado que tu avastsvc.exe esta limpio por VT.

Abres Avast > Escudo de sistema de archivos > Opciones avanzadas > Exclusiones > Añadir.  Buscas la carpetas de Malwarebytes' y la añades. Click Aceptar

Escudo de web > Opciones avanzadas > Exclusiones > URLs a excluir > Añadir. Copia/Pega   " *.mbamupdates.com " sin las comillas. Click Aceptar

Escudo de comportamiento > Opciones avanzadas > Procesos de confianza > Añadir.
direccion completa de estos procesos:

\mbamgui.exe
\mbamservice.exe

Click Aceptar.

Abre MBAM > Lista para ignorar o exclusiones ( no se porque el mio es en ingles ) > Añade la carpeta de Avast software que tienes en C:\Archivos de programas.






Offline Populous

  • Advanced Poster
  • **
  • Posts: 977
Re: Problemas con Avastsvc.exe
« Reply #3 on: March 15, 2012, 09:51:03 PM »
Solo si haz comprobado que tu avastsvc.exe esta limpio por VT.

Abres Avast > Escudo de sistema de archivos > Opciones avanzadas > Exclusiones > Añadir.  Buscas la carpetas de Malwarebytes' y la añades. Click Aceptar

Escudo de web > Opciones avanzadas > Exclusiones > URLs a excluir > Añadir. Copia/Pega   " *.mbamupdates.com " sin las comillas. Click Aceptar

Escudo de comportamiento > Opciones avanzadas > Procesos de confianza > Añadir.
direccion completa de estos procesos:

\mbamgui.exe
\mbamservice.exe

Click Aceptar.

Abre MBAM > Lista para ignorar o exclusiones ( no se porque el mio es en ingles ) > Añade la carpeta de Avast software que tienes en C:\Archivos de programas.

@Iroc9555:

Creo que es al revés...

No es que AVAST detecte a MBAN como amanaza sino que es MBAN quien detecta un proceso de AVAST como amenaza...

¿No habría que hacerlo al revés? Es decir, ¿Añadir los procesos de Avast dentro de las exclusiones de MBAN cuando tenga la certeza de que están limpios en lugar de añadir MBAN a las exclusiones de Avast?  :o Creo que me he liado un poco ::) ;D
Avast Premium Security 20.2.2401 (compilación 20.2.5130.565) |CPU: Intel(R) Core(TM) i7-8700 CPU @ 4,06GHz, 6 procesadores principales, 12 procesadores lógicos | RAM: 32GB -DDR4-2666 | T.Gráfica: GeForce GTX 1060 | SO: Win 10 Pro Versión 1909 Build (18363.752) - 64 Bits

iroc9555

  • Guest
Re: Problemas con Avastsvc.exe
« Reply #4 on: March 15, 2012, 10:04:10 PM »
Populous.

Las exclusiones son mutuas y recomendadas en el foro de MBAM. Aunque yo nunca he tenido problemas con los dos, yo lo he hecho asi por si acaso.

Tambien lo que mas se ve es Avast! detectando mbamswissarmy.sys que es un archivo flotante, como yo los llamo, que es cuando MBAM se actualiza. Este archivo se comporta como avast.setup y es que no esta en tu ordenador al menos que el programa se este actualizando.

De F&Q de MBAM ve la seccion K

http://forums.malwarebytes.org/index.php?showtopic=10138
« Last Edit: March 15, 2012, 10:08:52 PM by iroc9555 »

Offline Populous

  • Advanced Poster
  • **
  • Posts: 977
Re: Problemas con Avastsvc.exe
« Reply #5 on: March 15, 2012, 10:13:24 PM »
Populous.

Las exclusiones son mutuas y recomendadas en el foro de MBAM. Aunque yo nunca he tenido problemas con los dos, yo lo he hecho asi por si acaso.

Tambien lo que mas se ve es Avast! detectando mbamswissarmy.sys que es un archivo flotante, como yo los llamo, que es cuando MBAM se actualiza. Este archivo se comporta como avast.setup y es que no esta en tu ordenador al menos que el programa se este actualizando.

Pues la primera vez que oigo hablar de eso! Yo siempre que he tenido problemas con algún antivirus y un programa en concreto lo excluyo en el antivirus y no en los dos sitios, pero supongo que es para tener más seguridad de que no intefiera una con el otro no? ...

Respecto al MBAN y AVAST no sé decirte porque al igual que tú, nunca he tenido problemas con los dos programas instalados conjuntamente.

Pero vamos, creo que es más acertada tu indicación porque así nos aseguramos que ni el programa A interfiere en el programa B ni viceversa!

Gracias de nuevo! Como decía mi abuela... "Todos los días se aprende algo nuevo!" :)

Quote
Tambien lo que mas se ve es Avast! detectando mbamswissarmy.sys que es un archivo flotante, como yo los llamo, que es cuando MBAM se actualiza. Este archivo se comporta como avast.setup y es que no esta en tu ordenador al menos que el programa se este actualizando.

Ya, me imagino que se descarga a la carpeta temporal del sistema (%temp%) y una vez hecha la actualización se elimina.. Tampoco lo sabía!  :'( Me vas a terminar deprimiendo! .... ;D

Saludos y a ver que nos responde Papasito!
« Last Edit: March 15, 2012, 10:15:53 PM by Populous »
Avast Premium Security 20.2.2401 (compilación 20.2.5130.565) |CPU: Intel(R) Core(TM) i7-8700 CPU @ 4,06GHz, 6 procesadores principales, 12 procesadores lógicos | RAM: 32GB -DDR4-2666 | T.Gráfica: GeForce GTX 1060 | SO: Win 10 Pro Versión 1909 Build (18363.752) - 64 Bits

iroc9555

  • Guest
Re: Problemas con Avastsvc.exe
« Reply #6 on: March 15, 2012, 10:22:35 PM »
Bueno todo esto es un poquo fuera de tema, OT, pero al mismo tiempo instructivo. Yo excluyo programas de seguridad, y mas aun los analizadores, porque asi cuando uno este analizando el otro que tambien, vamos a decir ve o chequea lo que el otro hace, no de falsos/ positivos ( F/P ). A ti no te a pasado que estas haciendo un barrido con un antispyware y Avast! detecta un troyano o virus o viceversa.

Offline Populous

  • Advanced Poster
  • **
  • Posts: 977
Re: Problemas con Avastsvc.exe
« Reply #7 on: March 15, 2012, 10:36:26 PM »
Bueno todo esto es un poquo fuera de tema, OT, pero al mismo tiempo instructivo. Yo excluyo programas de seguridad, y mas aun los analizadores, porque asi cuando uno este analizando el otro que tambien, vamos a decir ve o chequea lo que el otro hace, no de falsos/ positivos ( F/P ). A ti no te a pasado que estas haciendo un barrido con un antispyware y Avast! detecta un troyano o virus o viceversa.

Pues si te soy sincero... NUNCA!  :o

De hecho sólo he tenido problemas con 2 software de seguridad.. Avast y Zone Alarm.

Como instalara Avast y luego el Zone Alarm FREE el PC directamente no arrancaba... En el booting se quedaba "muerto" no llegaba ni a cargar el escritorio de windows... Solución: Arrancaba en modo seguro, desinstalaba ZA y ya el equipo volvía a arrancar perfectamente. Sin embargo a un amigo le instalé AVAST FREE 6 y ZONE ALARM FREE y el pc arrancó sin problemas.. :o

Con antispywares nunca me ha pasado. De hecho llevo años usando MBAN y antes usaba el AD-AWARE PRO. Pero te digo, con la combinación que uso ahora (AVAST FREE, MBAN, y PCTOOLS FIREWALL) el equipo me va muy bien,  no se ralentiza y no interfiere ninguno con otro.

Supongo también que dependerá de la configuración del sistema, versión del OS, etc etc pero te digo yo con eso, jamás he tenido un sólo problema.

De hecho esta misma tarde hice un análisis completo con MBAN de todo el sistema y no encontró nada ni AVAST me detectó nada raro y no tengo MBAN en las exclusiones de AVAST ni viceversa pero supongo que el que fallen o entren en conflicto uno con el otro dependerá de muchas cosas y no sólo de que estén instalados conjuntamente...

Es como el ejemplo que pusiste antes mientras MBAN se actualiza... A mi por ejemplo nunca me ha saltado AVAST mientras actualizo MBAN y lo acabo de actualizar hace unos minutos cuando me comentaste lo del fichero mbamswissarmy.sys.

¿Por qué a mi no me produce ningún conflicto y a otros usuarios si?

Pues vete tu a saber por qué! Habría que coger a los ingenieros de Avast y a los de MBAN y que se sentaran juntos a "investigar". Sin duda es un tema intesante a debatir!  A ver si a algún otro le ha ocurrido algo parecido con algún antivirus que entre en conflicto con un antispyware y lo comenta por aquí!  Así aprendemos todos de todos un poco más :)

Saludos!
« Last Edit: March 15, 2012, 10:38:35 PM by Populous »
Avast Premium Security 20.2.2401 (compilación 20.2.5130.565) |CPU: Intel(R) Core(TM) i7-8700 CPU @ 4,06GHz, 6 procesadores principales, 12 procesadores lógicos | RAM: 32GB -DDR4-2666 | T.Gráfica: GeForce GTX 1060 | SO: Win 10 Pro Versión 1909 Build (18363.752) - 64 Bits

papasito

  • Guest
Re: Problemas con Avastsvc.exe
« Reply #8 on: March 18, 2012, 10:48:48 AM »
Ante todo muchas gracias por toda vuestra ayuda.
Siento mucho haber desencadenado tanto trabajo por mi culpa, aunque he de reconocer que esto es muy raro, porque vereis...
Tengo la misma configuración en un portatil y no hay problema. Pensé que como el portatil era más moderno la instalación del Avast también lo sería y efectivamente: La instalación del fijo estaba en directorios de Alwill y de Avast5 cosa que en la actual ya no se utiliza.
Bueno he puesto en práctica lo que habeis dicho:
-He escaneado "avastsvc.exe en la página virustotal
-He bajado los dos programas en sus últimas versiones desde sus páginas originales.
-He desinstalado primero avast y después malwarebytes.
-He pasado el desinstalador de avast.
-He comprobado que no quedaba rastro ni en "Archivos de Programa" ni en Program Data".
Me he tomado un respiro.
-He instalado primero Avast 7 y después Malwarebytes.
TODO SEGUÍA IGUAL. Cádavez que accedía a internet y Avast intentaba analizar la página me daba error.
La solución incluirlo en los ignorados de Malwarebytes y...
PROBLEMA SOLUCIONADO.

iroc9555

  • Guest
Re: Problemas con Avastsvc.exe
« Reply #9 on: March 18, 2012, 04:45:22 PM »
Ante todo muchas gracias por toda vuestra ayuda.
Siento mucho haber desencadenado tanto trabajo por mi culpa, aunque he de reconocer que esto es muy

De nada un placer. Tampoco tienes que culparte de nada puesto que los que participamos aqui solo buscamos solucionar los problemas y aprender mas.

Bueno he puesto en práctica lo que habeis dicho:
-He escaneado "avastsvc.exe en la página virustotal
-He bajado los dos programas en sus últimas versiones desde sus páginas originales.
-He desinstalado primero avast y después malwarebytes.
-He pasado el desinstalador de avast.
-He comprobado que no quedaba rastro ni en "Archivos de Programa" ni en Program Data".

Eso es bueno, pero deberias de haber pegado el enlace de VT aqui para comparar el SHA y MD5 de tu archivo detectado a lo que uno tiene.

https://www.virustotal.com/file/4718d9158aeaf648bf544bd7f72b0fac56ff5920e0161ec0519b2b950ad3b3d3/analysis/1332083524/

-He instalado primero Avast 7 y después Malwarebytes.
TODO SEGUÍA IGUAL. Cádavez que accedía a internet y Avast intentaba analizar la página me daba error.

Vez esto es informacion nueva " Cádavez que accedía a internet y Avast intentaba analizar la página me daba error ". No habias dicho eso en tu topico original. Solo decias que MBAM detectaba avastsvc.exe como peligroso:

Estoy teniendo problemas con Avastsvc.exe ya que el programa "Malwarebytes Anti-Malware" lo detecta como potencialmente peligroso y para el proceso.

Primero. Puedes decirnos que pagina Avast! intenta analizar y que error te da.
Segundo. Si ya borrastes los logs de MBAM. Pudieras eliminar las exclusiones que hicistes para que se reproducieran los errores o detecciones de Avast! y MBAM y postearlas aqui para verlos. Ej Abres MBAM click Logs ( reportes ) de proteccion y copias el ultimo que tenga un error o deteccion ( puedes borrar el nombre de tu PC y el tuyo para mayor privacidad ) aqui. Ve el anexo.

papasito

  • Guest
Re: Problemas con Avastsvc.exe
« Reply #10 on: March 19, 2012, 08:50:18 AM »
Bueno pues, a pesar de haber incluido el fichero "AvastSvc.exe" en la lista de los ignorados sigue diciendome el Malwarebytes que ha parado el proceso.
He parado un momento y creo que lo que está haciendo Makwarebytes es simplemente "su trabajo" igual que "AvastSvc".
El log de Malwarebytes contiene líneas como esta:
2012/03/19 08:19:58 +0100   FIJO   jr   IP-BLOCK   199.80.55.135 (Type: outgoing, Port: 65092, Process: avastsvc.exe)
A ver si lo que me sale es porque Avast monitoriza la entrada en una página sospechosa y Malwarebytes la bloquea lanzandome el mensaje siguiente:
"Bloqueado con éxito el acceso a un sitio web potencialmente malicioso: 199.80.55.135
Tipo: Salientes
Puerto:65092
Proceso:AvastSvc.exe
Pero lo extraño es que en el portatil que tengo la misma configuración Malwarebytes como si no existiera.
Extraño, muy extraño. Aunque se que no existen las cosas extrañas sino procesos o configuraciones que se han hecho mal.
De todas formas gracias.

iroc9555

  • Guest
Re: Problemas con Avastsvc.exe
« Reply #11 on: March 19, 2012, 01:24:45 PM »
Ahora si entiendo.

No es que Avast! y MBAM estan interviniendose. Si no que MBAM esta bloqueando ese IP y el proceso que trata de comunicarse a ese IP es avastsvc.exe. Bueno, es normal que sea Avast! el que lo haga porque Avast! hace el trabajo de un proxy para poder escanear con su escudo de web y network tu navegacion en la web y conexiones en la net. El problema es que tu ordenador ( NO AVAST! ) quiera comunicarse constantemente con ese IP que MBAM lo considera malicioso. El IP pertenece a una compañia de servidores en USA:

http://webdetail.org/ip/199.80.55.135

Puede ser un falso/positivo de MBAM. Pude ser un programa que tengas que use esos servidores, o puede ser que estes infectado o tuvistes una infeccion y esta quiere comunicarse de nuevo usando esos servidores y MBAM esta parando la comunicacion.

La unica forma de saber es abriendo un topico en los foros de MBAM en la seccion F/P y preguntar porque MBAM bloquea ese IP. El unico problema es que es en ingles.

http://forums.malwarebytes.org/index.php?s=a3666871ef607c18230d9ed05ee372db&showforum=42

Espero que sea un F/P. Suerte.
« Last Edit: March 19, 2012, 01:27:06 PM by iroc9555 »