Author Topic: Cannot connect to antivirus engine  (Read 15348 times)

0 Members and 1 Guest are viewing this topic.

Offline dunkelheit

  • Newbie
  • *
  • Posts: 2
Cannot connect to antivirus engine
« on: April 10, 2012, 03:59:48 PM »
Hi,

I've encountered the same error as reported by the OP.

I just installed Avast on my Mac for the first time, and got the following:
NOT SECURED
Cannot connect to antivirus engine. Close and re-open the Avast! application to repair the antivirus components.

There is no avastscript*.log file in my /tmp directory, however, there are avastinstscript*.log and avastinstusrscript*.log, so I have included those.

The daemons for Avast seem to be running properly, but the GUI doesn't seem to be able to interact with them.

My /var/log/system shows:
Code: [Select]
Apr  5 17:44:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 122nd try. No such file or directory [2]
Apr  5 17:45:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 152nd try. No such file or directory [2]
Apr  5 17:46:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 182nd try. No such file or directory [2]
Apr  5 17:47:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 212nd try. No such file or directory [2]
Apr  5 17:48:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 242nd try. No such file or directory [2]
Apr  5 17:49:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 272nd try. No such file or directory [2]
Apr  5 17:50:08 nemesis avast![2602]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 2nd try. No such file or directory [2]

My Mac is running OSX 10.7.3.

Thanks.

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: Cannot connect to antivirus engine
« Reply #1 on: April 10, 2012, 04:24:34 PM »
Hi,

I've encountered the same error as reported by the OP.

I just installed Avast on my Mac for the first time, and got the following:
NOT SECURED
Cannot connect to antivirus engine. Close and re-open the Avast! application to repair the antivirus components.

There is no avastscript*.log file in my /tmp directory, however, there are avastinstscript*.log and avastinstusrscript*.log, so I have included those.

The daemons for Avast seem to be running properly, but the GUI doesn't seem to be able to interact with them.

My /var/log/system shows:
Code: [Select]
Apr  5 17:44:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 122nd try. No such file or directory [2]
Apr  5 17:45:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 152nd try. No such file or directory [2]
Apr  5 17:46:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 182nd try. No such file or directory [2]
Apr  5 17:47:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 212nd try. No such file or directory [2]
Apr  5 17:48:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 242nd try. No such file or directory [2]
Apr  5 17:49:42 nemesis avast![2413]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 272nd try. No such file or directory [2]
Apr  5 17:50:08 nemesis avast![2602]: av_perform_open: /Library/Application Support/avast/master connect() failed for the 2nd try. No such file or directory [2]

My Mac is running OSX 10.7.3.

Thanks.

Hallo,
please, open terminal window (applications/utilities), and type here:
ps -laxwww | grep MAD
... and paste the output here. Do the same one minute later, and also paste here.

pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)

Offline nickeb

  • Newbie
  • *
  • Posts: 1
Re: Cannot connect to antivirus engine
« Reply #2 on: April 12, 2012, 12:30:39 PM »
am having exactly same warning
here are my two results entering   in terminal

ps -laxwww | grep MADps -laxwww | grep MAD
result 1   506 39588 39582     4006   0  31  0  2434892    544 -      S+   ffffff800d585880 ttys000    0:00.00 grep MAD
 result 2  506 39607 39582     4006   0  31  0  2425480    188 -      R+   ffffff801a3e1b80 ttys000    0:00.00 grep MAD



Offline kubase

  • Newbie
  • *
  • Posts: 2
Re: Cannot connect to antivirus engine
« Reply #3 on: April 21, 2012, 11:18:45 PM »
I have solved this problem with a workaround, Avast cannot access to "/Library/Application\ Support/Avast" folder because "Avast" folder has upper "A" and Avast engine is looking for "/Library/Application\ Support/avast".

On /Library/Application\ Support/ I have made a softlink

sudo ln -s Avast avast

It works for me.


Offline Sperry23

  • Newbie
  • *
  • Posts: 1
Re: Cannot connect to antivirus engine
« Reply #4 on: April 22, 2012, 12:27:39 AM »
I'm having the same problem. Unlike Kubase, I cannot access the Avast folder to change the capital A to a lowercase a.

Another thing, the update feature just hangs up. I don't see any reason to keep this program on my Mac.

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: Cannot connect to antivirus engine
« Reply #5 on: April 29, 2012, 12:26:18 AM »
I'm having the same problem. Unlike Kubase, I cannot access the Avast folder to change the capital A to a lowercase a.

Another thing, the update feature just hangs up. I don't see any reason to keep this program on my Mac.

Shouldn't appear anymore - was succesfully tracked down and fixed 27/4/2012. Just uypdate the virus database, asnd the new ones won't cause this kind of flaw anymore.

regards,
pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)

Offline papis

  • Newbie
  • *
  • Posts: 1
Re: Cannot connect to antivirus engine
« Reply #6 on: May 02, 2012, 04:15:27 PM »
Hi!
I have quite the same problem. My Mac (using Lion OS X) says that "PowerPC applications cannot be installed" the thing is that I am using OS X Lion, which is Intel and, of course, the last version of Avast!.
Once in the application this is the message: "Cannot connect to antivirus engine".

I would appreciate your help!

Offline happytombee

  • Newbie
  • *
  • Posts: 1
Re: Cannot connect to antivirus engine
« Reply #7 on: May 03, 2012, 12:01:09 AM »
Hi,

same on my MAC. No connection to the database. Changing the "A" of avast to "a", all icons are green and the APP runs as desired. But no update can be done. Changing the "a" of the avast directory to "A", all icons are orange, updates can be done and the APP seems to work, because in the charts you can see it working and scanning during internet-use.
Changing user rights of the directory leads to a repair mechanism starting the APP.

APP version and virus definitions are up to date! OS X Lion, MB Pro.

Strange thing so far.
I like the APP, but these problems too much for normal users...

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: Cannot connect to antivirus engine
« Reply #8 on: May 03, 2012, 12:51:22 PM »
Hi,

same on my MAC. No connection to the database. Changing the "A" of avast to "a", all icons are green and the APP runs as desired. But no update can be done. Changing the "a" of the avast directory to "A", all icons are orange, updates can be done and the APP seems to work, because in the charts you can see it working and scanning during internet-use.
Changing user rights of the directory leads to a repair mechanism starting the APP.

APP version and virus definitions are up to date! OS X Lion, MB Pro.

Strange thing so far.
I like the APP, but these problems too much for normal users...

Hallo,
1) which "last" version of avast - build 36770? installed over previous version, or from scrath to clean (no avast there) /Applications?
2) don't manipulate with filenames in general - maybe it's an issue with (non-default) case-sensitive variant of HFS+, we'll test this as the first clue.

regards,
pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)

Offline ChaithraNag

  • Newbie
  • *
  • Posts: 1
Re: Cannot connect to antivirus engine
« Reply #9 on: May 04, 2012, 02:00:15 PM »
 :) ;) :D ;D

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: Cannot connect to antivirus engine
« Reply #10 on: May 04, 2012, 02:19:46 PM »
:) ;) :D ;D

Problem identified, fixed GUI will be available with the very next refresh. It's bound to case-sensitive variant of HFS+ filesystem, when used as rot partition for MacOS (by default all installations are case-insensitive).

Solutions:
- go to "/Library/Application Support" and create link, named "avast", pointing to "Avast" (as admin). the same for ~/Library/Application Support" in your home directory, if necessary
- or, wait for next program refresh (few days)
- or, use standard filesystem configuration (HFS+ case insensitive, recommended)

sorry for the inconvenience, and thanks for your reports,
regards,
pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)

Offline goddessmother1

  • Newbie
  • *
  • Posts: 2
Re: Cannot connect to antivirus engine
« Reply #11 on: May 15, 2013, 10:33:25 AM »
I have the same problem and I can't understand how to create a link to solve the problem. 

I have been using Avast for a year.  I re-registered yesterday which was confirmed.  Everything ran smoothly until today. 

Something happened that caused my MacBook Pro to shut down.  When I rebooted the computer, I got the error message YOU ARE NOT PROTECTED.  Cannot connect to virus engine error 7005.

So I shut the application, and restarted it with the same result.  Then I rebooted the computer into the rescue system and repaired the disk and the permissions.  There was a loose fragment on the disk which the Disk Utility successfully repaired.  After repairing the permissions, I rebooted the computer and opened Avast with the same error messages.  So I uninstalled and reinstalled it again.  Still no change. 

So I found the name in library/application support, and changed it to a lower case "avast" but nothing changed.  So I changed it back to an upper case "Avast." 

I opened the terminal and typed in: ps -laxwww | grep MAD
Last login: Wed May 15 00:09:18 on console
Robins-MacBook-Pro:~ robinsunbeam$ ps -laxwww | grep MAD
Robins-MacBook-Pro:~ robinsunbeam$

So I typed it in again and got:
  502  2268  1662     4006   0  31  0  2434892    552 -      R+   ffffff800bc6f000 ttys000    0:00.00 grep MAD

And again:
   502  2268  1662     4006   0  31  0  2434892    552 -      R+   ffffff800bc6f000 ttys000    0:00.00 grep MAD
-bash: 502: command not found

I don't get it.  Please help me get Avast back going again.