Author Topic: Avast 2014 Free Antivirus blocking web traffic  (Read 6833 times)

Offline Pointy

  • Newbie
  • *
  • Posts: 4
    • Personal Message (Offline)
Avast 2014 Free Antivirus blocking web traffic
« on: December 19, 2013, 01:41:00 AM »
Did a fresh install of Windows 7 Pro 64 bit.  Installed Avast 2014 Free Antivirus. 

With the web shield on, most websites and downloads don't work, such as: websites viewed in Firefox and IE, Windows Update, and Samsung Magician update.
Avast generates no errors or popups.  Downloads will either appear to start or not start and get stuck on some percentage.  Web sites will only partially load or not load at all.

With the shield off, everything works fine.  Is this a problem with the latest update, or something else?

Update:  The December 20th emergency patch seems to have fixed my problem.  :)
« Last Edit: December 22, 2013, 02:47:28 AM by Pointy »

Offline olddog

  • Poster
  • *
  • Posts: 567
  • Gender: Male
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #1 on: December 19, 2013, 02:31:22 AM »
Did a fresh install of Windows 7 Pro 64 bit.  Installed Avast 2014 Free Antivirus.

Would help to clearly identify the version installed, was it 2014.9.0.2008 or the current version 2014.9.0.2011.  If not the latter you could try updating to that.

If there was a previous AV system installed, did you use the manufacturers uninstallation and clean up utility to completely remove it before you installed Avast.

Quote
With the shield off, everything works fine.

I would suggest you try turning the webshield back on, and then try disabling the Avast Online Security extension in Firefox. If that works, it may be a problem with the AOS itself, or with it's settings blocking tracking. Some web sites will not provide their full features if you block tracking.

If disabling the AOS in Firefox works, you can also disable it in Internet Explorer.
At least then you will then have the protection of the web shield.
3.4Ghz Intel i7, 8Gb Ram, GeForce GTX560, Win 7 Pro 64 bit, Dual 1920x1080 monitors, Avast 2014, Firefox 26, Malwarebytes Pro, Paragon 14

Offline Pointy

  • Newbie
  • *
  • Posts: 4
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #2 on: December 19, 2013, 05:39:59 AM »
It was the latest one, the 2011 I think.  There was no previous AV.
I tried disabling the extension in Firefox and it had no effect.

I am using a SSD if it matters.  Maybe something to do with the temp directory like I've read in other posts?

Offline Zdenek

  • avast! team
  • Newbie
  • *
  • Posts: 17
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #3 on: December 19, 2013, 06:14:54 AM »
Hallo, we have discovered an issue in new WebShield implementation. This is probably reason of your problems. We are preparing fix for that.

Meanwhile you can try to switch to old WebShield implementation. To do that, please

Go to C:\programdata\avast software\avast directory

Find the WebShield.ini, file and add following lines:
 
[General]
UseStreamFilter=0
 
Now restart „avast! Antivirus“ service, or reboot.


Please let us to know if the problem is gone.
« Last Edit: December 19, 2013, 08:31:54 AM by Zdenek »

Offline abruptum

  • Poster
  • *
  • Posts: 588
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #4 on: December 19, 2013, 06:48:31 AM »
@Zdenek
Is this issue in new Web Shield implementation a reason for problems with CCleaner ?

  http://forum.avast.com/index.php?topic=143039.0

Offline Ruebenroder

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #5 on: December 19, 2013, 07:26:07 AM »
Zdeneks Solution works for me. :)
Added
[General]
UseStreamFilter=0
at the bottom of WebShield.ini.
rebooted,
Webshield is active, Issue is gone.

Thank You

Offline Zdenek

  • avast! team
  • Newbie
  • *
  • Posts: 17
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #6 on: December 19, 2013, 08:27:58 AM »
@Zdenek
Is this issue in new Web Shield implementation a reason for problems with CCleaner ?

  http://forum.avast.com/index.php?topic=143039.0

The mentioned problem is not browser or CC related, then I do not expect that these problems are connected.

Offline henri44

  • Full Member
  • ***
  • Posts: 148
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #7 on: December 19, 2013, 12:38:00 PM »
hi,
retry this morning with v 2011, ditto for blocking emails from laposte.net  >:(
deactivating agent Mail, it goes, so in this version it is the new web shield that problem with my config ... (We finally rewritten Web Shield)
back to version 2008, everything is OK :)

now new updated version of the 2014.9.0.211
I added in WebShield.ini :
 [General]
UseStreamFilter=0

and now everything is OK...and although not always the same problem   >:(

question: what is the action of this command line ?
thank you for your lighting
« Last Edit: December 19, 2013, 12:56:15 PM by henri44 »
W7 SP1 32 bits, Ram 4Go, intel core E7400, Chrome, PopTrayU, Mozilla Thunderbird portable, CCleaner, Avast free 2014.9.0.2011, uniquement protection active, Pare-Feu Windows

Offline sleepycal

  • Newbie
  • *
  • Posts: 9
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #8 on: December 19, 2013, 01:28:25 PM »
I can confirm I'm having the same problem.

Zdenek - Do you have an ETA on a fix? And can you confirm what `UseStreamFilter=0` actually does?

Thanks

Offline sleepycal

  • Newbie
  • *
  • Posts: 9
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #9 on: December 19, 2013, 01:31:58 PM »

Offline henri44

  • Full Member
  • ***
  • Posts: 148
    • Personal Message (Offline)
W7 SP1 32 bits, Ram 4Go, intel core E7400, Chrome, PopTrayU, Mozilla Thunderbird portable, CCleaner, Avast free 2014.9.0.2011, uniquement protection active, Pare-Feu Windows

Offline henri44

  • Full Member
  • ***
  • Posts: 148
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #11 on: December 19, 2013, 02:23:25 PM »
hi,
after some investigations in the folder C: \ ProgrammesData \ Avast,
there is a file EmailShield equivalent WebShield for emails and I think it is this document (configuration parameters) that is the problem ...
not too much courage for a new shift towards 2011: - \
W7 SP1 32 bits, Ram 4Go, intel core E7400, Chrome, PopTrayU, Mozilla Thunderbird portable, CCleaner, Avast free 2014.9.0.2011, uniquement protection active, Pare-Feu Windows

Offline Lord Ami

  • avast! translator
  • Full Member
  • ***
  • Posts: 156
  • Gender: Male
    • My site
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #12 on: December 19, 2013, 02:56:49 PM »
And can you confirm what `UseStreamFilter=0` actually does?

It disables new Streamfilter. I think it might be the new technology for Windows 7 and up that replaces "transparent proxy" that avast! webshield used in the past. I could be wrong tho :)

Offline Ureshi

  • Newbie
  • *
  • Posts: 7
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #13 on: December 19, 2013, 03:08:48 PM »
Same problem here avast killing all the web traffic

Added:
[General]
UseStreamFilter=0

at the bottom of WebShield.ini and now it works fine.

Please avast team fix the problem quick.

Avast 2014.9.0.2011
Windows 7 x64
« Last Edit: December 19, 2013, 03:10:40 PM by Ureshi »

Offline T-man

  • Newbie
  • *
  • Posts: 7
    • Personal Message (Offline)
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #14 on: December 19, 2013, 06:49:00 PM »
HI!

Please help me,I try to aply this solution :

[General]
UseStreamFilter=0

in win7Prox64, and when I wish to save the modification sistem said:
ACCES DENIED!

why?

Thanks...

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now