Author Topic: duplicate "clean" messages  (Read 15015 times)

0 Members and 1 Guest are viewing this topic.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re:duplicate "clean" messages
« Reply #15 on: January 03, 2005, 09:44:26 PM »
What settings do you have in you mail client? POP3 and SMTP server names and ports, authentication ...

Thanks.
Lukas.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re:duplicate "clean" messages
« Reply #16 on: January 04, 2005, 01:47:27 AM »
Could it be since it is checking 2 email accounts, that AVAST it puts 2 messages on outgoing messages?  Just thinking out loud...  Dennis  ???

No way...
Dennis, do you have any POP3 Alert application, i.e., when you receive a mail it says 'You've got mail' or a similar thing?
The best things in life are free.

huntsman

  • Guest
Re:duplicate "clean" messages
« Reply #17 on: January 04, 2005, 08:52:04 AM »
Hi Technical,

Sorry to say,  I thought Vlk's suggestion and my action  regarding the use of Anti Spam Apps (AnalogX..SDefender) & it's removal as I had indicated previously, had fixed the problem. It hasn't fixed it.
The problem seems to be random/intermittant.

I use IncrediMail to collect all my Emails from Hotmail & GMail as well as 2 addresses from my ISP. I also use Yahoo, but I haven't received any in a while. My ISP messages seem to be the only ones which get the "Clean" message appended, twice! I've also noticed, none of the email messages from Hotmail or GMail have the scanned...clean message appended.
I also use the IncrediMail function to announce all incoming Emails.
I use default settings in Avast except:
 1. additional file scanning of extensions in the Standard Shield
 2. ticking the Clean message box in the POP & SMTP
 3. untick the IMAP function. (I don't use it)
 4. set heuristics to high
 5. Turned Outlook/Exchange OFF (I don't use them)
 6. Turned ON all the P2P & IM XP functions.

I've also re-entered the Control Panel setup of these several times, but it hasn't helped.

That's about it.
Is there more I can provide you to help with this problem?
I advise many pensioners and support them & their PC's. I'd like to resolve this if possible, in case there's a hole which would confuse some very old users or cause them to lose confidence in their AV..

 BTW..Thanks guys for the very quick fix of the 1 Jan Registration problem.  

 :)

Just checked an email fom Yahoo and it has 2 "clean" messages as well!


--------------------------------------------------------------------------------

avast! Antivirus: Inbound message clean.

Virus Database (VPS): 0451-2, 17/12/2004
Tested on: 18/12/2004 7:32:13 AM
avast! is copyright (c) 2000-2003 ALWIL Software.
 



--------------------------------------------------------------------------------

avast! Antivirus: Inbound message clean.

Virus Database (VPS): 0451-2, 17/12/2004
Tested on: 18/12/2004 7:32:13 AM
avast! is copyright (c) 2000-2003 ALWIL
 
« Last Edit: January 04, 2005, 09:36:10 AM by huntsman »

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re:duplicate "clean" messages
« Reply #18 on: January 04, 2005, 09:52:12 AM »
Please insert the line
Log=20
to file C:\Program Files\ALWIL Software\Avast4\Data\avast4.ini under [MailScanner] for detailed logging.
Then send one mail (or retrive mail if incoming mail is the problem), which will generate the log file. After that, send me by mail the log file C:\Program Files\ALWIL Software\Avast4\Data\log\aswMaiSv.log. Thanks.

Dgc

  • Guest
Re:duplicate "clean" messages
« Reply #19 on: January 04, 2005, 10:32:54 AM »
No way...
Dennis, do you have any POP3 Alert application, i.e., when you receive a mail it says 'You've got mail' or a similar thing?

Just the Pop3 Alert that comes with Thunderbird 1.0... No external program.
From what I gather is that it only notifies me after the messages are already downloaded into the email program (and has sorted the files according to my rules)...not before...  :-\  I can turn it off... if you think that will help...

Email is set as: Acct: 1 127.0.0.1:110  POP3 / 127.0.0.1:25 SMTP
Acct: 2 pop.gmail.com:995 (SSL) / 127.0.0.1:25 SMTP


Dennis

Dgc

  • Guest
Re:duplicate "clean" messages
« Reply #20 on: January 04, 2005, 11:19:04 AM »
Well.. Well.. I think I found something out... Thunderbird gives you the option to send Email out in Either HTML or TEXT or Both.... Guess what?  I usually send out messages in DUAL format just in case people cant read HTML... SO.. After several tests... If I send a message in Both... you get 2 messages... Stupid me...  ::)
However, after I told TH to send only HTML email , it still sends out 2 messages ...
 
Here comes the log
Thanks for the help!  
Dennis

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re:duplicate "clean" messages
« Reply #21 on: January 04, 2005, 12:06:34 PM »
If I send a message in Both... you get 2 messages...

Dennis, I'll take a look but when I send in 'both' I have only message added to Inbound and only one message added to Outbound mail.
It seems to be other thing which is causing the annoyance  :-\
The best things in life are free.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re:duplicate "clean" messages
« Reply #22 on: January 04, 2005, 12:45:14 PM »
Hi Dennis,
it would be very helpfull to know the name of the process with PID 228 (if you have not already restarted since the time you generated the log file). It can be determined from the task manager, or you can download and run this command line utility http://www.sysinternals.com/files/pslist.zip.

Run the Command Prompt window and the enter:
pslist >c:\processlist.txt

and then please send me the resulting file processlist.txt.

It will help us understand what is happening there.
Thanks a lot,
Lukas.

Dgc

  • Guest
Re:duplicate "clean" messages
« Reply #23 on: January 04, 2005, 08:29:21 PM »
Hi Dennis,
it would be very helpfull to know the name of the process with PID 228 ...
Thanks a lot,
Lukas.

Hello, Lukas... Here you go...

THanks,
Dennis :-\

Dgc

  • Guest
Re:duplicate "clean" messages
« Reply #24 on: January 04, 2005, 08:32:39 PM »
 ;) - Had a problem uploading to forum... fixed now...
Dennis
« Last Edit: January 04, 2005, 08:35:11 PM by Dgc »

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: duplicate "clean" messages
« Reply #25 on: January 04, 2005, 11:11:25 PM »
Dennis, thanks for your logs. Unfortunately it doesn't make much sense to me now. Process with ID 228, the one which appears to send mails, is SERVICES.EXE. This process normaly hosts Event Log and Plug-n-Play services and I can hardly imagine the situation when these services would try to send mails.

Have you restarted the PC between the creation of avMaiSv.log and dennis_proccesslist.txt ? That would change the process IDs...

Lukas.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: duplicate "clean" messages
« Reply #26 on: January 04, 2005, 11:16:25 PM »
...hardly restarted since the system processes (including services.exe) show total uptime of more than 24 hours (in the log)... :-\
If at first you don't succeed, then skydiving's not for you.

Dgc

  • Guest
Re: duplicate "clean" messages
« Reply #27 on: January 05, 2005, 03:48:06 AM »
...
Have you restarted the PC between the creation of avMaiSv.log and dennis_proccesslist.txt ? That would change the process IDs...
Lukas.
Hello, Lukas... Not to my knowledge... As Vlk pointed out... my system has been running for  more than 24 hours... (according to the log) and from my knowledge that this baby stays on 24/7... only to reboot when my mouse driver decides to go south.
...
However, if I am the only one with this problem... And a easy resolve can not be found, I can live with the TURNED OFF messages...  Don't kill yourselves over this one... I like your product and I will be getting a new computer SOON (Thank you, my lovely wife!) So, I will have time to rebuild this one and see if it changes anything.
With such great support, it just makes me leaning toward purchasing the PRO version .
Happy New Year and Thanks for ALL your help  :)
Dennis

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: duplicate "clean" messages
« Reply #28 on: January 05, 2005, 10:45:16 AM »
As it seems to me this must be some kind of strange problem interrelated with ZoneAlarm. Will still trying to reproduce it here.

Anyway you might try to configure mail accounts directly (without the 127.0.0.1:25 trick). Setup your pop3 and smtp directly to mail1.telia.com (or whatever), it might help. Also disabling the autoredirect feature (in avast4.ini, section [MailScanner], AutoRedirect=0) will help (it this case you must leave the 127.0.0.1 in your accounts). But you'll loose some of the functionality (such as protection of other mail clients besides you primary Thunderbird).

L.