Author Topic: Fails to Generate Reports  (Read 4735 times)

0 Members and 1 Guest are viewing this topic.

Offline j.phillips

  • Newbie
  • *
  • Posts: 10
Fails to Generate Reports
« on: February 12, 2013, 04:34:47 PM »
I'm trying to generate some reporting tasks.  If I try to look at an infection report with the destination set to the task session or export to pdf and email the tasks fails.  In my server log I can see many instances of the following:
[2013/02/12 10:30:35.814,11192] Going to generate report 6
[2013/02/12 10:30:36.032,11192] Error -2147189176 in repGenerate: Crystal Reports ActiveX Designer-Logon failed.
[2013/02/12 10:30:36.032,11192] repGenerate() failed with error 0x00000000
[2013/02/12 10:30:36.032,11192] sqlFreeConnection with fReturnToPool=false (error handler)
[2013/02/12 10:30:36.032,11192] SQL Server connection has been destroyed...
[2013/02/12 10:30:36.032,11192] pThis->GenerateReports() failed with 0x0000A410 error

I have everything else working as it should.  The only thing special about my configuration is that my SQL server is on a different server from the actual EAS server. 

I've tried searching the forums but haven't found anyone with a similar problem that had posted a detailed fix.

Offline Che Johnson

  • Moderator
  • Full Member
  • *
  • Posts: 140
Re: Fails to Generate Reports
« Reply #1 on: February 18, 2013, 09:16:37 AM »
The SQL needs to be installed on the same machine the console is.  If not then there will be this issue since the instance of the SQL needs to be on the same machine so the database can be generated.


Offline j.phillips

  • Newbie
  • *
  • Posts: 10
Re: Fails to Generate Reports
« Reply #2 on: February 18, 2013, 08:07:20 PM »
Thanks!  I reinstalled and that fixed my issue.

Offline Che Johnson

  • Moderator
  • Full Member
  • *
  • Posts: 140
Re: Fails to Generate Reports
« Reply #3 on: February 19, 2013, 04:40:20 PM »
Great, good to hear!!