Author Topic: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!  (Read 27189 times)

0 Members and 1 Guest are viewing this topic.

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #30 on: March 21, 2013, 04:44:40 PM »
I am not saying do not use it, but registry cleaners can and do remove the wrong entries sometimes create a mess within the system

Could you screenshot the errors you are getting

I will try some repairs next

Download  Windows Repair (all in one)  from this site

Install the programme then run



Go to step 3 and allow it to run SFC



On the start repairs tab click start


Select the following  items and tick restart system when finished


REDACTED

  • Guest
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #31 on: March 21, 2013, 10:05:15 PM »
I disabled my windows firewall thinking it might be blocking all, but still didnt work.
attached is the screen shot of the error i keep getting.

Tried downloading the repair all in one from the site you said and when i try to install
from the setup it gives me the 2nd error attached and also says cannot start the setup.

Can't get it to download!!!! I am getting very frustrated. Is this fixable??
I am counting on Avast. Thats why I got the upgrade version.
« Last Edit: March 21, 2013, 10:44:54 PM by tadabass@aol.com »

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #32 on: March 21, 2013, 10:14:41 PM »
Avast sometimes does not like system restore as it messes its files

Do this prior to running windows repair

Lets reinstall Avast

Download aswClear to your Desktop.
Download the correct version of Avast 
http://files.avast.com/iavs5x/avast_free_antivirus_setup.exe
http://files.avast.com/iavs5x/avast_pro_antivirus_setup.exe
http://files.avast.com/iavs5x/avast_internet_security_setup.exe
Disconnect from the net
Uninstall Avast via control panel

  • Boot to Safe Mode.
    • Restart the computer.
    • As soon as BIOS is loaded begin tapping the F8 key until the Advanced Options menu appears.
    • Use the arrow keys to select the Safe mode with Networking menu item
    • Press Enter.
  • Run aswClear
  • In the Select Product to Uninstall dropdown choose the version of Avast that is on your system.

  • Press Uninstall
  • Once complete reboot your system to Normal Mode
  • Reinstall Avast
----------

REDACTED

  • Guest
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #33 on: March 26, 2013, 12:09:12 AM »
you never responded to my post from the other day when I sent you the error screen shots.
My computer won't install Avast because it says the error about spawning.
It won't install the repair program you told me either. Please help me know what to do next.
You can see the screen shots in my prior reply.

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #34 on: March 26, 2013, 11:43:00 AM »
You will need to fully uninstall Avast using aswClear .. Did you do that part before trying to reinstall

REDACTED

  • Guest
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #35 on: March 26, 2013, 09:39:15 PM »
Yes. I did everything you said. I uninstalled it in Safe Mode using ASWclear.
It still wont let me install Avast. It shows the spawning error.
I tried the free version and the Internet Security paid version.
Neither will install.

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #36 on: March 26, 2013, 09:56:59 PM »
I will have to forward this to the Avast team as I have never come across the spawning error before


REDACTED

  • Guest
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #37 on: March 27, 2013, 01:58:16 PM »
there is something mentioned on your forum about spawning. The person had the same error message I have. It sounds like the issue there ended up being maybe that he had another anti virus or something on it. I can't find any trace of Avast still on mine
except the setup for install. Are traces still lurking? i don't have anything else either to my knowledge. Please let me know what you find out. I'm so anxious to find out how to fix this.

Thanks.
« Last Edit: March 27, 2013, 02:01:39 PM by tadabass@aol.com »

REDACTED

  • Guest
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #38 on: March 27, 2013, 02:04:38 PM »
I did find A file named Avast software that seems to be empty in C: Program Data. Should I delete that thru
ASWclear? And could ASWCleaner or OTL be affecting the install in any way?

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #39 on: March 27, 2013, 03:29:20 PM »
Neither OTL nor AswClear should have any affect, spawning relates to the programming language used usually C++

The latest run time is available here http://www.microsoft.com/en-us/download/details.aspx?id=5555 and may be worth installing

REDACTED

  • Guest
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #40 on: March 27, 2013, 05:39:39 PM »
. I had trouble installing the Microsoft download the first time, but 2nd time it installed.w so now what do I do?

REDACTED

  • Guest
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #41 on: March 27, 2013, 05:58:52 PM »
I tried the Avast install after installing the Microsoft update and rebooting my computer,
but it still says the spawning error.

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #42 on: March 27, 2013, 07:15:38 PM »
In your programmes and features section of the control panel do you have an entry for C++ 2008 SP1 ? 
http://www.microsoft.com/en-us/download/details.aspx?id=11895

REDACTED

  • Guest
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #43 on: March 27, 2013, 07:50:31 PM »
It has:
Microsoft Visual C++ 2005 Compact Edition
Microsoft Visual C++ 2008 Redistributable - X86 9.0.3...... This is listed 3 times!
Microsoft Visual C++ 2010 X64 Redistributable - 10.0
Microsoft Visual C++ 2010 X86 Redistributable - 10.0

Do you want me to install the link you sent? Do I uninstall any of the others?




Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: VIRUS or TROJAN ON MY SYSTEM-Disabled my Avast Anti-virus!!!!
« Reply #44 on: March 27, 2013, 09:12:28 PM »
Yes install that as it is SP1 and may cure the problem