Author Topic: Firewall: autorizzazione connessioni  (Read 8307 times)

0 Members and 1 Guest are viewing this topic.

Offline Carburo

  • Newbie
  • *
  • Posts: 15
Firewall: autorizzazione connessioni
« on: July 24, 2013, 11:54:28 AM »
Buongiorno, sto provando il pacchetto Internet Security.
Ho necessità di utilizzare un servizio (che funziona su java) del banking-on-line, ma il firewall la blocca.
Java è tra le applicazioni autorizzate e funziona perfettamente.
L'help desk della banca mi dice di inserire tra le ocnnessioni autorizzate da firewall la stringa che identifica il servizio e la porta di comunicazione, nello specifico "nomeservizio.nomebanca.it:443".
Nelle impostazioni del firewall, il traffico java ha l'autorizzazione sia in entrata che in uscita con il protocollo TCP/UDP sulla porta 443. Ma non riesco a capire come inserire la stringa completa che la banca mi ha fatto avere.
Grazie,
Carburo

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4113
Re: Firewall: autorizzazione connessioni
« Reply #1 on: July 24, 2013, 09:38:11 PM »
Ciao e benvenuto,
sei sicuro di non avere attivi altri firewall? Comunque prova come suggerito e nelle regole pacchetti, pulsante che trovi accanto ad ogni applicazione controllata dal firewall di avast, inserisci l'indirizzo e la porta (vedi immagine allegata)
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline Carburo

  • Newbie
  • *
  • Posts: 15
Re: Firewall: autorizzazione connessioni
« Reply #2 on: July 24, 2013, 10:21:05 PM »
Per altri firewall, sono sicuro di no. Quello di Windows è disattivato, e pure quello del router.
Ho notato che, rispetto al tuo screenshot, avevo una sola voce "Internet Out" che però era settata: 1) solo in entrata, 2) senza indirizzo e 3) la porta 443 era segnata come porta remota.
Adesso ho sistemato le cose, e ho aperto sia la porta 443 che3 la 80, come chiede la banca. Domani mattina provo a vedere come va.
Intanto grazie mille, giogio,  per l'aiuto e la rapidità.
Devo dire che con avast mi sto trovando proprio bene. L'unica cosa che mi manca, ora, è trovare un bel manuale: quello che ho scaricato dal sito è solo una quick start guide di 36 pagine. Cercherò meglio sul loro sito.
Buona serata,
Carburo

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4113
Re: Firewall: autorizzazione connessioni
« Reply #3 on: July 25, 2013, 08:20:49 AM »
Quote
quello che ho scaricato dal sito è solo una quick start guide di 36 pagine. Cercherò meglio sul loro sito.
mi sa proprio che altri non ce ne sono...forse l'help all'interno del programma è un po meglio.

facci sapere come va con il firewall
ciao
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline Carburo

  • Newbie
  • *
  • Posts: 15
Re: Firewall: autorizzazione connessioni
« Reply #4 on: July 25, 2013, 09:04:55 AM »
Purtroppo la java mi dice che la connessione risulta tuttora impossibile. Ho verificato che gli altri firewall fossero effettivamente disabilitati. Ho anche verificatola versione di java.

Però, ho notato alcune cose, forse insignificanti:

1) Entrando nella finestra "Regole dell'applicazione" del firewall di avast, prima di aprire le regole dei pacchetti di Java, c'è una sorta di mini istogramma giallo con cinque barre crescenti a fianco di ogni applicazione: la prima barra è "Amici in uscita", la seconda "Amici in entrata/in uscita", ..., la quinta e ultima è "Tutte le connessioni".
Il Java Quick Starter Service è alla seconda barra; il Java Update Scheduler è alla terza (Internet in uscita).
Quella che ho creato come da istruzioni tua e della banca, che figura come Java Platform SE binary, Personalizzata, non ha neppure una barra evidenziata. E' corretto?

2) Dopo avere inserito le regole pacchetti personalizzate, al posto di nomeservizio.nomebanca.it è apparso l'IP 255.255.255.255.  Se non erro è un IP riservato alle comunicazioni alla propria rete locale. E' giusto che avast abbia sosituito tale IP agli indirizzo come li avevo inseriti io?

3) Ho notato che anche avast firewall service ha delle regole per i pacchetti. All'interno c'è solamente un "Internet Out - Permettere - TCP/UDP - In Uscita - [nessun indirizzo] [nessuna porta locale] Porta remota 80". Devo inserire il traffico in ingresso E IN USCITA e nella PORTA LOCALE anche qui?

Scusa le millemila domande, e anche la lunghezza del messaggio, ma l'interfaccia di avast mi mette a mio agio (molto più della suite internet security che usavo prima e che, quanto a friendlyness e trasparenza, mi lasciava perplesso) e, leggo, possibilità di settaggio e affidabilità sono nella fascia alta del mercato. Le mie capacità sono intermedie, e mi piacerebbe riuscire a capire meglio, così da poter decidere pro-avast al termine del periodo di prova.

Grazie ancora per la tua disponibilità,
Carburo

Offline Giony

  • Poster
  • *
  • Posts: 598
Re: Firewall: autorizzazione connessioni
« Reply #5 on: July 25, 2013, 10:51:04 AM »
prova:
per il punto 1) prova a variare l'istogramma e a mettere "tutte";
per il punto 2) prova a lasciare quell'indirizzo dei 255 e riaggiungi come altro inserimento i dati che ti ha dato la banca.

potresti anche provare nelle impostazioni del firewall nei criteri e poi nelle regole default di mettere "chiedi" anzichè "decidi automaticamente", e poi eliminare le regole che ti interessano per vedere se così avast non agisce automaticamente ma ti chiede regola per regola come fare con le "nuove" regole da come impostarle. Potrebbe funzionare ma anche no, in questo caso rischi di dover reimpostarti le regole che hai eliminato per fare questa prova.
Windows 10 Pro x64  -  Avast Internet Security 2016.11.2.2254  -  Mbam  -  HitmanPro  -  Ccleaner  -  Chrome

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4113
Re: Firewall: autorizzazione connessioni
« Reply #6 on: July 25, 2013, 07:23:33 PM »
2) Dopo avere inserito le regole pacchetti personalizzate, al posto di nomeservizio.nomebanca.it è apparso l'IP 255.255.255.255.  Se non erro è un IP riservato alle comunicazioni alla propria rete locale. E' giusto che avast abbia sosituito tale IP agli indirizzo come li avevo inseriti io?



prova a eseguire la ricerca dell'ip tramite il l'url (nomeservizio.nomebanca.it) qui e inserisci quello nel firewall di avast http://freelabs.info/UrlToIpOnline.aspx
ciao

ps che browser utilizzi? Se utilizzi firefox inserireri una regola anche per il plugin container di firefox..
« Last Edit: July 25, 2013, 07:26:20 PM by giogio »
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline Carburo

  • Newbie
  • *
  • Posts: 15
Re: Firewall: autorizzazione connessioni
« Reply #7 on: July 26, 2013, 02:50:37 PM »
Dunque, credo di averle provate quasi tutte.
Ho fatto come mi hai suggerito: l'IP inserito in quel modo resta come impostazione. Però, non è bastato.
Sono andato avanti pèer gradi. Ho anche aggiunto porte che, secondo il log di avast, erano state chiamate da java me che avasst aveva bloccato. Ho pure tentato con l'opzione che fa sì che avast mi chieda di volta in volta cosa fare e, per ultimo, ho provato ad autorizzare tutto il traffico Java.
Tuttavia ogni volta ricevevo lo stesso messaggio di errore (impossibile connettersi). Java, però, con altri siti funziona.
Se disabilito il firewall di avast tutto va alla meraviglia. Idem con il firewall di Windows.
Sono due giorni che provo e riprovo. Anche se comprendo perfettamente che è colpa mia, e che i corretti settaggi lo farebbero andare, non posso pensare di perdere altro tempo. Anche perchè ogni volta che cambio impostazioni (es. quella di far chiedere se autorizzare o no una certa applicazione) sparisce tutto il set di regole che avevo impostato, che a forza di aggiungere roba era arrivato a una quindicina di righe, e devo quindi riscrivere tutto. Ecco, se dovessi esprimere un parere, direi che l'ozione di esportazione dei settaggi permetterebbe di non doversi arrabbiare (oltre a essere utile per chi intende usare le stesse impostazioni su più computer).
Comunque, penso che avast non faccia per me. O, meglio, installerò l'AV in prova, anzichè l'Internet Security, e lascerò fare il lavoro al firewall di Windows (per quel che ne è capace!). Pazienza.
Giogio, ti ringrazio per l'aiuto,
Carburo

Offline Giony

  • Poster
  • *
  • Posts: 598
Re: Firewall: autorizzazione connessioni
« Reply #8 on: July 26, 2013, 03:09:57 PM »
hai provato nelle impostazioni>esclusioni globali>url a mettere l'url della banca con l'asterisco finale in questo modo:  www.sitobanca.it/*
poi nel percorso file proverei a mettere il percorso della cartella di java (non so dove esattamente è in xp):  c:\programmi\java\*

Per esportare/importare le impostazioni devi andare impostazioni>manutenzioni e qui fare il backup e ripristino.
Windows 10 Pro x64  -  Avast Internet Security 2016.11.2.2254  -  Mbam  -  HitmanPro  -  Ccleaner  -  Chrome

Offline Carburo

  • Newbie
  • *
  • Posts: 15
Re: Firewall: autorizzazione connessioni
« Reply #9 on: July 26, 2013, 05:32:16 PM »
FUNZIONAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Oltre all'url della banca con l'asterisco, ho dovuto inserire anche la stringa "http:\\applicazione.sitobanca.it/*" per ciascuna delle due applicazioni che la banca utilizza via Java.
Siccome non andava ancora, ho reinserito di nuovo tutti i collegamenti (la quindicina di righe che erano sparite), ho messo gli IP della banca tra gli "amici", ho fatto per fare il backup delle preferenze e... i collegamenti sono di nuovo spariti. Ho provato a dire ad avast che tutte le connessioni via Java sono affidabili e... si è collegato senza dare messaggi di errore.

A questo punto il problema sembra risolto, ma non so più quel'è l'elemento deterrminante  e, soprattutto, se a forza di smanettare non ho abbassato la guardia. In altre parole: va, ma non so perchè e se sono protetto.

Comunque, intanto grazie mille e vediamo come andrà nei prossimi giorni.
Carburo


Offline Giony

  • Poster
  • *
  • Posts: 598
Re: Firewall: autorizzazione connessioni
« Reply #10 on: July 26, 2013, 08:48:27 PM »
mai arrendersi :)

non capisco perchè ti spariscono delle impostazioni: come fanno a sparirti quando fai il backup? non capisco, anch'io le uso parecchio ma non mi è mai sparito niente. E poi per rimetterle fai ripristino? ma sei sicuro di utilizzare nel ripristino lo stesso file di backup?
quando hai inserito i collegamenti hai fatto attenzione se ci fosse un tasto OK da premere?

quando metti qualcosa nelle esclusioni globali praticamente quel qualcosa viene ignorato da avast e da tutte le sue protezioni. Da una parte bisogna essere sicuri che quel qualcosa sia pulitissimo ma dall'altra ne elimina dei blocchi come nel tuo caso.

Se a forza di spippolare tra le impostazioni hai abbassato la guardia di avast lo potrei capire solo vedendole, oppure fai un check alle protezioni di avast su questo sito: http://www.amtso.org/feature-settings-check.html
Windows 10 Pro x64  -  Avast Internet Security 2016.11.2.2254  -  Mbam  -  HitmanPro  -  Ccleaner  -  Chrome

Offline Carburo

  • Newbie
  • *
  • Posts: 15
Re: Firewall: autorizzazione connessioni
« Reply #11 on: July 26, 2013, 09:22:45 PM »
Non spariscono dal file di backup. Spariscono prima di fare il backup. E' accaduto due volte delle tre nelle quali ho reinserito le regole.
La prima volta è stato perchè ho cliccato sull'istogramma, circa a metà, e avast ha autorizzato tutto il traffico con gli "Amici".
e altre due volte, invece, ho inserito le connessioni da autorizzare. Finito l'inserimento delle regole do l'ok in basso a destra. Se riapro subito la finestra delle regole pacchetti, le mie impostazioni sono lì, come le ho messe io.
Faccio il backup, non lo ripristino (per chènon ne ho necessità su questo stesso sistema operativo (lo espoterò sugli altri, quando sarà settato per benino), vado a vedere le mie impostazioni e... sono sparite. Ci trovo l'autorizzazione a tutto il traffico java. L'istogramma è passato da personalizzato (zero barre) a "tutte le connessioni" (cinque barre).
Probabilmente, a forza di smanettare ho toccato qualcosa che ha una priorità superiore alle regole impostate qui.

Alcuni dei test dei quali mi hai mandato il link sono falliti. E' bene che ci guardi un po'.

Io non mi arrendo facilmente. Ma ci sono situazioni ove la soluzione più logica può essere... l'abbandono.  Io sto al PC dieci-dodici ore al giorno per lavoro, sabato compreso. E le ore che mi ruba la manutenzione del sistema si aggiungono. Quindi, dopo un po' sono quasi obbligato a fare marcia indietro.
Grazie anche a te per l'aiuto,
Carburo