Author Topic: VERY slow loading at bootup on Win XP SP3 desktop  (Read 13882 times)

0 Members and 1 Guest are viewing this topic.

Offline jontalk

  • Newbie
  • *
  • Posts: 9
VERY slow loading at bootup on Win XP SP3 desktop
« on: August 18, 2013, 01:27:00 AM »
Just curious if anyone else using Win XP experiences Avast Free taking a couple of minutes to show in the task bar and then another few minutes to update..It also used LOTS of CPU during this process essentially blocking you from doing anything else. I used to use AVG which is a memory hog, but I'm getting tired of waiting for so long during boot up.. Any ideas would be welcome. My machine is very well maintained (defrag, scanned for spyware/malware, etc. weekly). Thanks.

Offline !Donovan

  • Web Analyst
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2220
    • The WAR Against Malware
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #1 on: August 18, 2013, 01:33:19 AM »
Hi,

My XP desktop takes about 8-12 seconds to boot and usually 2-4 seconds for avast! 8 to load into the taskbar. Specs:
HP Compaq: Windows XP Professional SP3 32-bit / Intel Pentium 4 CPU 2.80GHz / 3.25GB RAM / NVIDIA GeForce 8400GS 512MB DDR3

I also have 128gb internal storage on this computer if that helps.

~!Donovan
Familiarize Yourself! | Educate Yourself! | Beautify Yourself! | Scan Yourself!
"People who say it cannot be done should not interrupt those who are doing it."

Offline iroc9555

  • CCS, Vzla.
  • Avast Überevangelist
  • Starting Graphoman
  • *****
  • Posts: 7460
  • No soporte por PM.
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #2 on: August 18, 2013, 01:35:08 AM »
Hi jontalk. Welcome to Avast! Forums.

¿ What Avast! version ?
¿ What Spk in XP and bit ?
¿ Any other security programs running ?

tell us little about your set up; RAM, CPU.
Hernan.
Dim 9200. C2D E6600; 2.40GHz. 4GB DDR2RAM. XP Pro_86. Spk3. IE8 & FF41. Avast FREE 2015. CIS 5.12(FW/D+). MBAM Premium. MCShield. WinPatrol +. SpywareBlasterOpenDNS. uBlock. WOT. Sandboxie

Offline Cluster-Lizard

  • Jr. Member
  • **
  • Posts: 98
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #3 on: August 18, 2013, 03:06:30 AM »
Hi,

My XP desktop takes about 8-12 seconds to boot and usually 2-4 seconds for avast! 8 to load into the taskbar. Specs:
HP Compaq: Windows XP Professional SP3 32-bit / Intel Pentium 4 CPU 2.80GHz / 3.25GB RAM / NVIDIA GeForce 8400GS 512MB DDR3

I also have 128gb internal storage on this computer if that helps.

~!Donovan

128GB of internal storage sounds like you're using a SSD in which case the boot up times will be incomparably faster than somebody, for example, using an IDE 5400rpm HDD like I do

I'm using a Dell Inspiron 2.66GHz, WinXP SP3, 32MB dedicated GPU and a minimum of 1GB RAM.

Cold booting to the login page takes 45 secs but from login to desktop and the task bar Avast icon to appear depends how long I've left it on the login screen. Why? Simply because all the stuff that runs at start up I've found is best allowed to do its thing before login.

BTW I've pared the programs running at start up to an absolute minimum already so if you haven't done it yourself then that could speed up the desktop loading very noticeably.

Once logged in the Avast icon appears after about 60 secs on my machine but here's the thing, if I'm connected to the internet it takes considerably longer. Why? The automatic Avast definitions udate will start to download/install as soon as the desktop starts up. This takes, I'd guess, half the resources available and slows the desktop loading down by that amount ie. extending the time taken to 90 - 120 secs. It is pointless trying to use the laptop whilst this is going on as any program you try to run will simply be queued until the desktop is fully loaded.

Because of this whenever I do a cold boot I turn off the internet connection beforehand and allow the desktop to start loading before turning on the internet. My ISP connection takes 45 seconds to re-establish itself by which time the desktop has loaded and then any new Avast update will install faster too.

If you have automatic Windows updates enabled then you have a triple whammy on your system's resources at start up and I recommend turning it off and installing Windows updates  manually at a more convenient time. Any other automatic updates (like Adobe Reader and Flash) I do the same with too.

The only reason I haven't turned Avast's automatic updating off so that is doesn't run at start up is because it still nags you from the task bar icon to do the update and turn on automatic updates anyway.   

 


 



 


 
« Last Edit: August 18, 2013, 01:08:37 PM by Cluster-Lizard »

Offline !Donovan

  • Web Analyst
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2220
    • The WAR Against Malware
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #4 on: August 18, 2013, 03:38:46 AM »
Actually, I use an HDD. The computer is one of the better ones from 2004.

~!Donovan
Familiarize Yourself! | Educate Yourself! | Beautify Yourself! | Scan Yourself!
"People who say it cannot be done should not interrupt those who are doing it."

Offline Cluster-Lizard

  • Jr. Member
  • **
  • Posts: 98
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #5 on: August 18, 2013, 01:50:25 PM »
Well it is booting damned fast compared to my P4 2.66GHz Dell 2003 laptop, apparently not that much less well specified than your machine.

Unfortunately the available BIOS for my laptop never supported anything more than 1GB RAM. So maybe because you're able to use the full amount of RAM allowed by WinXP ie. <4GB it is what makes the difference.   

Offline jontalk

  • Newbie
  • *
  • Posts: 9
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #6 on: August 18, 2013, 07:05:44 PM »
I have no idea what version of Avast Free I'm running since I don't see any 'about' link on the interface. All I can say is it's the latest version of the 2013 program.

I am running a Win XP SP3, 32 bit machine with 3 gb RAM, 320 gb HDD, no other security programs running in the background. As I said the machine is maintained weekly to keep it running optimally. I use the latest version of Chrome in case that has any impact.

I have run index checks on the registry (CHKDSK command), defragmented the registry and my HDD analysis tool says the HD is working perfectly. Of all the anti-virus programs I've used on this machine, Avast has provided great protection but is the SLOWEST loading of any I've used. It also takes several minutes to install the virus updates.. And in case you're wondering my broadband speed is well in excess of 18 mbps. Thanks.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84922
  • No support PMs thanks
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #7 on: August 18, 2013, 07:41:21 PM »
Right click on the avast tray icon and select about avast!
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline ram1220

  • Full Member
  • ***
  • Posts: 114
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #8 on: August 18, 2013, 08:23:37 PM »
Jontalk I have been griping about this same problem since Avast 8 came out. I am running the latest free version of Avast 8. I have an AMD quad core CPU running at 3.84, 8 GB of DDR3 PC1600, an AMD Radeon HD7950 with a Sata HDD. Windows 7 64bit with very minimal items loading on boot up. All previous versions of Avast were quick to load. And I could use my computer as soon as the desktop loaded. Ever since Avast 8 Free came out I have a longer boot up time. And after the desktop loads I can not use my computer for about 1 1/2 to 2 minutes until Avast releases it from whatever it does.
 The Avast supporters here have claimed that their systems all boot fast and they don't have this problem. They claim it's not Avast. However I have tested this theory and have used Avast's uninstall program and have installed MSE just to see. My system boots much faster and is not held hostage for minutes after it boots to desktop. I then uninstalled MSE and reinstalled Avast 8 Free and the problem returned. So yes it is a problem with Avast. I feel the program is just getting too bloated. I used AVG years ago until it became bloatware. Once Avast 8 Free does its thing and releases my computer I can do what I want to for days, even weeks without any slow downs. But a cold boot causes the problem all over again. I just wish I knew why Avast 8 free hogs computers like it does so I can turn that "feature" off.

Offline !Donovan

  • Web Analyst
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2220
    • The WAR Against Malware
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #9 on: August 18, 2013, 09:43:12 PM »
Hi all,

I am running avast! 8.0.1489.

~!Donovan
Familiarize Yourself! | Educate Yourself! | Beautify Yourself! | Scan Yourself!
"People who say it cannot be done should not interrupt those who are doing it."

Offline davexnet

  • Poster
  • *
  • Posts: 536
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #10 on: August 18, 2013, 10:07:55 PM »
There used to be an option (if I remember rightly) somewhere in the avast! settings to load up
*after* the other system services.  There was a second method which involved adding a line to the avast.ini
to delay the signature update  after boot up for a specified time (2 minutes for example).

Any negatives to these ?  At first glance, seems helpful for a slower system.
AMD FX-4300 4GB DDR3
avast free 2279 (Windows XP), MBAM free

Offline Secondmineboy

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3650
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #11 on: August 18, 2013, 10:10:13 PM »
Go to the interface click Settings on the top right top.

Go to Troubleshooting and check load Avast services after system start(the fourth option from the bottom).
Windows 10 1909, 4 GB DDR3 RAM, 500 GB 5400 RPM HDD, 1366 by 768 LCD Screen, Intel Core i3 5010U Dual Core, Intel HD Graphics 5500
HUAWEI P30 Pro. Android 10

Offline ram1220

  • Full Member
  • ***
  • Posts: 114
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #12 on: August 18, 2013, 10:34:28 PM »
 I have tried both of those suggestions. They don't make a difference.

Offline davexnet

  • Poster
  • *
  • Posts: 536
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #13 on: August 18, 2013, 11:03:37 PM »
My PC is older and more modest, AMD x2 4200, 2GB DDR1 RAM.
I did a custom install, deselected the p2p and email shields, and deselected everything in the middle column.
I do find a slight drag on the system after booting but the system is still usable - I can start Firefox,
for example.

Have you tried a HDD defrag?
AMD FX-4300 4GB DDR3
avast free 2279 (Windows XP), MBAM free

Offline jontalk

  • Newbie
  • *
  • Posts: 9
Re: VERY slow loading at bootup on Win XP SP3 desktop
« Reply #14 on: August 19, 2013, 01:44:58 AM »
Interesting... I guess I forgot to mention I'm also running an AMD 4600+ dual core CPU, Radeon X1250, etc..I saw another thread which caught my eye since the OP has removed AVG like I had and provided a link to AVG's complete removal program. I installed it and let it remove any remnants, though when the system booted up again, it didn't boot completely, so I did a hard shut down and rebooted again. I do NOT recommend using the AVG removal program but I have run a search and found NO AVG remnants and removed all the trails of the removal program too. That said, it boots a little faster but not nearly like MSE or even AVG which is a resource hog when running. Avast really needs to address this on this latest version because it's boring waiting several minutes for the program to load and update.. I think the updating/installation process is WAY too slow also.

Jontalk I have been griping about this same problem since Avast 8 came out. I am running the latest free version of Avast 8. I have an AMD quad core CPU running at 3.84, 8 GB of DDR3 PC1600, an AMD Radeon HD7950 with a Sata HDD. Windows 7 64bit with very minimal items loading on boot up. All previous versions of Avast were quick to load. And I could use my computer as soon as the desktop loaded. Ever since Avast 8 Free came out I have a longer boot up time. And after the desktop loads I can not use my computer for about 1 1/2 to 2 minutes until Avast releases it from whatever it does.
 The Avast supporters here have claimed that their systems all boot fast and they don't have this problem. They claim it's not Avast. However I have tested this theory and have used Avast's uninstall program and have installed MSE just to see. My system boots much faster and is not held hostage for minutes after it boots to desktop. I then uninstalled MSE and reinstalled Avast 8 Free and the problem returned. So yes it is a problem with Avast. I feel the program is just getting too bloated. I used AVG years ago until it became bloatware. Once Avast 8 Free does its thing and releases my computer I can do what I want to for days, even weeks without any slow downs. But a cold boot causes the problem all over again. I just wish I knew why Avast 8 free hogs computers like it does so I can turn that "feature" off.