Author Topic: avast!, Thunderbird and IMAP - BTW, I did search the forum for Thunderbird :)  (Read 5358 times)

0 Members and 1 Guest are viewing this topic.

Offline volki

  • Newbie
  • *
  • Posts: 3
I just joined the forum, although I have been reading lots of posts here for the past 3 days. avast! is a great product and this forum is awesome!!!

Here is the description of what I have.
I use Thunderbird (v.1.02) and avast! (home, 4.6.652) both at the school and home. I use IMAP (port 143) and our mail server uses TLS, so I already figured that I cant use avast!'s outbound scan with this connection. I am able to use the inbound mail scan of course. Every time I launch t-bird, a small icon appears in the task bar and if I move my cursor over it, it will show the name of our mail server. So, all is fine... However, when I close t-bird most of the time (~80%), the small icon does not go away from the taskbar and t-bird keeps running in the background (not functional though). If I try to re-launch t-bird, it will crash. The only way to do it is to go into taskbar and terminate thunderbird.exe.
If I turn off inbound mail check, then everything works just fine; t-bird quits everytime I close it and no running in the background, etc...
I searched the forum on avast! and thunderbird, but could not find anything similar to my problem; I apologize in advance, if I overlooked something.
So, is there anything that I can do to avoid this little annoyance?
Thanks for any help!
V.
« Last Edit: May 07, 2005, 01:42:45 PM by volki »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
I'm not an expert on Thunderbird, but I've read here in forums that, maybe if you use it with IMAP you can go to TB Sent folder: Tools > Account Settings > Server Settings > Advanced and set "Maximum number of server connections to cache" to more than 4.
This is related to TB timeouts: http://forum.avast.com/index.php?topic=11596.msg106618#msg106618
Hope this help in anyway...  :-[
The best things in life are free.

Offline volki

  • Newbie
  • *
  • Posts: 3
Thanks for the reply.... Upon your suggestion, I set that number to something more than 4. It did not help... Then I thought "what if I set it up to "1", since sometimes putting the cursor on that little icon on the taskbar shows duplicates of the same server name. Yeap... that did the trick. Everything is working fine now (I hope it will last, though)  ;D
Cheers!

Offline sded

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1718
  • Me llamo Ed
I use avast! to scan secure imap email.  If you want to use imap with TLS, avast! will support it with the use of OpenSSL and Stunnel.  To set it up for XP, assuming you still use port 25 for TLS smtp, 

1) In your email client, set
localhost:11143 for your imap server
localhost:11025 for your smtp server
Do not check "use secure"

2) In avast! email provider add
11143 to the imap ports to redirect
11025 to the smtp ports to redirect

3) With a text editor, create Stunnel.conf (or cut/paste/edit below)
Stunnel.conf, the configuration file, looks like this for secure email:


client=yes

# IMAP service listens on localhost 11143
[xxxxx-imap]
accept=localhost:11143
connect=mail.xxxxx.com:993

# SMTP service, listens on localhost:11025
[xxxxx-smtps]
protocol=smtp
accept=localhost:11025
connect=smtp.xxxxx.com:25

Replace the xxxxx connect lines with the names and ports of your ISP secure imap and smtp servers.

You need to download and install OpenSSL from http://www.openssl.org/related/binaries.html and Stunnel from http://www.stunnel.org/download/binaries.html and install them.  Stunnel can either be installed as a windows service or added to your startup group.  Put stunnel.conf in the same folder as stunnel.
Windows 7 x64HP-SP1-No UAC, Opera 11.51, Avast! Internet Security 6.0.128, Webroot SecureAnywhere latest beta, Windows FW off, MVPS HOSTS, SAS/MBAM offline, Macrium Reflect just in case ;)

Offline volki

  • Newbie
  • *
  • Posts: 3
Thanks very much for your detailed reply! For the moment, my problem is solved by setting the "number of accounts to cache" value to 1 in Thunderbird. I am more worried about scanning incoming mail (which works great), rather than outgoing... If I feel the need to scan outgoing mail (via IMAP with TLS), I will follow your instructions...
Thanks again!

Offline sded

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1718
  • Me llamo Ed
IMAP is a protocol for accessing mail (see http://www.imap.org/about/whatisIMAP.html) not for sending it, and sending is usually done via normal or secure (SSL/TLS) smtp.  If you have secure IMAP access (SSL, normally port 993), then you need to set up Stunnel and OpenSSL to enable avast! to scan it.   If your IMAP is not secure, no problems, but am surprised that transmission is secure and access is not.
Windows 7 x64HP-SP1-No UAC, Opera 11.51, Avast! Internet Security 6.0.128, Webroot SecureAnywhere latest beta, Windows FW off, MVPS HOSTS, SAS/MBAM offline, Macrium Reflect just in case ;)

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
I've found this post:

The problem seems to be caused by Thunderbird using a special IMAP feature - downloading the messages by pieces - i.e. it doesn't download the whole message, it doesn't even download the particular attachments as whole - but it simply downloads the message cut into smaller pieces, one by one (at least I suppose so - theoretically, it may get the pieces even randomly - one here, one there...). This feature, unfortunatelly, breaks avast! scanning - the virus is not recognized from a small piece of message only.

Just to post again the special IMAP feature of TB.
The best things in life are free.

Offline sded

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1718
  • Me llamo Ed
What OS are you running?    I use TB 1.02 and IMAP without any scanning problems with XP Pro, SP2, secure through Stunnel as well as in the normal (nonsecure) mode, so it is not an inherent TB or avast! problem-haven't seen the fragmentation issue, so can't address that.   You get the persistent small icon because of the nature of IMAP access.  With IMAP, your list of folders mirrors the list on your server.  The only thing available locally is normally the subject headers (unplug your internet link to verify this).  TB maintains an open link (multiple connections) with your server until you close it, in order to be able to download and read bodies, and avast! indicates this with the small icon until you close TB.  You can move messages to local folders as usual, but can't read them in your IMAP account and scan them without the link up.  My settings that work are shown in the figures.  As far as avast! settings for advanced, redirect should show 143, ignore local communications unchecked, advanced tab as shown.  For TB, picture is for secure IMAP, but should substititute your mail server name, port 143, username, other fields as shown.  Advanced settings are as shown.  How does your setup compare? 
« Last Edit: May 09, 2005, 04:27:51 PM by sded »
Windows 7 x64HP-SP1-No UAC, Opera 11.51, Avast! Internet Security 6.0.128, Webroot SecureAnywhere latest beta, Windows FW off, MVPS HOSTS, SAS/MBAM offline, Macrium Reflect just in case ;)