Author Topic: Please Remember To Fix The Outbound Email Scanning Problem  (Read 45864 times)

0 Members and 1 Guest are viewing this topic.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #15 on: May 23, 2005, 05:41:03 PM »
Allrighty, here's another version for you to test - I made some more changes to the code.
http://www2.asw.cz/misc/ashmaisv.zip

The installation procedure of the patch is the same as described above (you don't need to set anything in the INI file this time).
Please let me know how it goes. ;)


Thanks Vlk
If at first you don't succeed, then skydiving's not for you.

hgratt

  • Guest
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #16 on: May 23, 2005, 05:59:02 PM »
My xp setup now uses NAV. I am reluctant to uninstall it at this time. However, I have a
win98se setup which I could try. I have noticed though, that the redirect tab for the Mail Service is greyed out. Is Avast outbound scanning active in win98se?

Let me know if I should try your patch on the win98se setup. Also, since I will have to reinstall Avast, and then the patch, should I put the lines back in the .ini file?

Thanks,
Harvey

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #17 on: May 23, 2005, 06:10:00 PM »
I'd say it's still worth trying on the Win98 machine, although for the sake of candour it would be best to do the test on the XP box (please please, it's just like ten minutes isn't it? ;D).
No INI changes are necessary.
If at first you don't succeed, then skydiving's not for you.

hgratt

  • Guest
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #18 on: May 23, 2005, 06:59:01 PM »
O.K., I tried it. Here are the results.

1. After uninstalling NAV 2004 and before installing Avast, I tried another test. My outbound speeds dropped from 92KBS to around 80-83KBS! Consistent with what I've seen before, but still a mystery.

2. Your patch did not fix the problem.

3. Your patch made my system unstable.


If you don't have any other suggestions, I will reinstall NAV. Please let me know as soon as you can if there's something else to try.

Thanks,
Harvey

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #19 on: May 23, 2005, 07:02:53 PM »
2. so it's still at 3x KB/s? Quite strange. On my test machine, the patch changed the speed from 220 KB/s (speed with Internet Mail provider disabled) to around 550 KB/s -- it actually more than DOUBLED the upload speed...
3. What exactly does that mean?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

hgratt

  • Guest
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #20 on: May 23, 2005, 07:06:49 PM »
With scanning enabled, the mail client seemed to stop responding (it still sent mail). The first time I tried it, it froze NetPerSec. I then rebooted and tried again - only got about 35KBS. Then when I tried to save the test mail, mozilla hung.

Thanks,
Harvey


Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #21 on: May 23, 2005, 07:20:37 PM »
...must've been because of the 100% CPU usage the new ashMaiSv.exe was using during data transfer (because of its attempt to maximize the throughput).

Here's the last version: http://www2.asw.cz/misc/ashmaisv2.zip -- if that doesn't help, I must be dreaming (because it IS changing the speeds here - and very noticably).

Thanks for your help (and I'm really sorry for the hassle - I'm getting the impression that you're now incllining to NAV anyway... :-\).

Cheers
Vlk
If at first you don't succeed, then skydiving's not for you.

hgratt

  • Guest
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #22 on: May 23, 2005, 07:45:13 PM »
...must've been because of the 100% CPU usage the new ashMaiSv.exe was using during data transfer (because of its attempt to maximize the throughput).

Here's the last version: http://www2.asw.cz/misc/ashmaisv2.zip -- if that doesn't help, I must be dreaming (because it IS changing the speeds here - and very noticably).

Thanks for your help (and I'm really sorry for the hassle - I'm getting the impression that you're now incllining to NAV anyway... :-\).

Cheers
Vlk

O'K., this IS different!

1. With scanning disabled, I still only get around 80KBS.

2. However, now, with scanning enabled I am averaging close to the 92KBS that I see with NAV 2004. However, the speed as a function of time is very "spikey" (using NetPerSec) - that is, I will see lows of around 30KBS followed by highs of around 134KBS. The average appears to be around 92KBS.

This is worth further experimenting with.

Can you elaborate on what you did and why it is working as it is?

Thanks,
Harvey

hgratt

  • Guest
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #23 on: May 23, 2005, 08:14:34 PM »
...must've been because of the 100% CPU usage the new ashMaiSv.exe was using during data transfer (because of its attempt to maximize the throughput).

Here's the last version: http://www2.asw.cz/misc/ashmaisv2.zip -- if that doesn't help, I must be dreaming (because it IS changing the speeds here - and very noticably).

Thanks for your help (and I'm really sorry for the hassle - I'm getting the impression that you're now incllining to NAV anyway... :-\).

Cheers
Vlk

O'K., this IS different!

1. With scanning disabled, I still only get around 80KBS.

2. However, now, with scanning enabled I am averaging close to the 92KBS that I see with NAV 2004. However, the speed as a function of time is very "spikey" (using NetPerSec) - that is, I will see lows of around 30KBS followed by highs of around 134KBS. The average appears to be around 92KBS.

This is worth further experimenting with.

Can you elaborate on what you did and why it is working as it is?

Thanks,
Harvey


Well, I spoke too soon. After rebooting back into win xp, I recieved a message indicating Avast had to reload my OS. I rebooted and now with scanning enabled, I'm back to the same 35KBS speeds.

Harvey

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #24 on: May 23, 2005, 08:56:43 PM »
Oh yeah, the auto-updater replaced the patched file with its original version (as a security measure).
What version of avast do you have installed, exactly? Do you have the latest one - 4.6.665?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

hgratt

  • Guest
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #25 on: May 23, 2005, 09:06:11 PM »
Oh yeah, the auto-updater replaced the patched file with its original version (as a security measure).
What version of avast do you have installed, exactly? Do you have the latest one - 4.6.665?

Thanks
Vlk


Wait, wait, wait. I thought I had the latest version - but I have 4.6.652. I redid the patch and I was back to the 92KBS (erratic) average, so the reboots must have clobbered the changes I will update to the latest version and redo the patch and get back to you.

Thanks,
Harvey

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3866
  • Just an avast user
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #26 on: May 23, 2005, 09:11:33 PM »
Vlk,

could not resist trying the lastest patch you offered to hgratt.

Interesting -

My test message has varied in delivery time only between 87-90 seconds with Avast turned off, well within the variations of Comcast - my (and hgratt's) cable provider.

With the lastest patch, from hitting send to completion the result was 100 seconds. 

Allowing for the fact that I have reported before that it is taking 8-9 seconds to create the temporary cache (in the case of Thunderbird) and less than two seconds in the case of OE, it seems to me that you have just about matched the transmisson speed of Thunderbird.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #27 on: May 23, 2005, 09:12:02 PM »
hgratt: OK, let me explain what's up.
The ZIP file (the patch) contains two files - a .DLL and a .DLL.SUM.

The .DLL is the patch itself (the binary). The .DLL.SUM is a special file that is telling the avast updater that this is an authorized patch (otherwise, it would get replaced by the original version - this is part of the defensive strategy built-into avast to fight with unauthorized changes caused by malware).

However, the authorization is bound to a specific version number. This is because when a new version is installed, we want the patch to be updated by a new version.
And, the .DLL.SUM file in this particular ZIP file is for version 4.6.665 (so you need to have this version installed for the DLL.SUM file to be effective).

Hope this helps,
Vlk
« Last Edit: May 23, 2005, 09:13:43 PM by Vlk »
If at first you don't succeed, then skydiving's not for you.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3866
  • Just an avast user
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #28 on: May 23, 2005, 09:21:06 PM »
Vlk,

the result for the same message when using OE was 92 seconds compared with 130 seconds yesterday.

So, you have made sending mail by OE scanned with Avast much faster than sending it without scanning ... you should sell it to the folks in Redmond!

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Please Remember To Fix The Outbound Email Scanning Problem
« Reply #29 on: May 23, 2005, 09:26:45 PM »
;D

There's really no rocket science here. I changed only two things:

1. increased the chunk size (the size of data sent at once) from 8KB to 128KB
2. removed the sleep command after sending each chunk.

That is, there were artificial sleeps (delays) implemented in the code - I don't know why yet (I'll have to ask the developer responsible for this code tomorrow).
It's possible they were there for a reason - but I'd say the main reason was to prevent excessive CPU loads for the ashMaiSv.exe process...

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.