Author Topic: High Memory use Avast service 104 MB  (Read 10816 times)

0 Members and 1 Guest are viewing this topic.

Offline miguelgrado

  • Poster
  • *
  • Posts: 603
  • Warrior Forospyware
    • Forospyware
Re: High Memory use Avast service 104 MB
« Reply #15 on: December 24, 2013, 02:48:12 PM »
@rnuis

The dump file is for avastSvc.exe and give it a unique name. Do not forget to give the names of the dumps sent here in the topic so that avast! tweam member know what they are looking for.

@miguelgrado.

Same for you. What is the name of the dump file you sent ?

@lukas.hasik

Any news ? This is happening to Xp and 7 alike, but not all. So it must be a program or driver. Even some hardware or setting we have in common.


miguelgrado_windows 7_avastsvc.DMP or similar
« Last Edit: December 24, 2013, 02:56:36 PM by miguelgrado »
miguel:CPU:intel core 2 quad q9400 2.7 ghz-ram 8 g ddr3 1333 mhz-grafica nvidia g force 220gt 1 g ram-SO windows 10 pro 64 bits-Internet explorer 11 y firefox latest-Seguridad:Avast Internet Security- Malwarebytes Premiun- Hitman Pro alert

Offline miguelgrado

  • Poster
  • *
  • Posts: 603
  • Warrior Forospyware
    • Forospyware
Re: High Memory use Avast service 104 MB
« Reply #16 on: December 24, 2013, 05:32:45 PM »
my avastsvc.exe in this moment
miguel:CPU:intel core 2 quad q9400 2.7 ghz-ram 8 g ddr3 1333 mhz-grafica nvidia g force 220gt 1 g ram-SO windows 10 pro 64 bits-Internet explorer 11 y firefox latest-Seguridad:Avast Internet Security- Malwarebytes Premiun- Hitman Pro alert

Offline rnuis

  • Full Member
  • ***
  • Posts: 195
Re: High Memory use Avast service 104 MB
« Reply #17 on: December 26, 2013, 11:56:59 AM »
Why doesn't anyone of Avast reply here for this problem?
Avast internet security 2015 10.0.2208 , MBAM 2.03 ,Firefox 33.03
Windows 8.1 Pro 32Bit

Offline irongod

  • Full Member
  • ***
  • Posts: 111
Re: High Memory use Avast service 104 MB
« Reply #18 on: December 26, 2013, 01:43:43 PM »
... maybe cause it's Xmas holiday!!  :P

I had the same problem in XP with 9.0.2011 mem consumption was in average from 50 to 120MB... then I returned to v8 (again) until new release is out!
You take the tarot cards and throw them to the wind!

Offline rnuis

  • Full Member
  • ***
  • Posts: 195
Re: High Memory use Avast service 104 MB
« Reply #19 on: December 26, 2013, 04:40:26 PM »
@rnuis

The dump file is for avastSvc.exe and give it a unique name. Do not forget to give the names of the dumps sent here in the topic so that avast! tweam member know what they are looking for.

@miguelgrado.

Same for you. What is the name of the dump file you sent ?

@lukas.hasik

Any news ? This is happening to Xp and 7 alike, but not all. So it must be a program or driver. Even some hardware or setting we have in common.

This is the name of my dumpfile     AvastSvc.DMP
Avast internet security 2015 10.0.2208 , MBAM 2.03 ,Firefox 33.03
Windows 8.1 Pro 32Bit

Offline rnuis

  • Full Member
  • ***
  • Posts: 195
Re: High Memory use Avast service 104 MB
« Reply #20 on: December 27, 2013, 03:21:30 PM »
Hello someone from Avast , can u help us with this please? Or give us a anwser back from Avast?
Avast internet security 2015 10.0.2208 , MBAM 2.03 ,Firefox 33.03
Windows 8.1 Pro 32Bit

Offline propheticus

  • Common sense is the best safety feature
  • Sr. Member
  • ****
  • Posts: 202
Re: High Memory use Avast service 104 MB
« Reply #21 on: December 27, 2013, 03:53:45 PM »
1. If you really need urgent help from someone at Avast you're better of opening a support ticket than posting here. The forums are primarily for users helping users and the Avast crew is not too active here (apart from announcements). 
2. It's the Christmas holiday season.


3. Have you tried an installation repair and/or a removal+ clean install?

Offline NoelC

  • Poster
  • *
  • Posts: 569
Re: High Memory use Avast service 104 MB
« Reply #22 on: December 27, 2013, 05:23:18 PM »
As with many threads, a user asks about a particular symptom, and someone else chimes in and says yeah, me too, but there's really no indication of what we SHOULD be seeing on a perfectly working system - i.e. whether it's a problem at all.  It may be designed to work that way.

How it's observed to work on other (presumably normal) systems is certainly something other users could be providing on a user-user forum (as propheticus has done).

Personally I have a big system that I virtually never reboot, and I don't normally give an application that uses a mere few hundred megabytes of RAM a second glance - that's not that much RAM in this day and age.  My AvastSvc actually at the moment it is using 361 MB.  I noticed it increased from 141 MB a few minutes after a scan completed.  I assume it needs more or less RAM for various normal operations, as most applications do.

Is it just using RAM that no one else needs?  Should it be expected to increase over time to some extent then top out.  I wouldn't think an ever-increasing RAM usage would be normal, but it wouldn't be the first application ever programmed that expects reboots from time to time - though that's quite unacceptable in this day and age of stable systems that don't normally need rebooting.

Can someone please say what we should EXPECT to be seeing with version 2014.9.0.2011, and whether using several hundred MB is actually a real problem?

FYI, I use neither the web shield or firewall components.

-Noel
« Last Edit: December 27, 2013, 05:34:16 PM by NoelC »

Offline Braver

  • Full Member
  • ***
  • Posts: 132
Re: High Memory use Avast service 104 MB
« Reply #23 on: December 27, 2013, 05:44:52 PM »
I, myself have been having some weird problems regarding this since updating to Version 9.0.2011, with version 2010 Avastsvc.exe was using around 30-40MB on startup but shortly diminished to around 3-8MB average. After computer got through most of the lengthy processes (Windows Defender scans,etc) Avast would scan or read its dat/txt files and would go up to around 30-40MB again and drop just the same, while browsing the internet or watching videos, with each page refresh it'd jump to about 20MB and drop once again. Note that this is the Working Memory (KB) that I'm referring to, not the Commit (KB) that I find by using Window 7's Resource Monitor.

Ever since updating to the current version though Avastsvc uses 50-60MB Working (KB) from the get-go and around 75-80 Commit (KB), after the usual lengthy processes (see above) it dropped to around 60MB to 8, but then starts increasing over time, after browsing the internet for about an hour it rose to around 50MB once again and did not even attempt to drop or showed no signs of dropping. It only increases, while on version 2010 it constantly rose and dropped just as quickly, but theres no sign of this whatsoever now, it only rises and shows no signs that the shields are even working, even though they are. The increases/decreases in memory are generally the way of showing the shields are doing something I thought.

/sigh not sure whats going on but this is rather annoying, I'm rather OCD about the amount of memory my processes use and this drastic a change kind of bugs me. (maybe not a massive change in memory use but still it doesn't release the memory it seems and over time that can become a problem as I can leave my computer on for extended periods of time.)

I hope this gets fixed or some kind of explanation is given as to why it now is more RAM extensive.
« Last Edit: December 27, 2013, 05:48:54 PM by Braver »

Offline NoelC

  • Poster
  • *
  • Posts: 569
Re: High Memory use Avast service 104 MB
« Reply #24 on: December 27, 2013, 11:59:20 PM »
at the moment it is using 361 MB
And now it's down to 96 MB.

Doesn't seem like a long-term leak to me.

-Noel

Offline Braver

  • Full Member
  • ***
  • Posts: 132
Re: High Memory use Avast service 104 MB
« Reply #25 on: December 28, 2013, 12:08:06 AM »
I've been looking around some and it seems every time I turn off the Mail Shield and back on the amount of memory used drops down to the minimum again, but still slowly rises over time once again.

I'm really not sure what to do, I loved Avast! and my computer was fine and stable yesterday (yesterday was when Avast told me the update was available) but now the amount of memory being used by it has grown about x5 and it makes me not want to leave my computer on for a long period of time. Not sure how to roll back down to my previous version either (I had 9.0.2010). I would rather take it back to a point where it worked but I'm not completely computer savvy about these kinds of things. :/

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: High Memory use Avast service 104 MB
« Reply #26 on: December 28, 2013, 12:20:37 AM »
There is a definite issue and hopefully, it will be fixed next build. I wouldn't advise downgrading to 9.0.2009 (9.0.2010 was a BETA release) since 9.0.2011 ironed out plenty of issues.

If you have the issue, send your memory dump...

http://forum.avast.com/index.php?topic=143372.msg1040156#msg1040156
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline NoelC

  • Poster
  • *
  • Posts: 569
Re: High Memory use Avast service 104 MB
« Reply #27 on: December 28, 2013, 12:29:00 AM »
Quote
There is a definite issue...

You've heard an official word on this?

-Noel

Offline Braver

  • Full Member
  • ***
  • Posts: 132
Re: High Memory use Avast service 104 MB
« Reply #28 on: December 28, 2013, 03:01:51 AM »
There is a definite issue and hopefully, it will be fixed next build. I wouldn't advise downgrading to 9.0.2009 (9.0.2010 was a BETA release) since 9.0.2011 ironed out plenty of issues.

If you have the issue, send your memory dump...

http://forum.avast.com/index.php?topic=143372.msg1040156#msg1040156

Dunno what to do then, I get a feeling if i leave my computer like this something will happen... it seems pretty unstable and the amount of memory being used by Avast! Service is increasing every minute or so, sometimes it even spikes up to around 10MB more.

Strange thing is... I did some testing to see which module of the antivirus was causing these spikes, by turning certain components off, turning off the service and restarting etc.

Memory went back to normal upon disabling the service and restarting, turning off the file and web shield did nothing to change anything... but when I turn off the Mail Shield and restarted it in the menu (during same PC session), the memory goes back down to a minimal amount (3~9MB) but then repeats itself by constantly rising over time. (Even when I'm not doing anything, not even browsing or anything, it just rises.)

Not sure how to get these dumps neither really, I'm generally quite good with computer problems, I generally handle them myself but I've never encountered something like this. :(
« Last Edit: December 28, 2013, 03:03:26 AM by Braver »

Offline rnuis

  • Full Member
  • ***
  • Posts: 195
Re: High Memory use Avast service 104 MB
« Reply #29 on: December 29, 2013, 02:51:01 PM »
Hello someone from Avast is there sombody out there too help us or just too anwser here?????
Avast internet security 2015 10.0.2208 , MBAM 2.03 ,Firefox 33.03
Windows 8.1 Pro 32Bit