Author Topic: Avast is locking up the PC  (Read 22632 times)

0 Members and 1 Guest are viewing this topic.

Offline BanziBaby

  • Full Member
  • ***
  • Posts: 138
  • Zeppelin Fanatic
Avast is locking up the PC
« on: October 14, 2003, 03:16:59 PM »
Hi Avast team :)

U havent heard from for a while cause i havent had any probs till the last 2 prog updates

What is happenin is just like mantra & others i have an entry in the run section of registry for ashdisp on 98se

Also, more so since the 280 update, avast will freeze the pc on startup as it is either loading or has loaded & is scanning explorer, if i ctrl+alt+delete, half the time there is nothin in the list that is not responding, i cant do anythin other than press the reset button, it also does the same on shutdown & will just sit there at the windows is shutting down screen & again i have to press reset, i have to constantly run scandisk as the pc boots cause if i run it in windows, avast locks that, also it has bad habit of lockin up opera browser(7.20final)

If i disable avast from loading(in msconfig)the problems disappear, same if uninstall it) I have tried countless times 2 reinstall it with the latest version from website, but the same happens, in fact it was gettin so bad, i  bought Mcafee virusscan 2004 (no probs with that)

Also, why has the mail protection changed, i mean this smtp authentication cause it wont let me send mail, it constantly pops up a password box & even if i leave it blank or Use my mail account password, 2 secs later it pops it up again, this is for all accounts unless i change the UseDefaultSMTP=0 to 1, then open outlook express 6 & uncheck the use smtp authentication in all my account, then terminate the mail provider & then restart it & then reboot (if on a rare occurence that avast dont lock the pc up) ??? ??? ???

I recently had 2 reformat as avast missed a virus that had started 2 delete files, so i fdisk /mbr the hd & then fdisk it 2 delete the partitions & then reformat, so all i have is win98se & all critical updates, not much loadin at startup (just kerio 2.15)

I know it is Avast causin it cause like i say if i uninstall/disable it, the faults go away & there are no lockups at all

I think in the rush to get the 280 update out, somethin else got broken as is evident by all the people postin probs here

I never ever had any probs with version 4, just version 4.1, although i am gettin to like McAfee 2004, i still want to use Avast as my main A/V as a)i have paid for the professional version & b)it isnt as resource intensive as other a/v progs, but all these little faults & bugs are kinda makin me want to think about uninstallin it for good :( :(

I sincerely hope that avast team can help me here as i still think Ur prog is the best (but these faults are makin that hard) ???

I only have the IM, standard shield, internet mail & script blockin providers runnin (i only activate the p2p one as it is needed) I dont install the outlook provider as i have absolutely no use for it

I ont mind postin any logs or anythin else that is required for U to help me, i just hope U can :)

Remember, if avast is not runnin or loaded, i have no probs & i find it strange that havin never ever had the ashdisp thing in my startup before, why has it suddenly appeared there

Thanks for any help givin & apoligies for the length of this post, i just wanted to give U as much info on the faults as possible

Cheers

BaNzI

Offline techie101returns

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1900
Re:Avast is locking up the PC
« Reply #1 on: October 14, 2003, 04:38:07 PM »
Banzi,

Wow...that was a mouthful of words!
Ok....It seems like you have suffered major disaster with AVAST.  Only joking.  Without looking at your logs, it seems apparent that AVAST has suffered some corruption of the files.  The fact that you uninstalled it may not fix things.  When its' files are badly corrupted, the usual method of uninstalling does not always remove ALL Avast files.

At this point, you need to know 2 things.
1.  AVAST does not like other anti-virus software running on the same system.  This will inherently cause problems (more so with NAV than McAfee).
2.  If you wish to use AVAST, then go to www.avast.com and download a copy of AVClear 4 which is an AVAST removal tool.  This will remove all the remnants of AVAST so you can do a clean install.

A PC will lock up if the system resources are depleted.
Examine your system to insure that you don't have a program pulling down the memory.

I am not sure WHY you email settings have changed.  Any update from AVAST should keep them, but users have had problems with the update from 268 to 278.  The update to 280 was a "shell" update to only correct the problems with downloading the new update itself.  NO other changes were made.  It is basically a build 278.

The problems with THAT download (268 to 278) did cause errors and file corruption with some users, and I suspect that is why you are having the trouble now.

Your post was quite long, so I am "generalizing".  Let's try to clean up the old AVAST files, then you need to decide if you want McAfee or AVAST.  They won't run together.  Even if you don't have McA running at startup, its' files are still there which more than likely will conflict with AVAST.

I have both Home and Pro and tested it in W98, XP and ME.  Yes, some problems pop up, but we fix them and go on.

We may need to examine your setup logs, but for now, try what I recommended.

Good luck.
techie
« Last Edit: October 14, 2003, 04:39:35 PM by techie101 »

Offline BanziBaby

  • Full Member
  • ***
  • Posts: 138
  • Zeppelin Fanatic
Re:Avast is locking up the PC
« Reply #2 on: October 14, 2003, 06:30:45 PM »
Hi techie101 :)

Thanks for Ur reply, im sorry nut i did try the avclear prog from avast site, i apoligise as i forgot to mention that fact in my first post :(

The steps i done were uninstall avast using its uninstaller, reboot & then run the av clear prog & then rebooted again, i also searched the registry & deleted all references to avast & rebooted again, then reinstalled it

All during that time, i never had McAfee or any other a/v prog on the pc, it was only after gettin fed up with all the lockups & freezes & constant runnin of scandisk as pc was booting that i then disabled avast completely (ie both ashserv & the new mysterious ashdisp, before i done that i removed the mail protection first)

I only installed McAfee as i am on broadband & need to have a a/v prog runnin in background & i do find avast to best the best at what it does, believe me i dont like critising all the hard work the avast team puts into it product & have been a happy user for quite a while

Like i said this is on a fresh install of win98se with all critical updates & none of the other ones (ie games & language packs)

When the probs first started the first thing i did was get the latest version of avast from the website & also the avclear4 prog.I have checked the system & resources & nothin is hogging any of them, the problem to me seems to be when avast is either loading or has loaded & starts to scan explorer, then the system just locks up with the hourglass cursor, if i do the 3 fingered salute (ctrl+alt+del)it sometimes says that explorer isnt responding & other times no programs are listed as not responding.If avast is disabled even with no other a/v prog on the system it runs fine ???

Thanks again for Ur reply, if U or avast team want the logs, i will uninstall McAfee & set avast to load at startup again & send the logs, im just wondering if it could maybe be the ashdisp entry in the run section of the registry that might be causing it, but i didnt want to disable it as i thought one of the updates had put it there ???

Cheers

BaNzI ;D

Offline techie101returns

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1900
Re:Avast is locking up the PC
« Reply #3 on: October 14, 2003, 06:56:03 PM »
Banzi,

You seem to have taken all the steps necessary to try and clear the problem.

At this point, leave McAfee in place.  I understand your concern being on broadband.

I know it really looks like Avast is the culprit, but I have found in the past that sometimes AVAST is only the trigger, but not the cause.  You know what I mean?

I will try to do some research on this to see if I can come up with anything else.

Hopefully, one of the Moderators will pass this way and offer some help.

You can try doing a copy and paste of this post, and sending it on to the Avast Team support email address.
I don't know if they will respond any faster than we here at the forum but I would put all things in motion.

Hang in there....we'll figure it out.

techie :D


Offline BanziBaby

  • Full Member
  • ***
  • Posts: 138
  • Zeppelin Fanatic
Re:Avast is locking up the PC
« Reply #4 on: October 14, 2003, 07:26:15 PM »
Hi techie101 :)

Thanks yet again for Ur reply, i will send a copy of these post to the support mail address, just a bit busy the now as im in & out of the house the now, but i will try to do it before tomorrow :)

Many thanks again for all Ur help & i hope a mod will see this post as well, if i can suss out how to give U some karma, i will m8 :)

Cheers

BaNzI ;D

Offline techie101returns

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1900
Re:Avast is locking up the PC
« Reply #5 on: October 15, 2003, 05:15:11 AM »
banzi,

I haven't given up on you yet...still researching.

Giving Karma is easy.....just click on the work [applaud] under the user's name.

bye
techie

Offline Hornus Continuum

  • Full Member
  • ***
  • Posts: 119
  • If you only remember one thing, it's this ...
Re:Avast is locking up the PC
« Reply #6 on: October 15, 2003, 07:34:30 AM »
BanziBaby,

Do you have avast! scheduled to scan at bootup?  There were past reports that some people using version 4.0.235 experienced similar symptoms when avast! scans during startup.  I don't remember seeing a definitive resolution to that problem.  If the problem was never reproduced and corrected, maybe it still exists in 4.1.

Regards,
Hornus

"Quote me as saying I was misquoted." -- Groucho Marx  ;D

Offline techie101returns

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1900
Re:Avast is locking up the PC
« Reply #7 on: October 16, 2003, 07:41:26 AM »
Banzi,

Thought I forgot about you?  No way.
I am working with another user on a problem that might have bearing here.  You may have low system resources caused by memory leakage.

Remember I said that Avast could be the trigger but not the cause!

Read through this thread.  It may help.
http://www.avast.com/forum/index.php?board=1;action=display;threadid=1477&start=0

Good nite.  Too many posts and not enough answers.
I think my brain is suffering from memory leak!  ;)

Techie101
« Last Edit: October 16, 2003, 07:43:31 AM by techie101 »

Offline BanziBaby

  • Full Member
  • ***
  • Posts: 138
  • Zeppelin Fanatic
Re:Avast is locking up the PC
« Reply #8 on: October 16, 2003, 02:03:14 PM »
Hi techie101 & Hornus Continuum :)

@Hornus Continuum, i use win98se, i think U are reffering to the boottime scanner ??? As far as i know that only works withNT/2000/XP & not on 9x, i did try changing the configuration of Avast (ie scan all created/modified files & scan default ext set, but the same keeps happening

@techie101, i have monitored my resources, ihave a p2 300/196mb (old i know, but that was why i used avast as the hit on the system was negligable)I tried the FreeMem & also the mem optimiser in TuneUp Utilities 2003, but again the same will happen, i uninstalled McAfee & cleaned up registry & then reinstalled Avast, but it was doin it all the time, so i ended up unistalling it & putting McAfee back on.I have computers for years & do have a fair bit of knowledge, i can understand that Avast can sometimes be the trigger, but i always do the same tweaks & customisations that i have always done, so i know that it is Avast that is the root cause of it, even before i had to format, i was having niggles with version 4.1 (mostly the slightly different way the mail protection works ie smtp authentication)Before 4.1, Avast didnt use that, but 4.1 does, i can recieve mail ok, but the password box pops up constantly if i try 2 dend mail.I did use that trick that was mentioned on the forum, but found as well as having to change UseDefaultMSTP=0 to 1, i would also have to open OE6 & uncheck the use authentication in my accounts, then terminate the mail provider then restart it & then reboot, after doing all that i could then send mail & it was scanned

To me the fault is with Avast as it starts scanning a few seconds after it loads (usually windows explorer) I did try AVG7, but Avast seems to have done something to the accounts as i cant get the AVG mail wizard to automatically chage the settings to use its scanner ??? ??? ??? I did try ssetting it up manually, but the way it describes it isnt easy to do ??? ???

Thanks for lettin me know how to give U karma, i gave U 2 for all Ur help :)

Im am curious as to why none of the Avast team have responded ??? ??? ??? I am a big fan of their program & am starting to think that they dont want to help me for whatever reason ??? ??? ???

I repeat, i would like to go back to Avast as i know it does the job, im more than willing to let the fact it let some form of virus through, after all no a/v program is 100% accurate, but im gonna have to stick with McAfee till the next program update for Avast is released then i will retry it :)

Many thanks to techie & Hornus Continuumfor Ur help, it has been much appreciated & i hope techie101 that U can be free of Ur memory leak ;D

PS Raman, Pavel, Vlk & Avast team, i would like it if i could hear Ur comments on this problem, i know im not a prolific poster here, but that is cause i have not had any problem that i havent been able to fix, so please advise Avast team, i promise i will be nice :P ;D :)

Cheers

BaNzI ;D
« Last Edit: October 16, 2003, 02:05:03 PM by BanziBaby »

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11713
    • AVAST Software
Re:Avast is locking up the PC
« Reply #9 on: October 16, 2003, 02:11:24 PM »
Just a try: do you have "Show detailed info on performed action" switched on in the Standard Shield (4th page of the configuration)? Do you have scanning (all?) the files on open switched on (2nd page of the configuration)?
You are saying it freezes - does anything happens if you wait for a while (lets say 3 minutes... or just to be sure, 5) - maybe some the blue icon rotates a little further after that time?

Offline BanziBaby

  • Full Member
  • ***
  • Posts: 138
  • Zeppelin Fanatic
Re:Avast is locking up the PC
« Reply #10 on: October 16, 2003, 02:58:39 PM »
Hi igor :)

I dont have "show detailed info" enabled for any of the providers apart from the internet mail one, i have tried it with scan all files & just using the default extention set (the lower portin of the dialog U mention)I was using the extention list that was posted here by Vlk & others (but not scanning zip or rar files as it slows it right down) & i have also tried leaving it with the default extention set (top bit of the dialog on page U mention)

What i mean by freezs is that the as the desktop is loading, Kerio loads, then Avast (have even tried without Kerio 2.15 loading at startup)then Avast loads & as the desktop finishes loading, it just sits there sometimes with the hourglass cursor, sometimes without, nothin will work, either the cursor freezes or it will et me move it, but the taskbar wont appear & the shortcut key for showing the taskbar wont work.I have left it for various amounts of time (even overnight once, but it was still the same in morning)

When i ctrl+alt+del, sometimes it says explorer isnt responding, sometimes nothing is listed as not responding, but when i try to end task the not responding task, it comes up with the other end task dialog, but when i click end task it just sits there sayin closing & doesnt do anything else.The few times it didnt do that on startup, as soon a ran Opera 7.20 & 7.21 finals, not betas, it would say opera wasnt responding, so i did the same & again it just sat there sayin closing, pressing ctrl+alt+del again most of the time done nothing, but on a few occasions it would blue screen with system is unstable & a few times would say there was a fault with a Avast dll or file (sorry i cant remember which one it was, but it was the standard BSOD with the registers & place in memory that the fault occured ??? ??? ???

I have checked that all components were firmly seated inside the PC (ie memory/cars/processor)It has only been since the 4.1 update that the system would seem to become unstable, ie i never had Avast crash with 4.0 & neither was it the cause of any crashes, only since i used the online update to upgrade it to 4.1 & rebooted after it did some small niggles & crashes suddenly start to happen, but since the 4.1.280 update it has become constant, i have tried uninstalling & rebooting & then using the AV4clear tool & rebooting & also manually rditing the registry to clear all remains (there are one or two left as well as the maim Alwill entries, but all the subkeys were gone.About the only thing i never tried was disabling the mysterious ashdisp entry that appeared in the run section after one of the updates (i wasnt sure as i thought it might have had something to do with the new IM & P2P modules ??? ??? ???

Thanks for Ur time & help
Cheers

BaNzI ;D

Offline techie101returns

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1900
Re:Avast is locking up the PC
« Reply #11 on: October 16, 2003, 04:59:02 PM »

@techie101, i have monitored my resources, ihave a p2 300/196mb
Your system capabilities are fine.  I have Avast running on an old 333mhz with only 128 mb ram with negligible "bugs".

Quote
I did try AVG7, but Avast seems to have done something to the accounts as i cant get the AVG mail wizard to automatically chage the settings to use its scanner ??? ??? ??? I did try ssetting it up manually, but the way it describes it isnt easy to do ??? ???
NO, AVG can sometimes have problems trying to run its' mail wizard even without AVAST.  If you want to use AVG for now, you MUST uninstall AVAST, run the AVclear4, shut down ALL other Windows programs [AVG is really sensitive to this] and run the AVG install.
Quote

Quote
Im am curious as to why none of the Avast team have responded ??? ??? ??? I am a big fan of their program & am starting to think that they dont want to help me for whatever reason ??? ??? ???
That is not the case at all.  The AVAST team is always in the background working on perfecting AVAST and fixing any problems or bugs that we here at the forum uncover.
***I don't remember in your posts, but have you sent a request directly to their email address??  If you haven't, then do so.  If you have, then try an IM to one of the Moderators and have them send you request on to them.

Keeping up with program development is a vast task, but you WILL see many of the AVAST team present here on the forum at times.  Have faith.

Quote
I repeat, i would like to go back to Avast as i know it does the job....
We'll do our best to see that you do come back to AVAST!

We can only solve problems with the help of users like yourself who take the time to bring them to us, and have the patience to work with us to find a solution to what appear to be unsolveable issues.

I thank you on behalf of all the Forum and the AVAST team.

 :)
Techie101



« Last Edit: October 16, 2003, 05:06:21 PM by techie101 »

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11713
    • AVAST Software
Re:Avast is locking up the PC
« Reply #12 on: October 16, 2003, 09:29:14 PM »
Just to be sure where the problem really is:
If you disable the Standard Shield provider, does the problem disappear? If yes - does it help when you disable only "scan files on open" (completely)?

Recently, I've (hopefully) finished changes to the Standard Shield; the mechanism for scanning files on execute/open has been changed to avoid incompatibilities with some nasty "protections" (e.g. LaserLock). It still needs some testing - but if you think your problems are caused by the Standard Shield and want to try, I can send a link with the new files. I sort of doubt it would help, but you never know...

Offline darek12

  • Newbie
  • *
  • Posts: 11
Re:Avast is locking up the PC
« Reply #13 on: October 17, 2003, 06:05:01 PM »
 >:( Similar problem.
Win98SE, Athlon 600MHz, 20 GB HD, 448 MB RAM, only one av installed -Avast; no scan at bootup scheduled.

After one of mentioned here 'updates,' my pc freezes (without any error massage) during scanning; everything is shut down (only Explorer and Systray alive).

The same happened to me with AVG, and it was the reason I moved to avast...
However, will I have to move again...???



Offline BanziBaby

  • Full Member
  • ***
  • Posts: 138
  • Zeppelin Fanatic
Re:Avast is locking up the PC
« Reply #14 on: October 17, 2003, 06:58:29 PM »
Hi techie101 & igor :)

Ok heres what i have done, i have uninstalled McAfee 2004, rebooted, cleaned up registry, then rebooted again.Then i downloaded the latest setup from the Avast site & installed it & rebooted when it asked me to, then i ran Avast & set the settings to the way i like it (ie no mem scan/manual updates/etc) Then i set up the providers the way i have always done & in the strandard shield in the scan files on open i used the extention set i have used for a while ie COM,EXE,DLL,SYS,SCR,OV?,VXD,386,BIN,BAT,CMD,DO?,XL?, PP?,HT*,HLP,CH?,{*},ASP,CLA*,CPL,CSS,INF,JS*,LNK,MS?,OCX,PDF,PIF,PO?, PRC,RTF,SHS,VB?,VSD,WS?,SWF,AD?,ASX,BAS,CRT,INS,ISP, MDB,MDE,PCD,PRF,REG,SCF,SCT,SHB,URL,EML,NWS

Everythin seemed fine, then when tidying up the pc prior to a defrag, i uninstalled a prog that i wasnt using that asked for a reboot, after the reboot as the desktop was loading it done the same as it was doing ie freezin as Avast was loading.Pressed reset & sat through scandisk only for it to do it again, in all it done it 7-8 times (exact same point) Out of frustration i booted into safe mode & used msconfig to disable the ashdisp entry in the run section (according to Vlk in a another post shouldnt be there in win9x) It then done the same thing twice, then i shut pc down, waited 30 seconds & switched on, it loaded ok that time, i then changed the scan on open back to the default ie just WS?

Then i had to go out & when i came back, it seems to be loading ok, but i havent used it a while too see if it persists, i am going to try what igor has said & disable the standard shield (that does kinda worry me) & see if it does it again, will post back with the results, but on the good side it hasnt locked wehn shutting down or rebooting yet (fingers crossed) There is no other a/v progs on the system & i have attached a screengrab of the settings in the standard shield for igor, but i am wary of unchecking scan files on open completely as there are numerous files out there that will want to get more aquainted with my pc & that i dont want after having to reset everything back up after the last one ???

On the plus side so far im able to send mail with the Use smtp authentication on (ive still to check to see if it is enabled in OE6)I sent a test mail to myself & it went ok wothout that password box popping up :)

@techie101, i know the Avast team is hard at work making the prog better, i was just suprised that Vlk hadnt replied, thats all :)
The whole reason i moved to Avast from NAV2002 was that AVast was a lot more resource friendly & quicker & i still think Avast is the best a/v U can get (& im not just saying that lol) , especially on my PC which is similar to Urs

@igor, im interested in these files U mention (will PM U with my email if U would be kind enough to let me try them) & hope they can maybe make the problem go away as i dont know if the scan files on open with just WS? is as secure as the extention list i have been using?!?!?! As for the scan ceated/modified files i have always had that set to scan all files

Just one question, after installing Avast again, i seem to have lost the ability to open .eml files in OE6 (it was workin after i uninstalled McAfee), I just get the open with box, If anyone can tell me how to fix that i would be gratefull :)

Once again i thank all for their help & advice, the support here is top class :)

Cheers

BaNzI ;D
« Last Edit: October 17, 2003, 06:59:08 PM by BanziBaby »