Author Topic: com.avast.MacAvast.MAD %CPU up to 500%+  (Read 2361 times)

0 Members and 1 Guest are viewing this topic.

Offline jwjb

  • Newbie
  • *
  • Posts: 6
com.avast.MacAvast.MAD %CPU up to 500%+
« on: June 26, 2014, 05:35:36 AM »
For the last three days com.avast.MacAvast.MAD %CPU up to 500%+ slowing down my late 2013 iMac with specifications below for your reference.

avast! Free Antivirus Version: 8.0 (40795), Virus definitions version: 14062501

Late 2013 Apple iMac (27-inch Display 2560 x 1440), 3.4GHz Quad-core Intel Core i5, Turbo Boost up to 3.8GHz, 8GB 1600MHz DDR3 SDRAM - 2X4GB, 512GB Flash Storage, NVIDIA GeForce GTX 775M 2GB GDDR5, Magic Trackpad, Apple Wireless Keyboard and OS X 10.9.3 Mavericks


I have been using Avast Free on PC's for 15+ years and on my iMac for these last 6 months and this is the first issue I have found with the software, but unfortunately I will have to uninstall it and rely on Avira Free Antivirus until this issue is resolved as the iMac unproductive in its current state.
« Last Edit: June 26, 2014, 11:41:13 PM by jwjb »

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 70281
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: com.avast.MacAvast.MAD %CPU up to 500%+
« Reply #1 on: June 26, 2014, 09:42:12 AM »
W8.1 [x64] - Avast PremSec 21.4.2463.B4i [UI.617] - EEK - Firefox ESR 78.10.1 [NS/uBO/PB] - TB 78.10.1
Avast-Tools: Secure Browser 90.1 - Cleanup 21.1 - SecureLine 5.11 - Driver Updater 21.1 - CCleaner 5.78
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline jwjb

  • Newbie
  • *
  • Posts: 6
Re: com.avast.MacAvast.MAD %CPU up to 500%+
« Reply #2 on: June 26, 2014, 11:13:29 PM »
@Asyn, thanks for your reply and I will look at the latest beta as a viable alternative.

Offline jwjb

  • Newbie
  • *
  • Posts: 6
Re: com.avast.MacAvast.MAD %CPU up to 500%+
« Reply #3 on: June 26, 2014, 11:20:19 PM »
I just came across the below post from today regarding the new release for Mac 9.0 which I will install and hope will fix this issue.

Please note we have just released avast! for Mac 9.0.

It is available here: http://download.ff.avast.com/mac/avast_free_antivirus_mac_setup.dmg
(And it will be available from main http://avast.com website in couple hours when it propagates everywhere).

It is compatible with all OS X versions since 10.6.8 (including Yosemite developer preview 1 & 2).
Users with avast! 8.0 as well as users of 9.0 beta and beta 2 will get this update automatically.

Notable changes since 8.0:

  • New (and much nicer ;)) main UI.
  • Added command "Scan with Avast!" into Finder's context menu
  • Preferences has moved from System Preferences into the main application (menu Avast > Preferences)
  • No user registration required.
  • Complete support for 64bits. (In version 8.0 the antivirus engine was still running as 32bit for historical reasons.)
  • Many structural changes and fixes under the hood for higher stability and performance.
  • New major versions of browser avast! Online Security plugins bundled.

Offline jwjb

  • Newbie
  • *
  • Posts: 6
Re: com.avast.MacAvast.MAD %CPU up to 500%+
« Reply #4 on: June 26, 2014, 11:40:39 PM »
Just installed the newly released avast! for Mac 9.0 below and hope all works out with this new version.

avast! Free Antivirus Version: 9.0 (41877), Virus definitions version: 14062501

From looking at the Activity Monitor (All Processes) with the search term 'avast' there are only four processes which are running with low %CPU, i.e. 0.0 to 1.0 and 'com.avast.MacAvast.MAD' is not one of them in this new version.

So all is looking good at this point, but it would be nice to know what the root cause of this problem is which just started three, now four days ago.