Author Topic: avast web shield and slow webpage loading  (Read 10591 times)

0 Members and 1 Guest are viewing this topic.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 86816
  • No support PMs thanks
Re: avast web shield and slow webpage loading
« Reply #15 on: March 04, 2015, 08:47:16 PM »
Not seeing this on my XP Pro system, avast 2015.10.2.2214 and firefox 36.0. Pages appear to be loading as normal.

Note HTTPS scanning doesn't work with winXP and that is what the OP is using according to his signature, so it probably isn't that.

EDIT: the script shield and script scanning of old has been incorporated into the web shield function - I have seen no conflict in relation to NoScript and the web shield/script scanning, which I have used for some considerable time. NoScript essentially stops scripts running unless specifically allowed.

The web shield script scanning (as far as I'm aware) doesn't require the script to run it can check the script embedded in the web page.
« Last Edit: March 04, 2015, 08:52:18 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

REDACTED

  • Guest
Re: avast web shield and slow webpage loading
« Reply #16 on: March 04, 2015, 09:05:40 PM »
Not seeing this on my XP Pro system, avast 2015.10.2.2214 and firefox 36.0. Pages appear to be loading as normal.

Note HTTPS scanning doesn't work with winXP and that is what the OP is using according to his signature, so it probably isn't that.

EDIT: the script shield and script scanning of old has been incorporated into the web shield function - I have seen no conflict in relation to NoScript and the web shield/script scanning, which I have used for some considerable time. NoScript essentially stops scripts running unless specifically allowed.

The web shield script scanning (as far as I'm aware) doesn't require the script to run it can check the script embedded in the web page.

Thanks David for the edit info in reference to my question.   :)

REDACTED

  • Guest
Re: avast web shield and slow webpage loading
« Reply #17 on: March 04, 2015, 09:37:15 PM »
I'm using a modern operating system and am using HTTPS scanning, just to throw more variables at the problem!  ;)

Interestingly, the problem just happened on this Avast forum!  I cleared the Firefox cache, closed it, reopened it, browsed a couple sites, and then went to the Avast forum (HTTPS).  It took about 20 seconds for anything to happen after entering the URL.  Going to the next page in the forum was fast.

Offline jay21317

  • Jr. Member
  • **
  • Posts: 95
Re: avast web shield and slow webpage loading
« Reply #18 on: March 04, 2015, 09:54:19 PM »
My signature is actually out of date,  actually on a Windows 7 laptop, am using malwarebyes pro and avast pro.
Windows 10 Home ,Intel i7-7700hq @2.8GHZ/3.8ghz, 16GB DDR4 2400MHz ram, 512gb SSD, Avast 2017 PRO, Malwarebytes Pro, Firefox with Adblock plus and Noscript.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 86816
  • No support PMs thanks
Re: avast web shield and slow webpage loading
« Reply #19 on: March 04, 2015, 10:41:32 PM »
My signature is actually out of date,  actually on a Windows 7 laptop, am using malwarebyes pro and avast pro.

Yes I noticed you updated it after my post - so the option to uncheck the 'Enable HTTPS scanning' in the Web Shield settings is the one you should try - but that would only have an effect on https pages and you are experiencing it on http pages also.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline jay21317

  • Jr. Member
  • **
  • Posts: 95
Re: avast web shield and slow webpage loading
« Reply #20 on: March 04, 2015, 11:38:54 PM »
Yeah I figured I should update it, it was years out of date,  hope this is figured out,  and as I said it's odd,  it's only the first time a page is opened this happens,  and by first time I mean first time it's ever opened since updating to latest version,  after that no issues.
Windows 10 Home ,Intel i7-7700hq @2.8GHZ/3.8ghz, 16GB DDR4 2400MHz ram, 512gb SSD, Avast 2017 PRO, Malwarebytes Pro, Firefox with Adblock plus and Noscript.

REDACTED

  • Guest
Re: avast web shield and slow webpage loading
« Reply #21 on: March 05, 2015, 01:36:42 AM »
...and by first time I mean first time it's ever opened since updating to latest version,  after that no issues.

Interesting.  That's different from what I experience.  In my experience, it's the first time the page loads in a new browser session.

By the way, if it's the first time Avast ever encounters the site, but never after that, it's almost like Avast is keeping track of which sites you are viewing.   :-\

Offline jay21317

  • Jr. Member
  • **
  • Posts: 95
Re: avast web shield and slow webpage loading
« Reply #22 on: March 05, 2015, 01:42:34 AM »
I am also noticing this issue on all other computers in the house,  all using avast and malwarebyes pro as well as latest Firefox
Windows 10 Home ,Intel i7-7700hq @2.8GHZ/3.8ghz, 16GB DDR4 2400MHz ram, 512gb SSD, Avast 2017 PRO, Malwarebytes Pro, Firefox with Adblock plus and Noscript.

Offline abruptum

  • Massive Poster
  • ****
  • Posts: 2460
Re: avast web shield and slow webpage loading
« Reply #23 on: March 05, 2015, 11:56:31 PM »
Maybe this problem is fixed with Firefox 36.0.1

Firefox 36.0.1 fixes a number of critical issues

  http://www.ghacks.net/2015/03/05/firefox-36-0-1-fixes-a-number-of-critical-issues/

I didn't have this problem,but I had a problem with AdwCleaner not responding while scanning web browsers.
This is fixed in 36.0.1 version.