Author Topic: Avast is blocking access to webui of TP-Link router  (Read 4147 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
Avast is blocking access to webui of TP-Link router
« on: April 15, 2017, 11:12:14 AM »
Hello.

I am long-term user of Avast (since version 4.7). Now I have a problem with blocking access to webui of TP-Link router TL-WR840N.
Probably same problem as https://forum.avast.com/index.php?topic=200621.0 .

Avast Internet Security 17.3.2291 (build 17.3.3443.0), virus database 170414.0
Windows 7 32-bit.

Relevant components: Web Shield and Real Site.
If I temporarily disable it together, there is no problem to access webui.
If I activate one of them or both, I cannot access webui.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87645
  • No support PMs thanks
Re: Avast is blocking access to webui of TP-Link router
« Reply #1 on: April 15, 2017, 11:26:17 AM »
I don't use the Avast firewall, so I can't speak from personal experience, but there have been some topics that could possibly be related.

Is this a localhost IP address ?
If so then check in the firewall settings and disable local/IP scanning. Sorry if this isn't the correct term/title I'm working from memory of topics I have seen.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.4.6062 (build 23.4.8118.762) UI 1.0.762/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

REDACTED

  • Guest
Re: Avast is blocking access to webui of TP-Link router
« Reply #2 on: April 15, 2017, 11:41:36 AM »
Hi DavidR.

The firewall isn't reason of this problem.
Router is in my LAN and the same subnet as PC, IP address is 192.168.x.x .

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87645
  • No support PMs thanks
Re: Avast is blocking access to webui of TP-Link router
« Reply #3 on: April 15, 2017, 11:56:59 AM »
OK, I just thought it might be related to what some others are experiencing.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.4.6062 (build 23.4.8118.762) UI 1.0.762/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline chrisnpg

  • Newbie
  • *
  • Posts: 4
Re: Avast is blocking access to webui of TP-Link router
« Reply #4 on: April 23, 2017, 10:49:27 PM »
Has a resolution been found for this.
It is the Firewall of Avast that is blocking this. So if I disable the firewall, the login page will load, but once logged in, it still does not load correctly as it will sit and spin. So I look a little more and disabled the "Web Shield" and everything with the TP Link router will work without errors.

I'm killing myself trying to find a way to config the Firewall and Web Shield from blocking the local IP of my router.
The model of my Tp Link router is TL-ER5120.
Does not matter if I use Chrome or Firefox.

This was not a problem until Program Version 17.3.2291 (build 17.3.3443.0)
Virus Definition version: 170423-0

If I get on another Windows 10 system that Avast has not update to the version listed above, no blocking is happening. I am able to bring up the login page and do what I need to do without problems and without having to disable the Avast Firewall and Web Shield.




Offline chrisnpg

  • Newbie
  • *
  • Posts: 4
Re: Avast is blocking access to webui of TP-Link router
« Reply #5 on: April 23, 2017, 11:48:51 PM »
More info that I just noticed.

Avast is not only blocking my router access, it is blocking Chrome Cast.
My "Chrome" is not able to see my Chrome Cast unless I disable Avast Firewall.

So yes I am noticing many things being blocked by Avast that I have been using for a long time on this system. WTF is going on??????


Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5413
  • Spartan Warrior
Re: Avast is blocking access to webui of TP-Link router
« Reply #6 on: April 23, 2017, 11:56:48 PM »
More info that I just noticed.

Avast is not only blocking my router access, it is blocking Chrome Cast.
My "Chrome" is not able to see my Chrome Cast unless I disable Avast Firewall.

So yes I am noticing many things being blocked by Avast that I have been using for a long time on this system. WTF is going on??????
https://forum.avast.com/index.php?topic=199857.msg1387632#msg1387632
Reboot your system.  Allow EmUpdate.exe to run (takes about 8-12 minutes to finish)
Reboot.
Windows 10 Home 64-bit 21H2 Avast Premier Security version 22.8.6030 (build 22.8.7500.734) UI version 1.0.723.

Offline I_am_AM

  • Newbie
  • *
  • Posts: 11
Re: Avast is blocking access to webui of TP-Link router
« Reply #7 on: April 24, 2017, 04:49:31 PM »
I think I have found a solution... try going to Protection > Firewall and then click settings ( not application settings) go to advanced then uncheck port scan detection. This worked for me. Not sure if there is any benefit to having this enabled if you are already behind the firewall of your router? but I am NOT a computer security expert so assess the risks for yourself.

The way I located this was to look at the logs and show log for <rules>

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31094
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Avast is blocking access to webui of TP-Link router
« Reply #8 on: April 24, 2017, 04:52:08 PM »
There is no need to turn off the port scanning as the problem has been fixed already.

Offline solopablo93

  • Newbie
  • *
  • Posts: 3
Re: Avast is blocking access to webui of TP-Link router
« Reply #9 on: November 28, 2022, 01:18:22 AM »
it was never fixed it happens all the time and is a nightmare , with tplink 7200 every 20 mins with tplink 8200 every 10 mins , how a firewall can be a nightmare, with it disabled the connection never goes out, i m just about to change of antivirus all this years this was the problem damn, and i was instulting tplink it was all your fault, it had me mad 2 thousand times and it was your awful service

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87645
  • No support PMs thanks
Re: Avast is blocking access to webui of TP-Link router
« Reply #10 on: November 28, 2022, 02:19:38 AM »
To say it was never fixed in a topic that is well over 5 years old isn't advisable or this topic would essentially still be active.  Much has changed avast program, OS, etc. in over 5 years.

It would have been better to create your own new topic and give details (system, avast version).  But I guess you are past that.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.4.6062 (build 23.4.8118.762) UI 1.0.762/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security