Author Topic: New Beta version 18.6.2344  (Read 6893 times)

0 Members and 1 Guest are viewing this topic.

Offline petr.kolacek

  • Avast team
  • Jr. Member
  • *
  • Posts: 72
New Beta version 18.6.2344
« on: July 23, 2018, 02:44:41 PM »
Hi everyone,

new beta version 18.6.2344 (build 18.6.3946) is released.

What was fixed
  • DND mode - application whitelist/blacklist heavily modified
  • DND mode - several optimalization for 3rd party app blocking
  • several issues in licensing component (client as well as backend side)
  • blocking standard websites by Web Shield component
  • sometimes blocking TLS 1.3 connections

Known issues
  • DND mode - maximize performance option is enabled after DND mode disabled in single app
  • DND mode - "new app added" toaster does not appear in some cases
  • DND mode - not working correctly in Firefox and Edge browsers

Download links:
https://forum.avast.com/index.php?topic=179943.0

Enjoy this beta!
We are looking forward to your feedback.

AVAST Team.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 60372
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: New Beta version 18.6.2344
« Reply #1 on: July 23, 2018, 02:48:34 PM »
Thanks Petr, already up and running - no issues so far.
Windows 8.1 [x64] - Avast PremSec 19.7.2388.BC - CC 5.61 - EEK - Firefox ESR 60.8 [NS/AOS/uBO] - TB 60.8 [EM] - ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Massive Poster
  • *****
  • Posts: 4103
  • Whatever will be, will be.
Re: New Beta version 18.6.2344
« Reply #2 on: July 23, 2018, 04:38:16 PM »
Thanks for the new beta :)
Main: Win10 Pro 1903 64bit / Core i5-7400 3.0GHz / 8GB RAM / Avast 19 Premier Beta / Comodo Firewall 12
Mobile: Win10 Pro 1803 32bit, Vista SP2 32bit / Core 2 Duo SU9300 1.2GHz / 4GB RAM / Avast 19 Free / Windows Firewall Control
Phone: Android 2.3.4, 4.2.2 / Avast Mobile Security / Avast Anti-Theft

Avast の設定について解説しています。よろしければご覧ください。

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6016
  • When you think you know, Think Again
Re: New Beta version 18.6.2344
« Reply #3 on: July 23, 2018, 04:39:27 PM »
Behavior/Bug with Shields not enabling after Reboot Fixed:
https://forum.avast.com/index.php?topic=220143.0
Nice!
***HP ENVY 15K LT W10 Pro 1903 64Bit/750GB HD/16GB Ram/Avast Premier 19.7.2388 /VS 5.01(WC)/ASB/Mbam 4/Secureline b. 5.4/SANDBOXIE/Prey Project
**HP Compaq 8510p LT W10 Pro 1903 64Bit/1TB HD/8GB Ram/Avast Premier BETA 19.7.2388 /VS 5.01(WC)/ASB beta/Secureline b 5.4/SANDBOXIE/Prey Project 
     
*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2000)18.8.2356/OSA/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
<LAYERED SECURITY SOFTWARE PROTECTION ALL>

Offline TheLightgg

  • Jr. Member
  • **
  • Posts: 33
Re: New Beta version 18.6.2344
« Reply #4 on: July 23, 2018, 06:32:28 PM »
"Little bug" after the last update (beta).

UI failed to load.

Screen:
http://prntscr.com/k9zvsz

Configuration:
Windows 7 64 bits
i5 3570k
8 go ram

Offline petr.kolacek

  • Avast team
  • Jr. Member
  • *
  • Posts: 72
Re: New Beta version 18.6.2344
« Reply #5 on: July 24, 2018, 09:12:46 AM »
"Little bug" after the last update (beta).

UI failed to load.

Screen:
http://prntscr.com/k9zvsz

Configuration:
Windows 7 64 bits
i5 3570k
8 go ram
Hi TheLightgg, thank you for your report. Could you please find the logs in "c:\ProgramData\AVAST Software\Avast\log" path, copy them into some temporary folder, make an ZIP archive of them (by 7zip, WinRar or so) and send them to our FTP[1] for further analysis? Could you also confirm the problem persists even after the computer restart? Thank you!

[1]
FTP: ftp.avast.com/incoming
login/password: anonymous/anonymous

Offline TheLightgg

  • Jr. Member
  • **
  • Posts: 33
Re: New Beta version 18.6.2344
« Reply #6 on: July 24, 2018, 02:25:50 PM »
"Little bug" after the last update (beta).

UI failed to load.

Screen:
http://prntscr.com/k9zvsz

Configuration:
Windows 7 64 bits
i5 3570k
8 go ram
Hi TheLightgg, thank you for your report. Could you please find the logs in "c:\ProgramData\AVAST Software\Avast\log" path, copy them into some temporary folder, make an ZIP archive of them (by 7zip, WinRar or so) and send them to our FTP[1] for further analysis? Could you also confirm the problem persists even after the computer restart? Thank you!

[1]
FTP: ftp.avast.com/incoming
login/password: anonymous/anonymous

After the second restart of the computer there is no problem. =)

Avast is working well now.

Offline Vitdom

  • Jr. Member
  • **
  • Posts: 28
Re: New Beta version 18.6.2344
« Reply #7 on: July 24, 2018, 05:54:22 PM »
Another issue I found is when the results of the Smart Scan has been resolved, a blank page is presented. Going back to Status only displays the Smart Scan results again.
I am still able to reproduce this issue in version 18.6.2344.

Offline Vitdom

  • Jr. Member
  • **
  • Posts: 28
Re: New Beta version 18.6.2344
« Reply #8 on: July 25, 2018, 12:06:49 PM »
Ever since I installed this beta version 18.6.2344 a few times a day Windows 10 stops getting responses from DNS resolvers.
A system restart fixes the issue. Could be Avast as this update is the only change I've made since a week.

DNS servers ping fine and other devices on my network have no issues resolving hostnames from DNS but sometimes it just stops working on my laptop as of the 23:rd July.

Offline Evjls

  • Jr. Member
  • **
  • Posts: 95
Re: New Beta version 18.6.2344
« Reply #9 on: July 25, 2018, 02:26:54 PM »
The feature "warn when downloading files with poor reputation" still hasn't been fixed in this version
I still requires File shield to be disabled

proof:
https://youtu.be/MSAq1IRo4Y8

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Massive Poster
  • *****
  • Posts: 4103
  • Whatever will be, will be.
Re: New Beta version 18.6.2344
« Reply #10 on: July 25, 2018, 03:13:42 PM »
Ever since I installed this beta version 18.6.2344 a few times a day Windows 10 stops getting responses from DNS resolvers.
A system restart fixes the issue. Could be Avast as this update is the only change I've made since a week.

DNS servers ping fine and other devices on my network have no issues resolving hostnames from DNS but sometimes it just stops working on my laptop as of the 23:rd July.
What avast edition are you using (Free, Pro, IS, Premier)? I had a similar issue yesterday with Premier.
Main: Win10 Pro 1903 64bit / Core i5-7400 3.0GHz / 8GB RAM / Avast 19 Premier Beta / Comodo Firewall 12
Mobile: Win10 Pro 1803 32bit, Vista SP2 32bit / Core 2 Duo SU9300 1.2GHz / 4GB RAM / Avast 19 Free / Windows Firewall Control
Phone: Android 2.3.4, 4.2.2 / Avast Mobile Security / Avast Anti-Theft

Avast の設定について解説しています。よろしければご覧ください。

Offline alanb

  • Sr. Member
  • ****
  • Posts: 345
Re: New Beta version 18.6.2344
« Reply #11 on: July 25, 2018, 05:38:45 PM »
Quote
What avast edition are you using (Free, Pro, IS, Premier)? I had a similar issue yesterday with Premier.

Ditto, with AIS 18.5.2342.

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Massive Poster
  • *****
  • Posts: 4103
  • Whatever will be, will be.
Re: New Beta version 18.6.2344
« Reply #12 on: July 25, 2018, 05:48:36 PM »
Quote
What avast edition are you using (Free, Pro, IS, Premier)? I had a similar issue yesterday with Premier.

Ditto, with AIS 18.5.2342.
For users having above DNS issue, this is from the developers:

Quote
Can you please provide the exact error message from browser.
And also try if stopping and starting just Web Shield and leaving other shields ON helps resolve the issue?
And if not then stopping and starting just Real Site and Web Shield (both turned OFF) and leaving other shields ON helps resolve the issue?
Main: Win10 Pro 1903 64bit / Core i5-7400 3.0GHz / 8GB RAM / Avast 19 Premier Beta / Comodo Firewall 12
Mobile: Win10 Pro 1803 32bit, Vista SP2 32bit / Core 2 Duo SU9300 1.2GHz / 4GB RAM / Avast 19 Free / Windows Firewall Control
Phone: Android 2.3.4, 4.2.2 / Avast Mobile Security / Avast Anti-Theft

Avast の設定について解説しています。よろしければご覧ください。

Offline Vitdom

  • Jr. Member
  • **
  • Posts: 28
Re: New Beta version 18.6.2344
« Reply #13 on: July 25, 2018, 09:34:29 PM »
I have confirmed that the DNS issue is caused by Avast. I am personally using Avast Internet Security version 18.6.2344 (build 18.6.3946.0) on Windows 10 version 1803 build 17134.191 (10.0.17134.191).

After clicking Avast shields control > Disable permanently, the issue was immediately resolved. I was able to toggle all Avast Shield on again without encountering the issue. Why the issue sometime occurs, I don't know...

By analyzing network traffic in detail with WinPcap and Wireshark, I have determined that the issue lies in Sending the DNS queries, not in reciving the responses. DNS queries fail(no trace of them) to send to the DNS servers. Ping works fine.

I have attached all of my logs from Avast: https://www.dropbox.com/s/moat1drytlswcfo/avastdnsissuelogs_18.6.2344.zip?dl=1

I will try to disable Real Site and Web Shield respectively the next time the issue occurs to find out if those components could be causing this.
Update: Disabling Web Shield wasn't enough. But when I also disabled Real Site, the issue was resolved.
« Last Edit: July 25, 2018, 10:58:21 PM by Vitdom »

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 41291
  • 59 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: New Beta version 18.6.2344
« Reply #14 on: July 26, 2018, 12:27:57 AM »
I have confirmed that the DNS issue is caused by Avast. I am personally using Avast Internet Security version 18.6.2344 (build 18.6.3946.0) on Windows 10 version 1803 build 17134.191 (10.0.17134.191).

After clicking Avast shields control > Disable permanently, the issue was immediately resolved. I was able to toggle all Avast Shield on again without encountering the issue. Why the issue sometime occurs, I don't know...

By analyzing network traffic in detail with WinPcap and Wireshark, I have determined that the issue lies in Sending the DNS queries, not in reciving the responses. DNS queries fail(no trace of them) to send to the DNS servers. Ping works fine.

I have attached all of my logs from Avast: https://www.dropbox.com/s/moat1drytlswcfo/avastdnsissuelogs_18.6.2344.zip?dl=1

I will try to disable Real Site and Web Shield respectively the next time the issue occurs to find out if those components could be causing this.
Update: Disabling Web Shield wasn't enough. But when I also disabled Real Site, the issue was resolved.
Have you tried just disabling just Real Site to see if that bypasses the problem ???
Disabling Webshield is never a good thing.
Free avast! Security Seminar: https://goo.gl/kh3cqR  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1903 64bit, 8 Gig Ram, AvastFree 19.6.xxxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq