Author Topic: Avast scans all of my HDDs, whenever I install, uninstall or repair any software  (Read 577 times)

0 Members and 1 Guest are viewing this topic.

Offline mm81

  • Newbie
  • *
  • Posts: 4
Hi there

I'm using Avast Free 18.7.2354 with Windows 8.1 enterprise 64bit.

Every time I install, uninstall or repair any kind of a software, Avast perform a full scan of all my hard drives, simultaneously scanning the rest of files or programs that run after I install/uninstall/repair software. It makes my PC totally unresponsive, sometimes it just freeze, the whole scan takes several minutes, at the time I can't do anything on my PC. This is VERY frustrating. You may ask, how many times I install, uninstall or repair software? Well, quite often!

I don't think it's a bug. It's a feature ("behavior shield"). But it just too resource-hungry. Maybe it works good for single, tiny 480GB SSD, but not for couple of TB on HDDs.

Is there anything I can do, besides switching off behaviour shield?

(sorry for my poor english)
« Last Edit: November 11, 2018, 01:00:53 AM by mm81 »

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 56869
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
- Other security related software installed..?
- Which AV(s) did you use before Avast..?
Win 8.1 [x64] - Avast Premier 19.1.2360.BUC - CC 5.51 - MCS - EEK - FF ESR 60.4 [NS/AOS/uBO] - TB 60.4 [EM] - ACP/ASB/ASL.BUC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 80782
  • No support PMs thanks
This certainly isn't normal procedure and hasn't happened on any of my systems in all of the time I have been using avast.

Aside from what Asyn has asked. 

Have made any changes to to the default settings of Avast ?
If so you could try a 'Restore factory defaults' option in the AvastUI > Settings > Troubleshooting.  This only changes the Avast settings not your wider system.

Reboot when you have done this for the changes to take effect.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.1.2360/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline mm81

  • Newbie
  • *
  • Posts: 4
- Other security related software installed..?
- Which AV(s) did you use before Avast..?
- RansomFree
- 2013-2016 Windows Defender, 2016-2018 Bitdefender Antivirus Free Edition. I'm using Avast Free for 5 months now.


This certainly isn't normal procedure and hasn't happened on any of my systems in all of the time I have been using avast.

Aside from what Asyn has asked. 

Have made any changes to to the default settings of Avast ?
If so you could try a 'Restore factory defaults' option in the AvastUI > Settings > Troubleshooting.  This only changes the Avast settings not your wider system.

Reboot when you have done this for the changes to take effect.
Hmm, yes, I have made some small changes, but mainly related to exceptions. I'll try to restore settings.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 56869
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
OK, report back.
Win 8.1 [x64] - Avast Premier 19.1.2360.BUC - CC 5.51 - MCS - EEK - FF ESR 60.4 [NS/AOS/uBO] - TB 60.4 [EM] - ACP/ASB/ASL.BUC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523

Offline mm81

  • Newbie
  • *
  • Posts: 4
Nope.
Restoring setting didn't help at all.
I just uninstalled MSI Afterburner, and Avast is scanning my computer for 15 minutes now. I mean, it's not scanning per se, there is no mention that Avast is doing some scanning, it's just AvastSvc.exe working in background taking some CPU resources and - most of all - over 50% HDD resources, for several, long minutes, making my PC run very, very slow.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 56869
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
First, be sure to get rid of all remnants of your prior installed AV(s)..!!
-> https://support.avast.com/article/11/

Then:
1. Download Avast Free Antivirus: https://files.avast.com/iavs9x/avast_free_antivirus_setup_offline.exe
2. Follow instructions: https://www.avast.com/uninstall-utility (Run this tool for all prior installed Avast versions..!!)
3. Reinstall Avast with the downloaded installer from point 1.
4. Reboot.
Win 8.1 [x64] - Avast Premier 19.1.2360.BUC - CC 5.51 - MCS - EEK - FF ESR 60.4 [NS/AOS/uBO] - TB 60.4 [EM] - ACP/ASB/ASL.BUC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523

Offline mm81

  • Newbie
  • *
  • Posts: 4
I did everything according to the four steps above. I tested for two days with default settings, no weird problems have occured. Today I also enabled hardened mode and PUP detection. I will be testing for the next few days, I have just installed HWINFO, and Avast is not going crazy, like before, so probably everything will be fine. Thanks. But please don't close this topic yet.

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 39575
  • 58 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
I did everything according to the four steps above. I tested for two days with default settings, no weird problems have occured. Today I also enabled hardened mode and PUP detection. I will be testing for the next few days, I have just installed HWINFO, and Avast is not going crazy, like before, so probably everything will be fine. Thanks. But please don't close this topic yet.
Topics never get closed. When you've solved your problem, You can edit your original post
and change it to Re: Avast scans all of my HDDs, whenever I install, uninstall or repair any software (Solved)
Free avast! Security Seminar: https://goo.gl/kh3cqR  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1809 64bit, 8 Gig Ram, AvastFree 18.7.2354, WinPatrol, Unchecky How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 56869
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
I did everything according to the four steps above. I tested for two days with default settings, no weird problems have occured. Today I also enabled hardened mode and PUP detection. I will be testing for the next few days, I have just installed HWINFO, and Avast is not going crazy, like before, so probably everything will be fine. Thanks. But please don't close this topic yet.
You're welcome.
Win 8.1 [x64] - Avast Premier 19.1.2360.BUC - CC 5.51 - MCS - EEK - FF ESR 60.4 [NS/AOS/uBO] - TB 60.4 [EM] - ACP/ASB/ASL.BUC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523