Author Topic: [BUG] Firewall not working properly on Chinese character'd programs  (Read 510 times)

0 Members and 1 Guest are viewing this topic.

Offline JimmyZJX

  • Newbie
  • *
  • Posts: 4
Since updated to Avast Premium Security, one of my programs does not run properly: it fails to access the Internet.
So I tried to configure Avast Firewall. But unfortunately, no matter how I "allow" its Internet access, the program always tells "web request out of time".

Later I tried to rename the program to pure English name, then it works 100% of the time!

Please do fix the problem! People are using programs of different languages!

Offline JimmyZJX

  • Newbie
  • *
  • Posts: 4
Re: [BUG] Firewall not working properly on Chinese character'd programs
« Reply #1 on: November 23, 2019, 08:11:52 AM »
I forgot to tell my settings:
Firewall: default (Auto-decide)
Program version: 19.8.2393 (build 19.8.4793.544)

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 63687
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: [BUG] Firewall not working properly on Chinese character'd programs
« Reply #2 on: November 23, 2019, 08:13:42 AM »
- Which Avast..? (Free/Pro/IS/Premium)
- OS..? (32/64 Bit..? - which SP/Build..?)
- Other security related software installed..?
Win 8.1 [x64] - Avast PremSec 20.2.2401.BC [UI.505] - CC 5.65 - EEK - Firefox ESR 68.6.1 [NS/AOS/uBO/PB] - TB 68.6 - ASB/ASL.BUC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline JimmyZJX

  • Newbie
  • *
  • Posts: 4
Re: [BUG] Firewall not working properly on Chinese character'd programs
« Reply #3 on: November 23, 2019, 08:40:27 AM »
- Which Avast..? (Free/Pro/IS/Premium)
- OS..? (32/64 Bit..? - which SP/Build..?)
- Other security related software installed..?

Avast Premium Security
OS: Win10 x64 10.0.17763
No other security related software installed.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 63687
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: [BUG] Firewall not working properly on Chinese character'd programs
« Reply #4 on: November 23, 2019, 08:47:03 AM »
Follow instructions: https://support.avast.com/article/33/ and post your File-ID here afterwards.
Win 8.1 [x64] - Avast PremSec 20.2.2401.BC [UI.505] - CC 5.65 - EEK - Firefox ESR 68.6.1 [NS/AOS/uBO/PB] - TB 68.6 - ASB/ASL.BUC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline JimmyZJX

  • Newbie
  • *
  • Posts: 4
Re: [BUG] Firewall not working properly on Chinese character'd programs
« Reply #5 on: November 23, 2019, 10:03:28 AM »
Follow instructions: https://support.avast.com/article/33/ and post your File-ID here afterwards.
FileID: ZULQQ

Thanks in advance!

I also quickly wrote a test program and upload the zip here: there are 2 exactly the same exe's. The one with a Chinese name could not perform HTTP requests. (Strangely HTTPS works)

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 63687
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: [BUG] Firewall not working properly on Chinese character'd programs
« Reply #6 on: November 23, 2019, 10:06:55 AM »
Win 8.1 [x64] - Avast PremSec 20.2.2401.BC [UI.505] - CC 5.65 - EEK - Firefox ESR 68.6.1 [NS/AOS/uBO/PB] - TB 68.6 - ASB/ASL.BUC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline HK

  • Avast team
  • Jr. Member
  • *
  • Posts: 90
Re: [BUG] Firewall not working properly on Chinese character'd programs
« Reply #7 on: November 25, 2019, 11:00:02 AM »
Hi JimmyZJX,

thanks for reporting the issue. Could you please specify the app's name (the one that can not connect to the internet) so we can properly test it and fix it?

Thanks in advance,
HK