Author Topic: Windows very slow to close after installing Avast.  (Read 11431 times)

0 Members and 1 Guest are viewing this topic.

Offline zammer

  • Jr. Member
  • **
  • Posts: 21
Windows very slow to close after installing Avast.
« on: November 25, 2007, 10:07:43 PM »
Avast 4.7 Home. XPSP2. Since I installed Avast, when I try to close Windows, "Windows is shutting down" remains onscreen for at least 8 minutes before Windows shuts down. I removed Trend Micro PC-Cillin before installing AVAST, using PC-Cillin uninstall tool plus Add/Remove. Have also used SEARCH to find any remaining Trend Micro or PC-Cillin files/folders and removed them. Also have installed SuperAdblocker (includes anti-spyware), Spysweeper anti-spyware, use Windows Firewall.
Help is appreciated.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Windows very slow to close after installing Avast.
« Reply #1 on: November 25, 2007, 10:53:09 PM »
Any useful information into Control Panel > Administrative Tools > Events, specially 'Errors' ?
The best things in life are free.

Offline zammer

  • Jr. Member
  • **
  • Posts: 21
Re: Windows very slow to close after installing Avast.
« Reply #2 on: November 26, 2007, 01:58:49 AM »
I found three "errors"  1) "Application...application error" 2) "Anti-virus...system, error records" 3) "IE...custom log errors."
I'm not a newbie, but far from a knowbie, and don't know what to do with the info (if anything.)

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Windows very slow to close after installing Avast.
« Reply #3 on: November 26, 2007, 02:56:17 PM »
I found three "errors"  1) "Application...application error" 2) "Anti-virus...system, error records" 3) "IE...custom log errors."
I'm not a newbie, but far from a knowbie, and don't know what to do with the info (if anything.)
In the System and the Application logs, is there any error related to antivirus, or with problems when you shutdown.
For instance, shutdown now and see if any entry appears with the time and date of this shutdown.
The best things in life are free.

Offline zammer

  • Jr. Member
  • **
  • Posts: 21
Re: Windows very slow to close after installing Avast.
« Reply #4 on: November 26, 2007, 09:22:41 PM »
Thank you for your interest. I did as you said and shut down. The WINDOWS IS SHUTTING DOWN showed for approx 7 minutes before Windows shut down, only during the last minute or two did the hourglass blink. Shutdown was at 10:59:55; startup was 11:07:57 (both times taken from Application). Avast opened with Windows, scanned.
These are the readings. I am giving you all, as I don't know which are of value to you.
Application:
10:59:55 WARNING...(source)USER ENV...(category)NONE...(user)SYSTEM
11:07:46 ERROR...(source)ESENT...(category)GENERAL...(user)N/A
11:07:47 ERROR...(source)ESENT...(category)LOGGING/...(user)N/A
11:07:57 ERROR...(source)ESENT...(category)LOGGING/...(user)N/A
System:
Only one error on page.
11:11:24 ERROR...(source)SERVICE CONTROL MANAGER...(category)NONE...(user)N/A
11:11:24 INFORMATION...(source)SERVICE CONTROL MANAGER...(category)NONE...(user)N/A    (The rest of the page is the same, with different times.)
Anti-Virus:
10:57:14 ERROR...(source)AVAST...(category)CLIENT...(user)N/A
10:57:14 WARNING...(source)AVAST...(category)CLIENT...(user)N/A
11:11:46 ERROR...(source)AVAST...(category)CLIENT...(user)N/A
11:11:45 WARNING...(source)AVAST...(category)CLIENT...(user)N/A

Thanks again.




Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Windows very slow to close after installing Avast.
« Reply #5 on: November 26, 2007, 09:28:19 PM »
11:07:46 ERROR...(source)ESENT...(category)GENERAL...(user)N/A
11:07:47 ERROR...(source)ESENT...(category)LOGGING/...(user)N/A
11:07:57 ERROR...(source)ESENT...(category)LOGGING/...(user)N/A
All of these. Double click them and copy&paste the info (description) here.

11:11:24 ERROR...(source)SERVICE CONTROL MANAGER...(category)NONE...(user)N/A
Same here.

10:57:14 ERROR...(source)AVAST...(category)CLIENT...(user)N/A
11:11:46 ERROR...(source)AVAST...(category)CLIENT...(user)N/A
Same here.
The best things in life are free.

Offline zammer

  • Jr. Member
  • **
  • Posts: 21
Re: Windows very slow to close after installing Avast.
« Reply #6 on: November 26, 2007, 09:57:42 PM »
Event Type:   Error
Event Source:   ESENT
Event Category:   General
Event ID:   490
Date:      11/26/2007
Time:      11:07:46 AM
User:      N/A
Computer:   LEN-03D74362213
Description:
wuauclt (1976) An attempt to open the file "C:\WINDOWS\SoftwareDistribution\DataStore\Logs\edb00145.log" for read / write access failed with system error 32 (0x00000020): "The process cannot access the file because it is being used by another process. ".  The open file operation will fail with error -1032 (0xfffffbf8).

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Event Type:   Error
Event Source:   ESENT
Event Category:   Logging/Recovery
Event ID:   454
Date:      11/26/2007
Time:      11:07:47 AM
User:      N/A
Computer:   LEN-03D74362213
Description:
wuauclt (1976) Database recovery/restore failed with unexpected error -1032.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Event Type:   Error
Event Source:   ESENT
Event Category:   Logging/Recovery
Event ID:   454
Date:      11/26/2007
Time:      11:07:47 AM
User:      N/A
Computer:   LEN-03D74362213
Description:
wuauclt (1976) Database recovery/restore failed with unexpected error -1032.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Event Type:   Error
Event Source:   ESENT
Event Category:   Logging/Recovery
Event ID:   454
Date:      11/26/2007
Time:      11:07:57 AM
User:      N/A
Computer:   LEN-03D74362213
Description:
wuauclt (1524) Database recovery/restore failed with unexpected error -1032.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Event Type:   Error
Event Source:   ESENT
Event Category:   Logging/Recovery
Event ID:   454
Date:      11/26/2007
Time:      11:07:57 AM
User:      N/A
Computer:   LEN-03D74362213
Description:
wuauclt (1524) Database recovery/restore failed with unexpected error -1032.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Event Type:   Error
Event Source:   ESENT
Event Category:   Logging/Recovery
Event ID:   454
Date:      11/26/2007
Time:      11:07:57 AM
User:      N/A
Computer:   LEN-03D74362213
Description:
wuauclt (1524) Database recovery/restore failed with unexpected error -1032.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Event Type:   Error
Event Source:   Service Control Manager
Event Category:   None
Event ID:   7001
Date:      11/26/2007
Time:      11:11:24 AM
User:      N/A
Computer:   LEN-03D74362213
Description:
The Media Center Extender Service service depends on the SSDP Discovery Service service which failed to start because of the following error:
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Event Type:   Error
Event Source:   avast!
Event Category:   Client
Event ID:   90
Date:      11/26/2007
Time:      10:57:14 AM
User:      N/A
Computer:   LEN-03D74362213
Description:
AAVM - scanning error: x_AavmCheckFileDirectEx: avfilesScanReal of C:\Program Files\Webroot\Spy Sweeper\Masters\masters.mst failed, 00000005.  

Event Type:   Error
Event Source:   avast!
Event Category:   Client
Event ID:   90
Date:      11/26/2007
Time:      11:11:46 AM
User:      N/A
Computer:   LEN-03D74362213
Description:
AAVM - scanning error: x_AavmCheckFileDirectEx: avfilesScanReal of C:\Program Files\Webroot\Spy Sweeper\Masters\masters.mst failed, 00000005.  



Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Windows very slow to close after installing Avast.
« Reply #7 on: November 26, 2007, 10:56:13 PM »
Event Type:   Error
Event Source:   ESENT
Event Category:   General
Event ID:   490
Date:      11/26/2007
Time:      11:07:46 AM
User:      N/A
Computer:   LEN-03D74362213
Description:
wuauclt (1976) An attempt to open the file "C:\WINDOWS\SoftwareDistribution\DataStore\Logs\edb00145.log" for read / write access failed with system error 32 (0x00000020): "The process cannot access the file because it is being used by another process. ".  The open file operation will fail with error -1032 (0xfffffbf8).
Windows Update problem... did you install any updates recently? Does any of them failed to install?

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Event Type:   Error
Event Source:   Service Control Manager
Event Category:   None
Event ID:   7001
Date:      11/26/2007
Time:      11:11:24 AM
User:      N/A
Computer:   LEN-03D74362213
Description:
The Media Center Extender Service service depends on the SSDP Discovery Service service which failed to start because of the following error:
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.
This seems to be related to login, not to shutdown.


The AAVM - scanning error: 00000005 is just access denied. Not to worry.

Hmmm... it's not easy to discover what is making your shutdown process slower.
Which programs are you running when you shutdown?
The best things in life are free.

Offline Maxx_original

  • Avast team
  • Super Poster
  • *
  • Posts: 1479
Re: Windows very slow to close after installing Avast.
« Reply #8 on: November 26, 2007, 11:16:37 PM »
wuauclt is the process responsible for Automatic updates... if it falls because of sharing violation, you can look for the currently opened handle to the log file.. the easiest way to do it is to download Process explorer (from SysInternals -> MS) and use the "find handle or dll" function...

ehm.. are you getting any other warnings about Automatic updates failure?

Offline zammer

  • Jr. Member
  • **
  • Posts: 21
Re: Windows very slow to close after installing Avast.
« Reply #9 on: November 26, 2007, 11:41:56 PM »
You're very good. I've not been able to update, have a tech support request working with WINDOWS, expect a reply within 24 hours. I tried the solution in the database fo ox80248011 error code (get this when I use WINDOWS update site). Also emptied IE cookies, files, history. Can't update from PC icon. Screen freezes.
Do you think the update problem can be connected to the long shutdown? I thought it interesting that the hourglass only blinked the last minute or so of the seven before it Windows shut down.

Offline Maxx_original

  • Avast team
  • Super Poster
  • *
  • Posts: 1479
Re: Windows very slow to close after installing Avast.
« Reply #10 on: November 26, 2007, 11:53:23 PM »
i don't know... the handle to edb00145.log maybe remains open and some related processes/services must wait for their timeouts, because they can't be terminated correctly... but this is only one possible way... we could try to solve the problem with updates and look if some improvement will come.. download process explorer and try to get almost a basic knowledge about its using... i'm going to offline now, but someone from the evangelists team should help you with this, hopefully.. ;)

Offline zammer

  • Jr. Member
  • **
  • Posts: 21
Re: Windows very slow to close after installing Avast.
« Reply #11 on: November 27, 2007, 12:15:34 AM »
Thanks again. I looked at Process Explorer; it's way beyond my ability to understand. I'll see how MW Tech Support works out.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Windows very slow to close after installing Avast.
« Reply #12 on: November 27, 2007, 02:00:53 AM »
Thanks again. I looked at Process Explorer; it's way beyond my ability to understand. I'll see how MW Tech Support works out.
If you solve the Microsoft Updates problems we can help you IF the shutdown delays persist...
The best things in life are free.

Offline zammer

  • Jr. Member
  • **
  • Posts: 21
Re: Windows very slow to close after installing Avast.
« Reply #13 on: November 27, 2007, 02:45:24 AM »
I appreciate that. I will get back to this post after the updates problem is fixed. It will be, I hope this week.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Windows very slow to close after installing Avast.
« Reply #14 on: November 27, 2007, 12:11:02 PM »
I appreciate that. I will get back to this post after the updates problem is fixed. It will be, I hope this week.
We'll be here to help.
The best things in life are free.