Author Topic: Can't send or receive email...maybe after latest avast update??  (Read 39433 times)

0 Members and 1 Guest are viewing this topic.

Asbjorn

  • Guest
Re: Can't send or receive email...maybe after latest avast update??
« Reply #45 on: June 01, 2008, 12:25:36 PM »
I installed Avast! 4.8.1201 yesterday, since my old AVG antivirus was outdated.
XP sp2, Thunderbird, and Superantispyware , and an router firewall.

After removing the AVG, and installing Avast! and rebooted ( several times ) , I started up with an update, to be sure to have the latest datafiles, and programfiles. Including another reboot ( Avast! insisted ;-) )

Then after booting up again, I started thunderbird to access my email.
I have several email accounts - since I'm a forum admin on 3 different forums in Norway.
Some with standard pop3 accounts ( port 110 )
and a few GMAIL accounts, (port 995) .

After a while I got the "famous"   "Avast max connection exceed"

The mail collected trough port 995 came trough, but those with port 110 did not !
And I did NOT get the mail from the port 110 accounts...
Until I disabled the scanning of incoming mail service... Then they arrived without problems.

Today I tried again, first without enabling the incoming scan, , and later I tried again with scanning of incoming. ( after reading trough this topic here )
Now it worked without problem...

I did NOT have any troubles like this with AVG...

Hope this helps to find the problem...

regards Asbjorn.

Alexis

  • Guest
Re: Can't send or receive email...maybe after latest avast update??
« Reply #46 on: June 01, 2008, 03:08:03 PM »
Which was your antivirus before installing avast? How did you uninstall it?

No other antivirus than Avast since i use my computer.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Can't send or receive email...maybe after latest avast update??
« Reply #47 on: June 02, 2008, 01:11:57 AM »
After a while I got the "famous"   "Avast max connection exceed"
You can increase that limit, see
http://forum.avast.com/index.php?topic=11788.0#msg100032
But it will be good to know what is causing it...

The mail collected trough port 995 came trough, but those with port 110 did not !
Gmail is not scanned by avast.
First of all, it's not possible because Gmail uses SSL (Secure Socket Layer) connections. Avast mail scanner doesn't support SSL (Secure Socket Layer) connections. But take a look here: http://forum.avast.com/index.php?topic=10428.0 to see how to set up secure email with avast!.
The best things in life are free.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 89057
  • No support PMs thanks
Re: Can't send or receive email...maybe after latest avast update??
« Reply #48 on: June 02, 2008, 01:55:43 AM »
<snip>

Then after booting up again, I started thunderbird to access my email.
I have several email accounts - since I'm a forum admin on 3 different forums in Norway.
Some with standard pop3 accounts ( port 110 )
and a few GMAIL accounts, (port 995) .

After a while I got the "famous"   "Avast max connection exceed"
<snip>

When getting the 'famous' (as you say) avast max connections exceeded, does it not inform you of what processes are using the connections. From my recollections of these max connection issues there is usually and indication of what is using the connections.

So you should be looking out for what is causing the problem than treat a symptom by increasing max connections, by doing this whatever is eating up the connections will probably increase its connections up to the newly set limit.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re: Can't send or receive email...maybe after latest avast update??
« Reply #49 on: June 02, 2008, 10:27:20 AM »
Those who have problems described in this thread please create a dump of the ashMaiSv.exe process (when the problem is simulated, i.e. the connection times out) and upload it to our ftp site ftp://ftp.avast.com/incoming .

To create the dump, download and run http://public.avast.com/~vlk/hangrep.exe . In the list of processes select ashMaiSv.exe and use the Save button. This generates a file which you can upload to the ftp site.

Thanks
« Last Edit: June 23, 2008, 10:40:32 AM by vojtech »

frey

  • Guest
Re: Can't send or receive email...maybe after latest avast update??
« Reply #50 on: June 06, 2008, 10:54:39 AM »
tried to make a dump, failed error code 13 and the file is empty  :(

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re: Can't send or receive email...maybe after latest avast update??
« Reply #51 on: June 11, 2008, 10:54:01 AM »
Well, I don't know why the error 13. Try using Userdump (http://public.avast.com/~vlk/userdump.exe) instead of Hangrep. It's a command-line utility. The syntax is
userdump.exe ashMaiSv.exe c:\ashMaiSv.dmp
(producing dump file in the root of C:\ drive)
Thank you.

MarylandGuy_42

  • Guest
Re: Can't send or receive email...maybe after latest avast update??
« Reply #52 on: June 19, 2008, 12:06:21 PM »
After several weeks of hang-free service I just had ashMaiSv.exe hang on me again.  I tried both dump utilities.  hangrep.exe failed with error code 13, and userdump.exe failed as follows:

D:\Kits\avast>userdump.exe ashMaiSv.exe d:\ashMaiSv.dmp
User Mode Process Dumper (Version 1.0)
Copyright (c) 1999 Microsoft Corp. All rights reserved.

Dumping process 3728 (ashMaiSv.exe) to
d:\ashMaiSv.dmp...
The process could not be dumped.
Access is denied.

D:\Kits\avast>

What to do next?

Paul

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re: Can't send or receive email...maybe after latest avast update??
« Reply #53 on: June 19, 2008, 02:06:29 PM »
I'm sorry I didn't mention that the Self Defense must be off when creating the dump. It can be disabled at the Troubleshooting page in avast settings.

MarylandGuy_42

  • Guest
Re: Can't send or receive email...maybe after latest avast update??
« Reply #54 on: June 21, 2008, 08:14:46 AM »
I'm sorry I didn't mention that the Self Defense must be off when creating the dump. It can be disabled at the Troubleshooting page in avast settings.

That helped.  hangrep still gave me the Error 13, but userdump successfully dumped the process.  I uploaded it to ftp://ftp.avast.com/incoming/ as 'MarylandGuy-ashMaiSv.dmp'.

Paul
« Last Edit: June 21, 2008, 08:17:32 AM by MarylandGuy_42 »

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re: Can't send or receive email...maybe after latest avast update??
« Reply #55 on: June 24, 2008, 05:45:43 PM »
Thank you for the dump. The fix will be available in the next update. Until it is released, you will need to restart the Internet Mail provider when this problem occurs.

MarylandGuy_42

  • Guest
Re: Can't send or receive email...maybe after latest avast update??
« Reply #56 on: June 24, 2008, 08:12:16 PM »
Excellent!  ..and no problem.

Thanks!
Paul