Author Topic: Web Shield causes all browsers to stop working  (Read 93755 times)

0 Members and 1 Guest are viewing this topic.

info

  • Guest
Re: Web Shield causes all browsers to stop working
« Reply #105 on: July 23, 2008, 11:52:37 PM »
Goliath, your description sounds more like the problem that was supposed to be fixed in the latest update.

info, once the problem is simulated, please disable avast self defense (avast Settings -> Troubleshooting page) and then start Task Manager, go to the Processes page, righ-click ashWebSv.exe and select Create Dump File. Finally, ZIP the created dump file and upload it to our ftp site as described here: http://support.avast.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=18


Thanks
Vlk

Vlk, I uploaded the file as infoashWebSv.  It is 43.7 megs.  There is another which aborted named infosashWebSv (please disregard).  Thanks!

richarddi

  • Guest
Re: Web Shield causes all browsers to stop working
« Reply #106 on: July 23, 2008, 11:54:49 PM »
I don't use spybot and also have the problem. At the moment I'm running Avast without webshield and check daily this tread. Thanks info for all your effort trying to figure this out!

info

  • Guest
Re: Web Shield causes all browsers to stop working
« Reply #107 on: July 24, 2008, 12:01:54 AM »
richard, I know that the problem will eventually be found.  I just hope I'm alive to see it.  ;D

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Web Shield causes all browsers to stop working
« Reply #108 on: July 24, 2008, 12:03:10 AM »
I don't use spybot and also have the problem. At the moment I'm running Avast without webshield and check daily this tread. Thanks info for all your effort trying to figure this out!
There is a new avast version 4.8.1229, can you test?
The best things in life are free.

richarddi

  • Guest
Re: Web Shield causes all browsers to stop working
« Reply #109 on: July 24, 2008, 12:08:24 AM »
Yep, I will test.

richarddi

  • Guest
Re: Web Shield causes all browsers to stop working
« Reply #110 on: July 24, 2008, 12:59:12 PM »
Too bad, that update didn't fix the problem.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Web Shield causes all browsers to stop working
« Reply #111 on: July 24, 2008, 01:56:54 PM »
Can you activate logging in WebShield?
0. (Disable avast self-defense module: Program settings > Troubleshooting tab of settings.)
1. Edit <avast>\data\avast4.ini file with Notepad (or use step 0 with other text editors).
2. Find the section [WebScanner]
3. Add the line:
    EnableLogging=1
4. Restart Web Shield in XP\Vista (terminate and start again) or whole PC in case of Win98
5. Browse (trying to access some webpages)

The log file are <avast>\data\log\ashwebsv.log and ashwebsv.ws.
They would be accessible when WebShield is terminated again.
Post them here or send by mail to rypacek (at) asw.cz
After that, disable the logging to avoid a big log file.

Oh, enable the self-defense module again after that if you have to follow step 0.
The best things in life are free.

richarddi

  • Guest
Re: Web Shield causes all browsers to stop working
« Reply #112 on: July 24, 2008, 03:04:00 PM »
I've just followed the steps and will sent the files when I have a lock-up again. This can take some time somtimes. Thanks for helping figuring this out.

richarddi

  • Guest
Re: Web Shield causes all browsers to stop working
« Reply #113 on: July 24, 2008, 11:09:06 PM »
No lock-up today, hopefully tomorrow more "luck". Goodnight

fooldog01

  • Guest
Re: Web Shield causes all browsers to stop working
« Reply #114 on: July 25, 2008, 01:15:34 AM »
The update has not fixed the issue for me.

richarddi

  • Guest
Re: Web Shield causes all browsers to stop working
« Reply #115 on: July 25, 2008, 10:49:25 AM »
Tech, I've just had a lock-up and sent the files to you. Maybe we can continue the conversation here so others can benefit from your investigations.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Web Shield causes all browsers to stop working
« Reply #116 on: July 25, 2008, 02:23:14 PM »
Tech, I've just had a lock-up and sent the files to you.
To Lukas indeed, not for me...
The best things in life are free.

richarddi

  • Guest
Re: Web Shield causes all browsers to stop working
« Reply #117 on: July 25, 2008, 02:55:34 PM »
I've send it to rypacek (at) asw.cz Is that not OK? Must I copy and past the file here?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Web Shield causes all browsers to stop working
« Reply #118 on: July 25, 2008, 02:59:09 PM »
I've send it to rypacek (at) asw.cz Is that not OK?
It's ok, it's just not me, it's the Lukas' email.

Must I copy and past the file here?
It's not necessary.
The best things in life are free.

Goliath Corporation

  • Guest
Re: Web Shield causes all browsers to stop working
« Reply #119 on: July 26, 2008, 08:16:48 AM »
Hi all,

Just a quick note to say that I haven't had the lock up since 4.8.1227 / 4.8.1229  - many thanks to the team!  :)

Wishing you similar success in tracking down the Vista bug too.