Author Topic: On-Access Protection causes Vista to hang on shutdown  (Read 9024 times)

0 Members and 1 Guest are viewing this topic.

Offline gpzbc

  • Newbie
  • *
  • Posts: 13
On-Access Protection causes Vista to hang on shutdown
« on: April 12, 2009, 12:31:59 AM »
Hi,
I have been having a problem where my Vista 64 machine hangs on shutdown.  Basically at shutdown it goes through all the steps, shuts down services, but when it gets to the "Shutting Down" screen the progress circle stops and the computer hangs.  The only way to get it to shutdown from there is to do a hard shut down by holding in the power button.

I have tried to diagnose this and it keeps coming back to Avast.  If I "Stop On-Access Protection" prior to my shut down or restart, then it works fine.  If I don't "Stop On-Access Protection" then it hangs at the "shutting down" screen.

Can anyone help me figure this out?  Is there a setting that I am missing that will prevent this?  As it is now, I just right click on the Avast icon and "Stop On-Access Protection" and that does the trick.  But I would like to solve whatever problem is causing this.

Thanks very much in advance for your help and advice.

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8784
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #1 on: April 12, 2009, 12:40:41 AM »
I don't have a Vista 64 machine but the folks over at Smokey's Security Forums probably do:
Turn Vista's Sleep Button Into a Power Button
http://www.smokey-services.eu/forums/index.php/topic,26209.0.html
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline gpzbc

  • Newbie
  • *
  • Posts: 13
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #2 on: April 12, 2009, 12:44:58 AM »
Thanks for the quick reply.

I'm not convinced it is strictly a 64 bit problem.   Is anyone else experiencing similar problems?

Thanks again.

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8784
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #3 on: April 12, 2009, 12:49:15 AM »
My 32 bit Vista system does not have a problem powering down.
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline Confused Computer User

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 700
  • The answer is 42
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #4 on: April 12, 2009, 01:45:59 AM »
My 32 bit Vista system does not have a problem powering down.

I second and triple that. I have 2 Vista systems both 32-bit (see signature at the bottom of my post) and never had this problem.

I don't have a Vista 64 machine but the folks over at Smokey's Security Forums probably do:
Turn Vista's Sleep Button Into a Power Button
http://www.smokey-services.eu/forums/index.php/topic,26209.0.html

This is a cosmetic change ... has no impact on how the computer shuts down overall (I know cause I did it on my systems)

gpzbc , did you have this issue for a while (ie since you installed avast) or before that?

Did you have other security software on that comp? Which were they if any?

Computer Systems:

Intel Pentium 4 641 / 2GB RAM / Vista Home Basic SP2 / avast! 5.0 Home / SAS Free / MBAM Free / Windows Defender / Windows Firewall / Spyware Blaster/ Secunia PSI / Firefox 3.6 / Opera 10.5

Core2Duo T8300 / 4GB RAM / Vista Home Premium SP2 (32 bit version) / Same Software.

Offline gpzbc

  • Newbie
  • *
  • Posts: 13
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #5 on: April 12, 2009, 01:55:46 AM »
I have been dealing with this issue for a while now.  But I can't pinpoint an exact date.   However, I have only had my 64 bit system since January.

No, I don't have any other security software aside from Avast, Windows Firewall, and Windows Defender.

After Googling this problem, it seems it is rather prevalent.  Here is the forum that suggested Avast may be the culprit.  After reading it, I ran some tests of my own.  And my tests seem to be in agreement.
http://msmvps.com/blogs/xperts64/archive/2005/09/06/65623.aspx

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8784
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #6 on: April 12, 2009, 04:43:48 AM »
You reference:
http://msmvps.com/blogs/xperts64/archive/2005/09/06/65623.aspx

That is for XP 64bit SP1 that occurred in 2005 and avast! has gone through many changes since then and I am sure that if other Vista 64bit users had problems with avast! I am sure that they would be jumping in saying Me too and would be complaining about this over at Smokey's Security Forums:
http://www.smokey-services.eu/forums/index.php?board=76.0

Look at this topic:
Troubleshoot driver problems in Vista
http://www.smokey-services.eu/forums/index.php/topic,24587.0.html

I just noticed a Vista 64bit user had their problem fixed in Reply #14
http://forum.avast.com/index.php?topic=44182.msg369804
« Last Edit: April 12, 2009, 04:58:20 AM by YoKenny »
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline gpzbc

  • Newbie
  • *
  • Posts: 13
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #7 on: April 12, 2009, 07:27:09 AM »
Thanks for the reply.  I read all of your links and none of them seem even remotely similar to what I am experiencing.  The solution that you reference in post #14 troubleshoots someone that is having a hard time installing Avast.  That is not my my situation.  For me, Avast is causing windows to hang on shut down.

I understand that Avast has undergone many changes since 2005, however the symptoms of my problem are similar.   That is why I referenced that forum.

Thanks again for your response and tips.  Unfortunately, I don't think they have helped me figure out why Avast is causing windows to hang on shut down.

I hope you or anyone else can help me figure this out.  Thanks!
« Last Edit: April 12, 2009, 09:54:15 AM by gpzbc »

Offline Adrian Ho

  • Newbie
  • *
  • Posts: 13
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #8 on: April 12, 2009, 11:34:03 AM »
Try exiting nvidia(if u are using nvidia)or other program from the system tray, I also had this problem and it was solved after I did this. You could do this thru msconfig and uncheck programs that are unnecessary at startup. I also thought it was avast! at first but when I did this I did not have problems shutting down anymore. Try it then you could tell me if it also worked for you.

Offline gpzbc

  • Newbie
  • *
  • Posts: 13
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #9 on: April 12, 2009, 11:40:29 PM »
Thank you for the nvidia tip.  I will run some tests and see if that helps.  I'll post back when I come to a conclusion.
Thanks again, Adrian Ho.

Offline gpzbc

  • Newbie
  • *
  • Posts: 13
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #10 on: April 13, 2009, 12:34:12 AM »
Well, there are no nvidia programs in the system tray.  And I have tried closing out of all programs in the system tray (except Avast) before I restart and it still hangs.

In MSConfig, there are three nvidia startups.  They are:
  • nvidia compatible windows vista display driver, version 176.44
  • nvidia media center library
  • nvidia hotkey service, version 176.44

And to be honest with you, I am nervous to disable those from startup.

Can you offer any advice?
Thanks!

Offline Alioth

  • Newbie
  • *
  • Posts: 19
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #11 on: April 13, 2009, 02:33:59 AM »
Hi, gpzbc. I also use a Vista 64 bits and once my computer also hanged during shutdown. It happened because I opened the CD tray when system was shutting down, so maybe the two problems are related.

I think your problem may be caused by the avast! ability to detect CDs, floppy disks and other removable media inserted into the computer when logging off (it is a remote possibility).

If you want to test it, you have to go to avast! settings -> Common settings and uncheck checkboxes "Check ... when logging off".

I hope it help you (sometimes miracles happen :))

Offline gpzbc

  • Newbie
  • *
  • Posts: 13
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #12 on: April 13, 2009, 08:34:10 AM »
Thanks very much for the advice.  I agree, that does seem like a possible cause.  Unfortunately, I looked at the settings and all of the "check ___ when logging off" boxes are already unchecked. 
So I don't think that is the cause.   :-\
Hmmm..

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8784
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #13 on: April 13, 2009, 10:34:58 AM »
Well, there are no nvidia programs in the system tray.  And I have tried closing out of all programs in the system tray (except Avast) before I restart and it still hangs.

In MSConfig, there are three nvidia startups.  They are:
  • nvidia compatible windows vista display driver, version 176.44
  • nvidia media center library
  • nvidia hotkey service, version 176.44

And to be honest with you, I am nervous to disable those from startup.

Can you offer any advice?
Thanks!
Its best to not use MSConfig as a start up manager at any time as it could seriously damage the operating system and leave it unable to boot. 
See BlackViper's comment about MSConfig:
Notes for a Happier Computer and User
• Do not use "msconfig" to disable services, type "services.msc" in the Run box instead!
http://www.blackviper.com/WinVista/servicecfg.htm

He has a listing of all Vista Services and what they do and recommended settings
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline Alioth

  • Newbie
  • *
  • Posts: 19
Re: On-Access Protection causes Vista to hang on shutdown
« Reply #14 on: April 14, 2009, 05:38:59 PM »
Hi again, gpzbc, I'm sorry my previous advice wasn't helpful.

Have you revised the Event Viewer? Maybe the cause of your problem was listed there (revise the System log specially).

Anyhow, I have another idea ;). Your problem may be due to the system is unable to end avast services, which may be due to the avast self-protection.

Again, if you want to test it, yo have to go to Avast settings -> Troubleshooting and check "Disable avast self-defense module"

Even if it solves your problem, disabling avast self-protection isn't safe, so you should ask for help to locate the conflict which causes the problem and solve it.