Author Topic: Windows 7 Ultimate 64 aswsp.sys blue screen  (Read 24176 times)

0 Members and 1 Guest are viewing this topic.

Offline acdcfan

  • Newbie
  • *
  • Posts: 15
Windows 7 Ultimate 64 aswsp.sys blue screen
« on: January 26, 2010, 02:24:31 PM »
I am not sure why this happen today....
It is fresh install of Windows 7, I have installed 5.0.377 program version...
I did have Avast screen saver running when this happened. I stopped and will see if it happens again...
In the mean time here is dump file from debug manager

WARNING: Whitespace at end of path element

Microsoft (R) Windows Debugger Version 6.11.0001.404 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Windows\Minidump\012610-27781-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

WARNING: Whitespace at end of path element
Symbol search path is: .sympath srv*c:\symbols*http://msdl.microsoft.com/download/symbols ;srv*c:\symbols*http://msdl.microsoft.com/download/symbols
Executable search path is:
Windows 7 Kernel Version 7600 MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16385.amd64fre.win7_rtm.090713-1255
Machine Name:
Kernel base = 0xfffff800`02812000 PsLoadedModuleList = 0xfffff800`02a4fe50
Debug session time: Tue Jan 26 20:51:31.617 2010 (GMT+8)
System Uptime: 0 days 5:25:17.351
Loading Kernel Symbols
...............................................................
................................................................
...........................
Loading User Symbols
Loading unloaded module list
......
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 50, {fffffa800914feea, 0, fffff88003ed4dd1, 0}

Unable to load image \SystemRoot\System32\Drivers\aswSP.SYS, Win32 error 0n2
*** WARNING: Unable to verify timestamp for aswSP.SYS
*** ERROR: Module load completed but symbols could not be loaded for aswSP.SYS

Could not read faulting driver name
Probably caused by : aswSP.SYS ( aswSP+5dd1 )

Followup: MachineOwner
---------

0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

PAGE_FAULT_IN_NONPAGED_AREA (50)
Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arguments:
Arg1: fffffa800914feea, memory referenced.
Arg2: 0000000000000000, value 0 = read operation, 1 = write operation.
Arg3: fffff88003ed4dd1, If non-zero, the instruction address which referenced the bad memory
   address.
Arg4: 0000000000000000, (reserved)

Debugging Details:
------------------


Could not read faulting driver name

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80002aba0e0
 fffffa800914feea

FAULTING_IP:
aswSP+5dd1
fffff880`03ed4dd1 f30f6f0401      movdqu  xmm0,xmmword ptr [rcx+rax]

MM_INTERNAL_CODE:  0

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x50

PROCESS_NAME:  avastSS.scr

CURRENT_IRQL:  0

TRAP_FRAME:  fffff88007782220 -- (.trap 0xfffff88007782220)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffffa800914e4e0 rbx=0000000000000000 rcx=0000000000001a02
rdx=fffff88003ee69ba rsi=0000000000000000 rdi=0000000000000000
rip=fffff88003ed4dd1 rsp=fffff880077823b0 rbp=fffffa8004886701
 r8=fffff8a00a847a6a  r9=0000000000000041 r10=fffff800029fe660
r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz na pe nc
aswSP+0x5dd1:
fffff880`03ed4dd1 f30f6f0401      movdqu  xmm0,xmmword ptr [rcx+rax] ds:6510:fffffa80`0914fee2=????????????????????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800029031e4 to fffff80002883f00

STACK_TEXT: 
fffff880`077820b8 fffff800`029031e4 : 00000000`00000050 fffffa80`0914feea 00000000`00000000 fffff880`07782220 : nt!KeBugCheckEx
fffff880`077820c0 fffff800`02881fee : 00000000`00000000 00000000`00000000 fffff8a0`07c19700 fffff880`0102547e : nt! ?? ::FNODOBFM::`string'+0x42907
fffff880`07782220 fffff880`03ed4dd1 : 00000000`00000000 00000000`00000044 00000000`00000039 fffff880`03ed8222 : nt!KiPageFault+0x16e
fffff880`077823b0 00000000`00000000 : 00000000`00000044 00000000`00000039 fffff880`03ed8222 fffff8a0`0a847901 : aswSP+0x5dd1


STACK_COMMAND:  kb

FOLLOWUP_IP:
aswSP+5dd1
fffff880`03ed4dd1 f30f6f0401      movdqu  xmm0,xmmword ptr [rcx+rax]

SYMBOL_STACK_INDEX:  3

SYMBOL_NAME:  aswSP+5dd1

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: aswSP

IMAGE_NAME:  aswSP.SYS

DEBUG_FLR_IMAGE_TIMESTAMP:  4b55b01b

FAILURE_BUCKET_ID:  X64_0x50_aswSP+5dd1

BUCKET_ID:  X64_0x50_aswSP+5dd1

Followup: MachineOwner

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11801
    • AVAST Software
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #1 on: January 26, 2010, 03:28:06 PM »
Can you please upload the dump to
Code: [Select]
ftp://ftp.avast.com/incomingThanks.

Offline acdcfan

  • Newbie
  • *
  • Posts: 15
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #2 on: January 27, 2010, 11:06:06 AM »
Can you please upload the dump to
Code: [Select]
ftp://ftp.avast.com/incomingThanks.



Not quite familiar how do I upload the file but what user name and password I need to log in.....  

Edit

Uploaded the dump file 012610-27781-01, I hope  I have done it right  because I can not see it either way

Edit 2
I don't think it got there
« Last Edit: January 27, 2010, 11:22:27 AM by acdcfan »

Offline logos

  • Avast √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 9441
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #3 on: January 27, 2010, 11:18:54 AM »
an easy way is to launch the avast ftp link in Internet Explorer, and from the options click on "Open FTP site" in Windows Explorer. Then you just do a drag and drop of your compressed dump file (compress it with WinZip or else before sending, that will spare you a lot of time)
w7 - ais7

Offline acdcfan

  • Newbie
  • *
  • Posts: 15
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #4 on: January 27, 2010, 11:23:08 AM »
an easy way is to launch the avast ftp link in Internet Explorer, and from the options click on "Open FTP site" in Windows Explorer. Then you just do a drag and drop of your compressed dump file (compress it with WinZip or else before sending, that will spare you a lot of time)


I have tried it.... please refer image above for error I have been getting

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11801
    • AVAST Software
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #5 on: January 27, 2010, 11:31:04 AM »
Got the dump file, thanks.

Offline acdcfan

  • Newbie
  • *
  • Posts: 15
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #6 on: January 27, 2010, 11:40:26 AM »
Got the dump file, thanks.



And could not even see it after first upload... thanks for letting me know

Offline Sean Huong

  • Newbie
  • *
  • Posts: 15
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #7 on: January 27, 2010, 12:36:33 PM »
I'm not sure if this is the correct location to address my problem but i have similar problem on mine except my windows 7 is 32bit.

i have used avast home edition 4.8 for years and  i was very happy with it.
I decided to purchase the AIS 5.0 with license. i have upgraded it. Since then i got the blue screen few times a day and it keeps showing up more and more often and finally i cannot work on my PC at all because each time windows completely restarted, it requested to send the report to Microsoft with some files (WER-XXXXXX-X.sysdata.xml and mmddyy-XXXXX-01.dmp), then it was the time of the blue screen to show up again, etc...

I decided to uninstall it and go back to avast home edition 4.8 and my PC is now back to the normal state.

What should i do? what about the a license i purchased?

Offline logos

  • Avast √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 9441
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #8 on: January 27, 2010, 12:44:24 PM »
no, it's another issue you got there. You should have started your own thread  ;) I know you already uninstalled Avast 5 but just in case you give it a new try, disable the behavior shield and see if you get better results. Also, there's a pre-release version of the next updated version here:
http://forum.avast.com/index.php?topic=54451.0
w7 - ais7

Offline Sean Huong

  • Newbie
  • *
  • Posts: 15
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #9 on: January 28, 2010, 12:44:33 AM »
Thank for advise. I'll do it and will let you know.

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2085
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #10 on: January 28, 2010, 12:54:36 AM »
This bug is already fixed in pre-release version as Logos pointed out.

Offline Sean Huong

  • Newbie
  • *
  • Posts: 15
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #11 on: January 28, 2010, 04:05:23 AM »
How can i access to the download page of the pre-release 5.0.394?

Offline cazoza

  • Full Member
  • ***
  • Posts: 140
  • a pretty malwarefighter! dont u think?
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #12 on: January 28, 2010, 04:34:28 AM »
How can i access to the download page of the pre-release 5.0.394?
Just click on the link i provide from another post in the forum, and download the new pre-release 5.0.394.
http://forum.avast.com/index.php?topic=54491.0, all versions are there. Take care pal!

PS. I have win 7 ultimate 64 bits, and with the pre-release i have no problems.
Our actions define who we are

MoBo ASUS P5QC
ATI HD3650 1 Gb RAM PCI-E 2.0
Win 7 Ultimate x64
Quad Core q6600 2.4 GHz
8 Gb RAM DDR2 800 MHz
500 Gb HDD SATA2 32 Mb Buffer 7200 RPM

Avast 5.0.462 Free
Outpost Firewall Pro 2009 v6.7.3

Offline Sean Huong

  • Newbie
  • *
  • Posts: 15
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #13 on: January 28, 2010, 04:42:29 AM »
Logos,

i have tried re-installed the ais 5.0.377 and disable the behavior shield but still the blue screen is happening 2 times within 10 minutes. Now working in safe mode. waiting for 394 to be downloaded and will re-try a shot and i do hope it will work fine or it will be very disappointing.

Offline cazoza

  • Full Member
  • ***
  • Posts: 140
  • a pretty malwarefighter! dont u think?
Re: Windows 7 Ultimate 64 aswsp.sys blue screen
« Reply #14 on: January 28, 2010, 06:26:33 AM »
Keep us informed, so we can help you more pal. Take care, hope the pre-release helps to solve your problem, it solved mine with 5 pro, at work.
Our actions define who we are

MoBo ASUS P5QC
ATI HD3650 1 Gb RAM PCI-E 2.0
Win 7 Ultimate x64
Quad Core q6600 2.4 GHz
8 Gb RAM DDR2 800 MHz
500 Gb HDD SATA2 32 Mb Buffer 7200 RPM

Avast 5.0.462 Free
Outpost Firewall Pro 2009 v6.7.3