Author Topic: AVAST free 5.0.396 i find a small bug.  (Read 8285 times)

0 Members and 1 Guest are viewing this topic.

waking

  • Guest
Re: AVAST free 5.0.396 i find a small bug.
« Reply #15 on: February 01, 2010, 08:50:29 PM »
Then address them if you feel they have been missed, because I can't.

I *have* "addressed" them - by attempting to restate the issues in the hope that it
might elicit an "official" reply from the only people who can authoritatively answer
the questions: the avast! developers.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 86949
  • No support PMs thanks
Re: AVAST free 5.0.396 i find a small bug.
« Reply #16 on: February 01, 2010, 09:45:36 PM »
If that is the case why address me at all, as I'm not an avast developer but an avast user.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.9.6034 (build 22.9.7554.734) UI 1.0.728/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

waking

  • Guest
Re: AVAST free 5.0.396 i find a small bug.
« Reply #17 on: February 01, 2010, 09:59:45 PM »
If that is the case why address me at all ...

Because you posted a reply relating to the issue of why some infections *cannot* be
repaired. While correct and accurate, it did not address the *actual* question asked:
Why is the "Repair" option offered for a given file before it's moved to the Chest but not
offered for that same file after it's moved there?

My post was addressed to "DavidR et al" - i.e. - "... and others"
If I had been aware that you were the sensitive type I would have omitted
your name.   ::)

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 86949
  • No support PMs thanks
Re: AVAST free 5.0.396 i find a small bug.
« Reply #18 on: February 01, 2010, 10:11:13 PM »
It has nothing to do with sensitivity, but one of sensibility, if I knew what to do about it then I would have addressed it, I already said it doesn't appear to effect my system so I 'can't check it out.'
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.9.6034 (build 22.9.7554.734) UI 1.0.728/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Cako

  • Guest
Re: AVAST free 5.0.396 i find a small bug.
« Reply #19 on: February 02, 2010, 12:01:35 AM »
ok guys.
are really two problems.
1) the name of the virus does not appear after the virus is placed in the virus chest,this is a master bug.
2) I found this second, not appears the repair option after the virus is placed in the virus chest,just before.

well,the only ones who can fix this bug are the engineers of AVAST.
it actually exists and is happening to many users.
who do not have this problem, congratulations.
but for me and others users it is a problem.

DavidR
Quote
Trojans generally can't be repaired, because the entire content of the file is malware, so it is either move to chest or delete, move to the chest being the best option (first do no harm). When a file is in the chest it can't do any harm and you can investigate the infected warning.

Only true virus infection can be repaired, e.g. when a virus infects a file it adds a small part to it, then it may be possible to repair the file to its uninfected state.

However, for the most part so called viruses, trojans (adware/spyware/malware, etc.) can't be repaired because the complete content of the file is malicious.

everything you said I already know,thanks.
the problem is two.
I just think it should have the option to repair the file in the virus chest
My inteded was notify and see if anyone else has this bug.

waking
your contribution was very useful..
thanks for help.

let's see if the next version of avast these bugs will be fixed.
« Last Edit: February 02, 2010, 12:09:15 AM by Cako »

Cako

  • Guest
Re: AVAST free 5.0.396 i find a small bug.
« Reply #20 on: February 07, 2010, 04:32:27 PM »
Its there I just didn't scroll all the way over.

I can't recall if I scanned them in the chest or not I was just sending some samples to the chest as a test to populate it.

just to remind,
this bug happens when you send the file to the virus chest, if only you make a individual file scan.
after a individual file scan.