Author Topic: Avast Firewall hogging CPU time, PC unusable...  (Read 20552 times)

0 Members and 1 Guest are viewing this topic.

Offline PCCChris

  • Newbie
  • *
  • Posts: 4
Avast Firewall hogging CPU time, PC unusable...
« on: February 15, 2010, 02:17:44 PM »
Hi fellow forum members...
We have a Dell Dimension 4600i in for repair.  The owner had been using Avast Free edition until his yearly license expired.  He liked Avast that much that he purchased the Full Internet Security Suite.  However, after installing it, he became very frustrated as the PC would freeze up and become unusable within 3 - 4 minutes after bootup.

He brought the system to ourselves for diagnosis.  I have noticed that once the Avast Firewall process starts (afwServ.exe), it utilises 50% total of the CPU time (This PC has 1 Physical CPU, 2 logical processors (Hyper-Threaded)).  After a couple of mins this then jumps to 99% and the Entire PC becomes unusable and the PC has to be powered down and restarted.  If I disable the Firewall module before the 99% CPU usage happens, the system is OK and then re-enabling the module causes the same thing to happen - 50% for about 1 - 2 minutes then 99% is hit.  I have also noticed that the Windows Firewall is not disabled whenever the Avast Firewall is enabled, is this supposed to be the case?  Enabling/Disabling the Windows Firewall makes no difference anyhow.  The system has been scanned for Spyware/Malware and came out clean, Malwarebytes was used.  I have backed up his Avast License and re-installed Avast Internet Security but the same symptoms still occur.

Does anyone out there have any idea's why this is occuring and any fixes?  I have noticed from other Forums that this is Alwil's first attempt at their own Software Firewall - is this true and am I (or the PC owner) going to have to wait until this issue has been acknowledged and addressed?  Thanks for reading this post and I look forward to any replies!

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #1 on: February 15, 2010, 03:41:17 PM »
1. is he using the latest version (5.0.418)?
2. what operating system was he using?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline PCCChris

  • Newbie
  • *
  • Posts: 4
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #2 on: February 15, 2010, 04:11:07 PM »
Hi Vlk,

Thanks for responding...
The PC is running XP Home Edition SP3, fully updated and Avast version is 5.0.418.

Taa,


Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #3 on: February 15, 2010, 05:29:53 PM »
Thanks for the info so far.
Do you still have access to the machine? It would be interesting to take a memory dump of the afwServ.exe at the moment it's happening.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline PCCChris

  • Newbie
  • *
  • Posts: 4
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #4 on: February 16, 2010, 11:35:38 AM »
Thanks Vlk,

I'm not able to access the PC just now as I'm offsite at another Client...  I have contacted a couple of my colleagues and one of them shall do this when they get the chance.

I used MSConfig to disable all Startup entries and the system seemed to behave itself so I'm hoping to isolate whichever program is causing this.  The PC also runs the Gemstat card reader software which I (as well as my colleagues) have seen cause several problems with AV/Firewall software, so hopefully, I can isolate/resolve the problem and once I know exactly what has caused this, I shall repost with my findings...

Offline cfsjr007

  • Newbie
  • *
  • Posts: 2
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #5 on: February 16, 2010, 10:08:58 PM »
Hi Vlk,
I'm seeing the same situation also on a Dimension 4600. What I did so far was as soon as the computer boots I disable the firewall via the UI. Now everything seems to be working fine except that the firewall is disabled.

Windows Home Version 2002 w/SP3, Avast version 5.0.418 Internet security, licensed.

I would like to contribute to fixing this problem. I have the machine on-site right now.

EDIT:
FIX? The problem was right after installation and restart. I forced a restart via "one finger salute". Upon rebooting and as soon as windows started I disabled the firewall. I restarted windows again. Now Windows came up with Avast firewall disabled...I watched the processes and noticed the setup was completing...and I brought up the UI.

Now I am presented with the FIX NOW option. After noticing that all the post setup processes seemed to be done I went ahead and clicked the FIX NOW to start the firewall. Now the status/summary shows Secured and firewall no longer at 99% CPU utilization.


I'm going to restart one more time and see if it stays secured with the awfserv.exe NOT at 99% CPU utilization.

DC
« Last Edit: February 16, 2010, 10:17:55 PM by cfsjr007 »

Offline cfsjr007

  • Newbie
  • *
  • Posts: 2
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #6 on: February 16, 2010, 10:39:39 PM »
restarting mades things bad again  :(

the firewall process was up to 99% again. The customer decided not to bother fixing it and said they needed their computer back. Unfortunately I will be uninstalling 5.0 AIS.

Sorry, I wanted contribute to finding the bug, but I won't be able to now.

DC
« Last Edit: February 16, 2010, 10:41:42 PM by cfsjr007 »

Offline ltoo

  • Newbie
  • *
  • Posts: 2
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #7 on: March 01, 2010, 12:37:48 PM »
Hi there,

I have the same problem with the afwServ.exe process hogging the CPU on a Toshiba laptop. I have the avast! Internet Security suite 5.0.418 installed on a Dell PC (Vista) and a Toshiba laptop (XP Professional), but it only happens on the laptop. Even on the laptop it does not happen always, sometime the machine starts properly and I can use it without any problems. For the time being I have disabled the firewall permanently and the afwServ.exe service has disappeared from the TaskManager.
I am happy to provide info, like log files, dumps etc, but I need instructions and to get this problem fixed reasonably soon.

Regards,
ltoo

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67250
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #8 on: March 01, 2010, 12:43:34 PM »
The guidelines for solving using too much CPU/RAM would be something like discovering which program is accessing the Internet, if avast is not scanning anything at that time, which provider is being used.
Also other security programs installed, old 3rd party firewalls, etc.
The best things in life are free.

Offline ltoo

  • Newbie
  • *
  • Posts: 2
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #9 on: March 01, 2010, 01:04:26 PM »
Hi Tech,
Thanx for the reply. When this happens, it is quite soon after the startup, before I even start a browser or any other application using the internet. The only ones that I can blame are any Microsoft updates that might take place without me knowing and Skype which signs on automatically. However, all these were working with the previous version of avast! and still work on the other PC. I do not have other antivirus S/W, but the firewall provided by Windows is on. I will try to turn it off (when I can get my hands on the laptop) and see what happens.
ltoo

Offline bong2x

  • Poster
  • *
  • Posts: 474
  • My system Protector is avast
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #10 on: March 01, 2010, 01:45:30 PM »
its happen some rookit inserted to the updates, all updates, properties unable to access boot.ini for some kind of higher fragments that creating boot folder hidden, boot back up. no anti virus can recognize coz its pure file, but it will reforming to your comp. and one text format activate it from cookies. i don't know what is that.
i'm sorry i don't know what im saying im posses with the virus ;D
Hardware
Intel Core 2 Duo @ 2.20GHz,3GB RAM.
Software
OS->WinXp-pro Sp3.
Protection->avast Free 6.0.1091,MBAM,SAS
Browser->Firefox 4.0,IE8,G-chrome
Emergency Interface->unlocker 1.8.9

Life is a continue process of learning

Offline PCCChris

  • Newbie
  • *
  • Posts: 4
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #11 on: March 10, 2010, 11:23:47 PM »
 :)
FIXED!!!
Apologies to you all for my massive delay in getting this addressed and resolved...

It was the Logitech Desktop Messenger software causing this problem on the system I was repairing!
Client never uses it so it was removed.

After 2 - 3 minutes, one of the Logical processors would be at 100% usage with the Logitech Desktop Messeger process at 50%...  Killing the process crashed the PC.  Disabled the process for startup, everything was OK.  Therefore deleted.........

Advice I would give to anyone with similar problems - Keep the Task Manager open and keep a close eye until the CPU usage goes skyhigh...

Thanks for all your input into this topic!  EVERYONE!!! ;)

Offline R.T.Lionheart

  • Newbie
  • *
  • Posts: 1
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #12 on: March 28, 2010, 11:24:36 PM »
I have the problem, that after having used the free version of Avast for a year and then registered Avast 5. Then my PC (Medion prof. Intel Pentium D, 3 GHz, 1 GB RAM)was paralysed after 5 – 10 minutes after start and unable to react to the mouse.

After restart with the net cable unplugged, the “afwServ.exe” uses 49 – 51% of the power.
Change of the firewall setting does not seam to have an influence, but unplugging the net cable rises the CPU use to 50 – 100%. Does anybody have a cure?

Offline ogl

  • Newbie
  • *
  • Posts: 1
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #13 on: April 01, 2010, 09:49:49 AM »
I too have the same problem.  Just installed Avast 5 (registered copy) after being a LONG TERM Norton's user and getting soooo frustrated with pc slow down.  I installed one version on my kids' newer pc (atom-based) and it's absolutely fine.  Installed onto our home PC (older Compaq Presario Athlon 1.8G with 1G RAM) and have the same problem with afwServ consuming 99% of CPU (!!!!).

I've now disabled the firewall, and what-do-ya-know?  It seems to work ok.  But this isn't the fix - Please help Team-Avast!!!??? :(

Offline thecam

  • Newbie
  • *
  • Posts: 4
Re: Avast Firewall hogging CPU time, PC unusable...
« Reply #14 on: April 13, 2010, 03:35:27 AM »
I installed the latest as of last Friday on two computers - both have Logitech Desktop Messenger and both running XP SP3 (32 bit) - and Avast Internet Security works fine on one computer, but I'm have the firewall hogging CPU problem on the other that makes it completely unusable.  Starting the computer with the hogging problem with the network cable unplugged avoids the problem as does turning off the firewall.  I did find that if I delete the firewall rules for Avast, and then plug in the network cable, Avast creates new rules and the computer works fine until I reboot - when I reboot (with the network cable connected) I get the CPU hogging problem again.  So I am using the AVG trial on the problematic computer for now.  I hope Avast will have this problem resolved soon so I can use it on both computers.