Author Topic: RPC failing to load and recovery  (Read 4167 times)

0 Members and 1 Guest are viewing this topic.

GOK

  • Guest
RPC failing to load and recovery
« on: July 22, 2010, 12:02:57 PM »
Hi there,

Running Windows XP SP3 and installed latest Avast thru update.
The system was working for a week or two, but is now starting in Safe Mode and is extremely slow to boot. The boot fails and I am informed that Avast is not starting. Cannot go on line as unavailable. Looking at the Services tab when running msconfig, I note that the RPC Locator has stopped and this is essential for running. I attempt to start this by using the diagnostic start up feature and tool hangs...

Not sure where to start here...

GOK

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: RPC failing to load and recovery
« Reply #1 on: July 22, 2010, 04:28:52 PM »
I suggest an installation from scratch:

1. Download the latest version of avast! Uninstall Utility and save it.
2. Download the latest avast! version and save it.
3. Uninstall avast from Control Panel (if possible). If, for any reason, you can't run it, try booting in Safe Mode and doing it from there. Anyway, boot after that.
4. Run the avast! Uninstall Utility saved on 1. If, for any reason, you can't run it, try booting in Safe Mode and doing it from there. Anyway, boot after you've run it.
5. Install avast! using the setup saved on 2. Boot.
6. Register your free copy or add the license key for Pro.
7. Check and post the results.

If it helps, you can try http://soluto.com to test your boot time.
The best things in life are free.

Offline mikaelrask

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1556
Re: RPC failing to load and recovery
« Reply #2 on: July 22, 2010, 04:36:14 PM »
tech you where a bit faster then me to respond there  :D
Windows 8.1 amd a10-5700 64 bit
12 GB ram 1 tb hard drive. Avast 18, MBAM

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: RPC failing to load and recovery
« Reply #3 on: July 22, 2010, 04:39:07 PM »
tech you where a bit faster then me to respond there  :D
Never mind. Will you post the same? Any other suggestion for GOK?
The best things in life are free.

GOK

  • Guest
Re: RPC failing to load and recovery
« Reply #4 on: July 22, 2010, 05:15:11 PM »
Cannot connect to internet through this system...
The RPC is down and so when I try to connect to the internet I get the diagnostic error...

Network Adaptor identification
Failed with error 0x80070422. the service cannot be started, either because the it is disabled or because it has no enabled devices associated with it.

I need the wireless component to work to connect to the internet. That is the root cause methinks.
Question is how to verify it? It is connected and functioning.

Offline mkis

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1618
Re: RPC failing to load and recovery
« Reply #5 on: July 22, 2010, 05:32:33 PM »
here is a Microsoft link
http://support.microsoft.com/kb/958043

also go to Services and check that Remote Procedure Call (RPC) is set to started and automatic
Start-> rightclick (My) Computer, and choose Manage, click through Services and Applications to open Services
Avast7 Free, MBAM (on demand), MVPS Hosts

Intel DG41TY, Windows 7 Ultimate, IE9, Google Chrome, 4 GB ram, Secunia PSI, ccleaner, Foxit Reader, Faststone Image viewer, MWSnap.