Author Topic: CCLEANER running slow  (Read 11426 times)

0 Members and 1 Guest are viewing this topic.

Offline slybo

  • Sr. Member
  • ****
  • Posts: 327
CCLEANER running slow
« on: January 20, 2011, 08:02:04 PM »
I notice after the first of the recent program updates of avast ccleaner would take about 60 seconds to clean instead of the usual 3 or 4 seconds. This only happens on my Windows 7 64bit, does not happen on xp or vista computer that I have. This is not causing a problem but wanted avast to know so they can check on it, has anyone else noticed this? I am using ccleaner version 3.02.1343, which is the latest. I did try to uninstall and reinstall ccleaner but it made no difference. I have done all the avast updates from the program UI. Thanks sly

Offline mag

  • Advanced Poster
  • **
  • Posts: 740
Re: CCLEANER running slow
« Reply #1 on: January 20, 2011, 08:08:26 PM »
I've had this issue for a while (I don't think it is avast related). Does unchecking internet explorer history speed things up?

Offline slybo

  • Sr. Member
  • ****
  • Posts: 327
Re: CCLEANER running slow
« Reply #2 on: January 20, 2011, 08:11:32 PM »
Did not try that but have noticed that ccleaner seems to hang on internet explorer history when cleaning. Did not try that because I do want it to clean the history.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: CCLEANER running slow
« Reply #3 on: January 20, 2011, 08:39:40 PM »
I've had this issue for a while (I don't think it is avast related). Does unchecking internet explorer history speed things up?
Only testing...
I'm facing no problems with CCleaner. Although I run it scheduled and don't worry too much on how it takes.
The best things in life are free.

Offline mag

  • Advanced Poster
  • **
  • Posts: 740
Re: CCLEANER running slow
« Reply #4 on: January 20, 2011, 08:47:40 PM »
I only see it on 64 bit. I don't think it is to do with ccleaner, since it takes just as long if I clear IE history from within IE.

It's not a major problem for me (since I don't use IE anyway!).

Offline slybo

  • Sr. Member
  • ****
  • Posts: 327
Re: CCLEANER running slow
« Reply #5 on: January 20, 2011, 08:55:27 PM »
Yes forgot to say I have also noticed it running slow form within IE, just thought it might all be related to Behavior Shield. If not will see if next version of ccleaner does any better.

Offline mag

  • Advanced Poster
  • **
  • Posts: 740
Re: CCLEANER running slow
« Reply #6 on: January 20, 2011, 10:16:13 PM »
One more odd thing I noticed about this issue. If you enable the guest account on windows 7 you will probably find that ccleaner runs at normal speed on it. I think the problem lies with IE, not ccleaner or avast - but I don't know what it might be.

Offline logos

  • Avast √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 9441
Re: CCLEANER running slow
« Reply #7 on: January 20, 2011, 10:42:00 PM »
I've had this problem on a previous Windows install... no idea how it happened, I had several issues in Windows suddenly at the same time and CCleaner getting stuck on IE data was one of them. Re-installed Windows and all the issues were gone of course. That was about two months ago...I think.

edit: I'm running IE9 beta, not sure if that's related.
« Last Edit: January 20, 2011, 10:43:43 PM by Logos »
w7 - ais7

Offline mag

  • Advanced Poster
  • **
  • Posts: 740
Re: CCLEANER running slow
« Reply #8 on: January 20, 2011, 11:21:56 PM »
Thanks for the input. IE8/IE9 makes no difference - I've tried both.

Now that you mention it, I think my problems with IE history and ccleaner did start round about the time I had a major windows issue after one of my system restore/avast problems.

Offline Silk0

  • Poster
  • *
  • Posts: 482
  • Octo Live
Re: CCLEANER running slow
« Reply #9 on: January 21, 2011, 12:18:22 AM »
I noticed a long wait with the search option of CCleaner on avast! 5.1.864 and 5.1.874 (if i'm not mistaken)
The search time passed from 0.300 sec and something to 18 seconds!
And in that time a process from avast! (sf.bin) was wasting 80% of the CPU.
With the last PR of avast! and the final version everything came back to normal.
« Last Edit: January 21, 2011, 12:25:35 AM by Silk0 »
~ Silk0
Avast! Free 6.0.1367

Offline mag

  • Advanced Poster
  • **
  • Posts: 740
Re: CCLEANER running slow
« Reply #10 on: January 21, 2011, 07:24:03 PM »
In my case the hang is during the clean phase, not the analyse phase.

I think Logos probably has the right explanation - it is a windows/IE corruption problem.

Trouble is I hate reinstalling windows - endless updates and reboots to go through, and always a chance it then decides it isn't genuine any more.