Author Topic: Avast 6 Free and smb problem  (Read 24428 times)

0 Members and 1 Guest are viewing this topic.

Igorella

  • Guest
Re: Avast 6 Free and smb problem
« Reply #15 on: March 19, 2011, 04:38:56 AM »
Similar problem here: after 6.0 update smb client (Mac desktop) sees only limited number of subfolders shared on the Win 7 machine; as experiment, I created the following situation: shared folder has N folders, of which only N-1 are showing in Mac's Finder. If I add 1 more subfolder preceding the original N subfolders in the sort sequence, then the last shown folder "drops off the radar", i.e. only N-2 folders showing, and missing folders are the last 2 in the sequence. I got an impression that alpha named and numerically named subfolders are treated separately, so that in the subfolders named
100
200
300
...
...
999
abc
bbc
ccc
ddd
 when I create subfolder 001, 999 disappears from smb client, but ddd stays visible.
I read elsewhere, that the problem can be solved by reverting to the previous version of Avast! but am reluctant to give 6.0 up, and am holding my breath for a quick bug fix

Over to you, avast!
 

Assimilator

  • Guest
Re: Avast 6 Free and smb problem
« Reply #16 on: March 20, 2011, 12:12:00 AM »
I can also confirm that this broke my abillity to view certain files and folders while browsing my win 7 64bit SMB shares from XBMC running on an old XBOX and an apple TV2.

Uninstalled Avast and went back to Avira

glad I never paied money for it nice work guys.
Guess this improtant issue sliped the QA testing.
Pitty becasue avast was loking to be the best free AV I had found. 

doktornotor

  • Guest
Re: Avast 6 Free and smb problem
« Reply #17 on: March 20, 2011, 12:25:19 AM »
glad I never paied money for it nice work guys.
Guess this improtant issue sliped the QA testing.
Pitty becasue avast was loking to be the best free AV I had found.  

I have been waiting a couple of months for Avira to fix even the most ridiculous issues in their shiny new v10 when they released it. No luck, plus all I got was completely useless antispam-restricted forum where people cannot reply to threads started by others and moderators asking for completely irrelevant HTJ or whatnot logs. Good luck with whatever AV you choose anyway.

P.S. Someone reported that SMB browsing/listing is already fixed in 6.0.1035 prerelease: http://forum.avast.com/index.php?topic=74149.0 Patience FTW  ::)

LordDWT

  • Guest
Re: Avast 6 Free and smb problem
« Reply #18 on: April 07, 2011, 07:56:12 PM »
This issue was suppose to be fixed in this build of avast according to post:
http://forum.avast.com/index.php?topic=69618.msg584532#msg584532

This apparently is still an issue because I can uninstall avast 6 and SMB works perfect.

This previous workaround is no longer valid as this is no longer an option under change:
http://forum.avast.com/index.php?topic=69618.msg584905#msg584905

Although in the new pre-release this seems to have been corrected.
You can install it from here:
http://forum.avast.com/index.php?topic=74515.0
« Last Edit: April 07, 2011, 08:50:46 PM by LordDWT »

simonk83

  • Guest
Re: Avast 6 Free and smb problem
« Reply #19 on: April 08, 2011, 03:07:29 AM »
I though the latest pre-release had fixed it (seemed to), but last night I noticed a new folder wasn't being picked up by my Boxee Box again so I'm assuming it's still broken.   

ravi16aug

  • Guest
Re: Avast 6 Free and smb problem
« Reply #20 on: April 08, 2011, 06:10:37 PM »
I'll be damned, and all this time I thought that the SMB implementation between Mac-Windows was broken. I copied many folders over to my MacBook Pro from my Windows 7 notebook running avast 6. Later I found that many files were missing from those folders. Also, many times I was unable to see the Windows 7 notebook in sidebar of my Finder window. avast 6 is gonna be yanked out of my Win 7 machine for the time being. Not sure if this is limited to a particular shield.

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2085
Re: Avast 6 Free and smb problem
« Reply #21 on: April 10, 2011, 05:26:44 PM »
This bug was fixed in Mar/17/2011 7:50 PM
build 1044 was released in Mar 23

Offline Ashish Singh

  • Poster
  • *
  • Posts: 437
  • Proud to be an Indian
    • Quick Heal
Re: Avast 6 Free and smb problem
« Reply #22 on: April 10, 2011, 06:01:22 PM »
check this version plz tell if this works for you or not..
If it doesn't work then wait for a few days as a new version is coming soon

Download links:
Free AV: http://files.avast.com/files/beta/6.0.1044/setup_av_free.exe
Pro AV: http://files.avast.com/files/beta/6.0.1044/setup_av_pro.exe
Internet Security: http://files.avast.com/files/beta/6.0.1044/setup_ais.exe
Windows 7 Ultimate(32 bit), avast! free (always latest released or beta), Intel Core2Duo, 2GB RAM, Outpost Firewall Pro 7.5,IE 9,TuneUp Utilities 2011,Diskeeper 2011

http://www.incredibleindia.org 

Caution! Online world is full of man made Aliens

BlkDraggon

  • Guest
Re: Avast 6 Free and smb problem
« Reply #23 on: April 13, 2011, 09:21:13 PM »
I had exactly the same problem and this beta version (free one!) worked!!!!

 ;D ;D ;D

Thanks Ashish!!!

LordDWT

  • Guest
Re: Avast 6 Free and smb problem
« Reply #24 on: April 14, 2011, 03:39:20 PM »
check this version plz tell if this works for you or not..
If it doesn't work then wait for a few days as a new version is coming soon

Download links:
Free AV: http://files.avast.com/files/beta/6.0.1044/setup_av_free.exe
Pro AV: http://files.avast.com/files/beta/6.0.1044/setup_av_pro.exe
Internet Security: http://files.avast.com/files/beta/6.0.1044/setup_ais.exe

In Avast 6.0.1044 the SMB share issue is fixed and I have verified working on my equipment.

ravi16aug

  • Guest
Re: Avast 6 Free and smb problem
« Reply #25 on: April 14, 2011, 04:25:34 PM »
You guys can't let one stay away for long, can you.  ;)

SplittingDistant

  • Guest
Re: Avast 6 Free and smb problem
« Reply #26 on: April 14, 2011, 08:22:15 PM »
Hi,

I too had the missing folders problem on my WDTV Live box when streaming form my Windows 7 64 bit SP1 box. Initially I wasn't too bothered as it seemed to be the SMB bug referred to in this thread, so I was content to wait for a fix and when I noticed the forum post about the pre-release version which fixed the issue I applied it and all was again back to normal.

However, fate then too a hand, and after a power cut I discovered the partition containing my media file was corrupt. I wasn't too concerned, as a born worrier I copy (using windows explorer) my media files to a second system which resides on my network, as a backup.

When I came to look at the backup media files on this second system I discovered to my horror that there were missing folders, and that the folders missing were exactly the same as the folders missing when viewed on the original system by my WDTV Live before I applied the pre-release program fix.

It appears that I had performed my "back up" copy to my second system BEFORE I applied the pre-release fix and (possibly) this bug had prevented the same folders which were "missing" on the WDTV Live from being copied to the second machine.

Luckily I managed to recover the corrupt partition by another method so I didn't lose anything.

If I'm correct (and that's by no means a certainty!) this means that this bug may be considerably more potent than originally thought, and may have lingering effects.

I wonder if there is anyone out there who can check to see if a similar thing has happened to them, and for everyone it might well be worthwhile checking any backups made while Avast was misbehaving.

I would stress again that I might not be correct in my understanding / assumptions and I offer this only as an observation of my specific problem, and unless others can confirm my findings I'll be more than happy to continue using Avast myself, and put the whole sorry thing down to me being a Muppet.

So over to you Avast users.......................................



stduc

  • Guest
Re: Avast 6 Free and smb problem
« Reply #27 on: April 18, 2011, 11:54:34 AM »
I have the same issue with missing files on network drives - more than 92 files in a folder and I can't see some of them. For example I can only see 109 files in a folder that has 131 files!

Any news on what Avast are doing to fix this? I'm not sure I want to try the bete version. I am currently on Avast 6.0.1000

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2085
Re: Avast 6 Free and smb problem
« Reply #28 on: April 18, 2011, 12:12:35 PM »
stduc: it's fixed in beta version; new official version is going to be released very soon (maybe today), so you can wait

Offline Ashish Singh

  • Poster
  • *
  • Posts: 437
  • Proud to be an Indian
    • Quick Heal
Re: Avast 6 Free and smb problem
« Reply #29 on: April 18, 2011, 12:17:28 PM »
I had exactly the same problem and this beta version (free one!) worked!!!!

 ;D ;D ;D

Thanks Ashish!!!

You are welcome..  ;)

I have the same issue with missing files on network drives - more than 92 files in a folder and I can't see some of them. For example I can only see 109 files in a folder that has 131 files!

Any news on what Avast are doing to fix this? I'm not sure I want to try the bete version. I am currently on Avast 6.0.1000


stduc: it's fixed in beta version; new official version is going to be released very soon (maybe today), so you can wait

Till then if you don't have patience then you can try this

Download links:
Free AV: http://files.avast.com/files/beta/6.0.1086/setup_av_free.exe
Pro AV: http://files.avast.com/files/beta/6.0.1086/setup_av_pro.exe
Internet Security: http://files.avast.com/files/beta/6.0.1086/setup_ais.exe

You can either install from scratch, or over an existing installation of avast (any version). Users of the previous pre-release builds (6.0.1021, 6.0.1027, 6.0.1035, 6.0.1044) can also use the built-in program updater.

Thanks
Ashish

Windows 7 Ultimate(32 bit), avast! free (always latest released or beta), Intel Core2Duo, 2GB RAM, Outpost Firewall Pro 7.5,IE 9,TuneUp Utilities 2011,Diskeeper 2011

http://www.incredibleindia.org 

Caution! Online world is full of man made Aliens