Author Topic: [RESOLVED] avast 6.0.1 free wont update  (Read 28695 times)

0 Members and 1 Guest are viewing this topic.

galocza

  • Guest
[RESOLVED] avast 6.0.1 free wont update
« on: March 04, 2011, 08:37:08 PM »
hi,

after reinstalling windows (xp x64), i installed avast (25th february). since then it doesnt update automatically. it doesnt give me any error messages, the update just starts, a little bit of the orange bar appears and just stays that way, no update, no failed message, nothing.

-starting it from within the program: doesnt work
-starting from tray: doesnt work
-downloading and installing the virus definition files manually: OK
-updating from add/remove programs: OK

i tried:
-rebooting
-repairing the installation
-removing (using the removal tool) and reinstalling
-scanning my system with avast (with the updated def files), malwarebytes and spybot search&destroy: no threats

nothing seems to work.

please if you have ideas, share it, i dont know what i did wrong (ive used avast for years no problems until now).
thanks,
g
« Last Edit: April 07, 2011, 05:48:30 PM by galocza »

norhuma

  • Guest
Re: avast 6.0.1 free wont update
« Reply #1 on: March 04, 2011, 08:56:53 PM »
Hey.

Nearly identical problem in my case. BTW, I can open another thread if that's the custom on this forum, but for now I'll just start describing my problem here since it sounds pretty similar.

My system: Windows 7 Professional 64, with Service Pack 1.

I installed Avast 6.0.1000 (from a cnet download), custom installation *without* the web reputation plugin and the gadget option, but all other options are installed.

My problem: Avast doesn't seem to update, no matter what I do. No autoupdate took place so far (even though it's well past the update interval), and a manual virus or program update doesn't give any result either, it just gets stuck at "initializing, please wait".

Netxt thing I did was downloading the virus definition file from the avast website and executed it, which gave me the Windows message that the defintions have been updated, but the avast main window still says that the definitions are outdated.

The main window also states that the *program* version is outdated: It gives the current version as "6.0.1000", in red, in the summary, and under maintenance it says: "a new version of the program is available! Latest program version: 0.0.0". Seems to be a bug, no?

Here's what I've tried already:
- reboot
- repair
- just now: full uninstall (with the uninstall tool, from Windows safe mode), then reinstall

Still, nothing changed, still no update (or at least no update occurs according to the Avast main window. After all, it's possible that internally the update works, and it's just the displayed information that's wroing). Any ideas what to do now?

EDIT: I just noted something interesting... inside the Avast windows (both in 'summary' and 'maintenance') the version number of both the program and the definitions are in red and appear to be outdated. However, if I go to 'add/remove programs --> Avast --> update', the 'current version' and the 'latest version' that are showed there match, and seem to be in fact up to date (right now: vps 110304-0). So it might after all be the case that the information displayed inside Avast is just wrong, and the updates actually /do/ take place.

Offline =SKY=

  • Super Poster
  • ***
  • Posts: 1621
Re: avast 6.0.1 free wont update
« Reply #2 on: March 04, 2011, 11:25:41 PM »
@galocza

Go to the settings and choose

- "Direct connection to the internet" and "No proxy".

Does it work now? ;)

Win11 Home [x64] 23H2 @ Windows Defender | FF ESR |
My oldest darling: W2k Pro SP4 & UR1 @ avast! Free Antivirus 8.0.1497 | Palemoon & K-Meleon [BOTH MODIFIED for W2k] |

laxnkio

  • Guest
Re: avast 6.0.1 free wont update
« Reply #3 on: March 04, 2011, 11:35:01 PM »
I'm having the same issues since I updated to Avast6;  Upon boot into my Vista 64 OS I get a red announcement from avast with an error code.  Then if I attempt to update the program states "The package is broken."  I also cannot open the real time shields tab on the main window.  Seems like something in 6 has broken the program for a lot of people.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: avast 6.0.1 free wont update
« Reply #4 on: March 04, 2011, 11:42:12 PM »
I'm having the same issues since I updated to Avast6;  Upon boot into my Vista 64 OS I get a red announcement from avast with an error code.  Then if I attempt to update the program states "The package is broken."  I also cannot open the real time shields tab on the main window.  Seems like something in 6 has broken the program for a lot of people.
Please, do not post twice the same.
Just double the help effort.
Please follow: http://forum.avast.com/index.php?topic=72663.msg607577#msg607577
The best things in life are free.

galocza

  • Guest
Re: avast 6.0.1 free wont update
« Reply #5 on: March 04, 2011, 11:48:03 PM »
@SKY: thanks for your input. yes, i forgot to write but i tried to play with the connection settings. the strange thing is that at add/remove programs manual updating works (with the default ie settings).

i think laxnkios post wasnt unnecessary: it seems to me that the common denominator is 64bit systems - win7, vista and xp, all 64bit platforms.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: avast 6.0.1 free wont update
« Reply #6 on: March 04, 2011, 11:50:03 PM »
i think laxnkios post wasnt unnecessary
Double posting is always unnecessary.
The best things in life are free.

YoKenny

  • Guest
Re: avast 6.0.1 free wont update
« Reply #7 on: March 05, 2011, 01:00:03 AM »
i think laxnkios post wasnt unnecessary: it seems to me that the common denominator is 64bit systems - win7, vista and xp, all 64bit platforms.
Its definitly not with all 64bit platforms but something in XP x64 that not many users have.   

laxnkio

  • Guest
Re: avast 6.0.1 free wont update
« Reply #8 on: March 05, 2011, 01:30:31 AM »
I figured since the 2 threads had two different subject lines, but were essentially the same problems, it was best to spread the word until the threads are combined.  Sharing information is usually the best way to solve the problems.
« Last Edit: March 05, 2011, 01:33:52 AM by laxnkio »

galocza

  • Guest
Re: avast 6.0.1 free wont update
« Reply #9 on: March 05, 2011, 07:31:21 AM »
i think laxnkios post wasnt unnecessary: it seems to me that the common denominator is 64bit systems - win7, vista and xp, all 64bit platforms.
Its definitly not with all 64bit platforms but something in XP x64 that not many users have.   

but norhuma has win7, with the same exact problem...

norhuma

  • Guest
Re: avast 6.0.1 free wont update
« Reply #10 on: March 05, 2011, 06:19:14 PM »

Can we get back on topic?


@galocza

Go to the settings and choose

- "Direct connection to the internet" and "No proxy".

Does it work now? ;)

Sorry, forgot to mention: I tried that as well, didn't work.

But I have a new theory, or let's rather say, a new observation:

So I can't update (pressing either 'update program' or 'update definitions' doesn't do anything, other than what seems to be a stuck progress bar) and the information in the 'maintenance' window of Avast is in /red/, i.e. it claims the info is outdated.

But I just noted, that after I updated the definitions /fully/ manual (i.e. with the downloaded .exe file), and after another restart, at least the maintenance window show the correct definition version number (right now: 110304-0). Note that the update buttons /still/ don't work, and the text is still in red, even though it was the latest definition version at the time, but at least the version number is correct.

Now here's the interesting part: the Avast program seems to compare the current version against something non-existant... under the definition version (still under 'maintenance') it says that the latest definitions (i.e. the one I should download) is "000000-0", similarly for the program version, it claims that my program version is outdated because there's a newer version, namely "0.0.0", and, finally, it says that the latest update attempt was on "01.01.1970".

Now, I'm not an Avast developer, but I know how to program, and that looks a lot to me as if my Avast is looking at something like a "null" update here, no? I mean, the fact that program and definition version are all 0's and that the date is "1970" implies that some actual data (like the latest definition update) is completely missing.

Anyone ever seen Avast behave like that, mentioning non-sensical version numbers?

galocza

  • Guest
Re: avast 6.0.1 free wont update
« Reply #11 on: March 05, 2011, 06:50:36 PM »
nothing like that, but slightly similar:
i updated avast by dowloading and installing the virus definitions update (110304-0) and then only _tried_ to update with add /remove programs. it downloaded 110304-1 and 110305-0 and here in add/remove programs it says its up to date, but in the program i read that the most recent update applied is 110304-0 and theres a newer: 110305-0.
it seems a bit erratic. ill reboot now and ill edit this post.
EDIT: after rebooting avast reports that the latest update (110305-0) is applied.
« Last Edit: March 05, 2011, 06:55:22 PM by galocza »

YoKenny

  • Guest
Re: avast 6.0.1 free wont update
« Reply #12 on: March 05, 2011, 06:53:04 PM »

Can we get back on topic?
Not many people have windows (xp x64) as that is a specialized XP version that was a pre-release to Windows 7
http://www.microsoft.com/windowsxp/64bit/default.mspx

norhuma

  • Guest
Re: avast 6.0.1 free wont update
« Reply #13 on: March 05, 2011, 06:56:56 PM »

Can we get back on topic?
Not many people have windows (xp x64) as that is a specialized XP version that was a pre-release to Windows 7
http://www.microsoft.com/windowsxp/64bit/default.mspx

didn't mean you, just wanted to ask if we could drop the "is it ever okay to double-post" discussion.

norhuma

  • Guest
Re: avast 6.0.1 free wont update
« Reply #14 on: March 05, 2011, 06:58:54 PM »
nothing like that, but slightly similar:
i updated avast by dowloading and installing the virus definitions update (110304-0) and then only _tried_ to update with add /remove programs. it downloaded 110304-1 and 110305-0 and here in add/remove programs it says its up to date, but in the program i read that the most recent update applied is 110304-0 and theres a newer: 110305-0.
it seems a bit erratic. ill reboot now and ill edit this post.
EDIT: after rebooting avast reports that the latest update (110305-0) is applied.

okay, so that part actually does sound similar to my situation (certain update (manual via file and from add/remove programs) work, but only show up after a reboot), minus the "0.0.0" version number.