Author Topic: Avast Free v6 & Privatefirewall clash  (Read 13801 times)

0 Members and 1 Guest are viewing this topic.

joburg

  • Guest
Avast Free v6 & Privatefirewall clash
« on: March 08, 2011, 03:40:19 PM »
Since I updated to Avast Free v6.0.1000 my Privatefirewall v7.0.23.4 crippled, the GUI very limited although as a firewall still functioning as it should be.
After trying various options I eventually reinstalled Avast v5.1.889 and that resolved the issue.
I'm running on W7 Pro 64-bit.

Any other Privatefirewall users here? If I'm the only one having this hiccup then I'll reinstall W7 and start from scratch.

Avast Support is of the opinion that Privatefirewall is an av prog and therefore the clash.

Offline nmb

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3054
Re: Avast Free v6 & Privatefirewall clash
« Reply #1 on: March 08, 2011, 04:59:13 PM »
You're not alone. I have reported this. But haven't found a way to fix it.

I will ask what ever I was asked in relation to this,

What other security program do you use?

Have you tried uninstalling both of them and installing them in a particular order for eg: 1st avast and then pf and 1st pf then avast?

What version of internet explorer do you use?
« Last Edit: March 08, 2011, 05:12:39 PM by nmb »

cadremis

  • Guest
Re: Avast Free v6 & Privatefirewall clash
« Reply #2 on: March 08, 2011, 06:00:19 PM »
I have been using PF for a year without problems in my computers, the problem with me started yesterday with the new Avast Beta 6.0.1021 and only in XP... PF starts to ask to allow avastsvc.exe and freezes my pc... I had to go back to the 6.0.1000 stable version.

Windows 7 works fine with PF... rm

joburg

  • Guest
Re: Avast Free v6 & Privatefirewall clash
« Reply #3 on: March 08, 2011, 06:28:20 PM »
nmb - I'm using IE8 with no extra toolbars. The long and the short of this issue is that Privatefirewall ran 100% up to the moment I upgraded to Avast v6.0.1000.

The trial & error testing procedure to attempt a fix veeeeeeery long. I even uninstalled all/any progs that I installed 10 days prior to the Avast upgrade. Even uninstalled/deleted upgraded standalone progs, MS .NET Framework 4, placed PF into Avast's Trusted processes, checked appcrash reports (WER), ran sfc scannow, scanned for malware, uninstalled WinPatrol, Sophos anti-rootkit, you name it, I can publish a book. Made snaps and notes of every step I took to keep track and ensure I can reset all to "normality".

I also tried all combinations of installation sequences. Many, many, many reboots as I install/uninstall to ensure the Registry took note.
Again - if Avast v6.0.1000 installed first and thereafter PF then PF is crippled. When I install PF first, running 100%, and then Avast v6.0.1000 PF immediately crippled. Eventually after installing Avast v5.1.889 and then PF (and vice versa) I discovered the reason.

I do not have another av prog because I've been an Avast user for many years, Avast only, I do not even bother to evaluate any other av prog no matter how slick the sales talk, promises, tests or reviews. Avast best, forget about the rest.

I see you're running PF, what is showing up as yr profile in the main menu, Home or Office? It defaults to Office Profile when it is crippled and you have no option to change it to Home.

cadremis - good to know regarding XP. I'll also install the latest version on my XP Pro (32-bit) and check. Running a dual boot but I very seldom use XP.

Offline nmb

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3054
Re: Avast Free v6 & Privatefirewall clash
« Reply #4 on: March 09, 2011, 12:45:36 PM »
Hi joburg,

I have the same exact problem as you on win 7 64 bit.

Yep, it displays only the office profile thing but if you click on home or public, it will switch to that internally but the on the GUI it still shows as office profile.

Don't know how it goes.. I mean the fixing thing.

privateofcourse

  • Guest
Re: Avast Free v6 & Privatefirewall clash
« Reply #5 on: March 09, 2011, 01:24:14 PM »
Not using on W7, but on XP I was using Privatefirewall for ages, without a problem, until I upgraded to Avast to v6.x. Then they just wouldn't work together properly. Squabbling over access to files, etc. and long waits. I couldn't be bothered to try an sort it out, so I uninstalled PF7 in the end, and installed only the Firewall component of Comodo Suite (nothing else, no defence +) and now everything works smoothly and quickly.

joburg

  • Guest
Re: Avast Free v6 & Privatefirewall clash
« Reply #6 on: March 09, 2011, 06:25:32 PM »
Thanks nmb, very interesting, I have not tested that direction but then on the other hand I'm still stuck because PF's other menus crippled by Avast. Those on the left side, Applications, Process monitor, Firewall log and Port tracking. I can not select any of them and therefore can not view, check or add any rules for example. Can you open any of these menus?

Privateofcourse - yes I suppose I could switch to another firewall, there are quite a few incl MS, but when you're contented with yr current setup it is rather difficult. PF running very smoothly with W7 & the older version of Avast.

I'm still positive that Avast Support (On Hold ticket) will come with a solution. I can not believe that Avast would upgrade their software and at the same time disqualify Privatefirewall and mark it as a "disallowed" program without any formal warning or some kind of notification?

mhf

  • Guest
Re: Avast Free v6 & Privatefirewall clash
« Reply #7 on: March 09, 2011, 07:45:39 PM »
Both are working here with no problems at all :

avast! 6.0.1000
PF 7.0.22.8
win xp

Not much help to anyone I'm afraid !

sded

  • Guest
Re: Avast Free v6 & Privatefirewall clash
« Reply #8 on: March 10, 2011, 01:37:00 AM »
Someone at Wilders received a response from PF support and successfully solved the problem.  Worth a try.  http://www.wilderssecurity.com/showpost.php?p=1840162&postcount=5 .

Offline nmb

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3054
Re: Avast Free v6 & Privatefirewall clash
« Reply #9 on: March 10, 2011, 01:22:41 PM »
Someone at Wilders received a response from PF support and successfully solved the problem.  Worth a try.  http://www.wilderssecurity.com/showpost.php?p=1840162&postcount=5 .

Thank you :)
That fixed it. Will have to check one last time. After the next time I login to my computer. But I wonder what is making it to not display properly.

joburg

  • Guest
Re: Avast Free v6 & Privatefirewall clash
« Reply #10 on: March 10, 2011, 09:03:08 PM »
nmb - wish I could have been that lucky, still no-go here.

sded - I actually went one step further (again 2 hrs ago), I uninstalled both progs and also used aswClear (both versions, via Safe Mode) to ensure Avast clean uninstalled, rebooted, etc, etc. Then installed Avast v6, disabled it, installed PF and it is running fine.
Reboot and PF still running and then I enabled Avast shields. That's it, PF crippled. No matter what I attempt Avast took over.
Repeat all again but using Avast v5 and all's well and normal.

Received a 2nd confirmation email from Avast Support today stating clearly that PF comes with an antimalware function and will therefore not function with Avast.

Luckily for me Avast only sees PF as an antimalware prog from v6 onwards, I'll never need to upgrade Avast in future  8)

sded

  • Guest
Re: Avast Free v6 & Privatefirewall clash
« Reply #11 on: March 10, 2011, 09:16:37 PM »
Avast! support seems to be wrong in many cases, including the v6 I run with PF under Vista.  It probably means help is not imminent, though.  In general, I have had better luck installing a firewall first, excluding any AV/AM from coverage, and then installing the AV/AM.  But I didn't need to try that with PF-Avast! 6 was already running- and am just not familiar enough with it to help.  What does PF support say to you?  They are getting lots of the same question on Avast! 6 and if you tell them you had a different result they might give you additional ideas.  They should certainly be able to repeat the problem with Free Avast! 6.  If it worked with all the shields diabled, btw, which could you restore before things stopped working?

Offline nmb

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3054
Re: Avast Free v6 & Privatefirewall clash
« Reply #12 on: March 11, 2011, 04:32:05 AM »
After a reboot, its still working fine.

Firebytes

  • Guest
Re: Avast Free v6 & Privatefirewall clash
« Reply #13 on: March 11, 2011, 05:26:44 PM »
I use Privatefirewall on a Windows 7 64-bit system and have the problem with the GUI of Privatefirewall locking up as well. I tried the workaround (uninstall PF reboot, disable Avast, reinstall PF, reboot) and it did work but as soon as Avast definitions updated PF's GUI was locked up again. I guess I will have to go back to Avast 5 as it did not cause this problem with PF. The only problem I had then was with PF always asking to allow the Temp file from Avast to access the web at boot up to update definitions.

The only other option I can see would be to switch firewalls and that doesn't seem like much of a solution as it seems I am reading around the web about many firewalls having problems getting along with Avast right now.

Offline nmb

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3054
Re: Avast Free v6 & Privatefirewall clash
« Reply #14 on: March 11, 2011, 05:31:06 PM »
@Firebytes

The update didn't change anything for me. The GUI is still working.