Author Topic: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)  (Read 9827 times)

0 Members and 1 Guest are viewing this topic.

Harry_P

  • Guest
Windows 7 x64.
Agnitum Outpost Firewall Pro 7.1 (3415.520.1247).
When System starts Outpost can't launch its process op_mon.exe (Outpost User Interface).
The only solution I found is to disable Avast Behavior Shield, run Outpost from the Windows Start Menu, and then enable Avast Behavior Shield.
Avast 5 was free from such a bug.

Offline Ashish Singh

  • Poster
  • *
  • Posts: 437
  • Proud to be an Indian
    • Quick Heal
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #1 on: March 20, 2011, 02:50:25 PM »
Just a suggestion from my side....
     Go to expert setting of behavior shield uncheck the option "MONITOR THE SYSTEM FOR UN AUTHORISED MODIFICATION" And add op_mon.exe and acs.exe in trusted processes.
Hope this may help you  :D
Also add outpost installation directory to file shield exclusion list.  :D :D
      Actually this worked for me..
Windows 7 Ultimate(32 bit), avast! free (always latest released or beta), Intel Core2Duo, 2GB RAM, Outpost Firewall Pro 7.5,IE 9,TuneUp Utilities 2011,Diskeeper 2011

http://www.incredibleindia.org 

Caution! Online world is full of man made Aliens

Harry_P

  • Guest
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #2 on: March 20, 2011, 03:35:43 PM »
ashishsingh1508,

A lot of thanks for your interesting suggestion.

Much to my regret it did not turn out to be helpful. I rebooted computer after op_mon.exe has been  added to trusted files but the Outpost icon did not appear in the tray. And when I executed sophisticated manipulations as mentioned above the icon showed up (see the picture).

Silk0

  • Guest
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #3 on: March 20, 2011, 03:39:26 PM »
In the second screenshot, I see you got MSE (first icon) and avast!

Although MSE apears to be disabled is never good to have 2 AV's installed. Can create conflicts between them.

Offline Ashish Singh

  • Poster
  • *
  • Posts: 437
  • Proud to be an Indian
    • Quick Heal
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #4 on: March 20, 2011, 03:48:24 PM »
Well in my case I first installed Outpost restarted then installed avast then again restarted. And is working for me with suggestions I provided you....
      These steps were told me by DavidR an avast Technical. And I am following this sice then. Do this after uninstalling them both and reply what happens... 
::) ::) Do clean install for both
« Last Edit: March 20, 2011, 03:50:23 PM by ashishsingh1508 »
Windows 7 Ultimate(32 bit), avast! free (always latest released or beta), Intel Core2Duo, 2GB RAM, Outpost Firewall Pro 7.5,IE 9,TuneUp Utilities 2011,Diskeeper 2011

http://www.incredibleindia.org 

Caution! Online world is full of man made Aliens

Harry_P

  • Guest
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #5 on: March 20, 2011, 03:53:39 PM »
Silk0,

Thank you for timely remark.

However, as you can see, MSE real-time shield is off (red icon) that is to say MSE is used as a scanner on demand only. Besides, MSE was in the same state when Avast 5 was installed and there was no  problem with Outpost.

Harry_P

  • Guest
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #6 on: March 20, 2011, 03:55:48 PM »
Well in my case I first installed Outpost restarted then installed avast then again restarted. And is working for me with suggestions I provided you....
      These steps were told me by DavidR an avast Technical. And I am following this sice then. Do this after uninstalling them both and reply what happens... 
::) ::) Do clean install for both

Thank you once more. I'll try to follow your advice.

doktornotor

  • Guest
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #7 on: March 20, 2011, 03:57:29 PM »
However, as you can see, MSE real-time shield is off (red icon) that is to say MSE is used as a scanner on demand only. Besides, MSE was in the same state when Avast 5 was installed and there was no  problem with Outpost.

Merely disabling MSE is NOT enough. The drivers are still loaded and will cause conflicts. You simply need to completely remove MSE, or do not install avast!

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89258
  • No support PMs thanks
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #8 on: March 20, 2011, 04:04:09 PM »
@ Harry_P
Sorry, but I recommend installing avast first, so that when Outpost is installed it detects avast and asks if you have it installed (answer yes). That way it will disable the Outpost anti-spyware and web-control modules so as not to conflict with avast's anti-spyware functionality or its web shield.

I have not excluded the Outpost program folder, I just acknowledged I did on the prompt. The only file that I exclude in the avast File System Shield (Expert Settings, Exclusions) belonging to Outpost was the C:\Program Files\Agnitum\Outpost Firewall Pro\wl_hook.dll file.

Recently after clean reinstalls of avast and the use of the 6.0.1035, I neglected to re-enter this exclusion and I have had no problem in that regard either (just re-entered it) and never had a problem with op_mon.exe.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.5.6116 (build 24.5.9153.762) UI 1.0.808/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Harry_P

  • Guest
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #9 on: March 20, 2011, 04:08:50 PM »
Merely disabling MSE is NOT enough. The drivers are still loaded and will cause conflicts. You simply need to completely remove MSE, or do not install avast!
Thank you!

However, I never observed any conflict between MSE and Avast!

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89258
  • No support PMs thanks
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #10 on: March 20, 2011, 04:17:26 PM »
I suspect that you are seeing conflict. Low level drivers will at some point come onto conflict at they are trying to do the same thing, hook a file so that it can be scanned (even if the supporting scan is disabled). This can lock out the system as all the dogs fight over the one bone.

The fact that it (in your opinion) hasn't happened would be more luck than design.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.5.6116 (build 24.5.9153.762) UI 1.0.808/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Harry_P

  • Guest
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #11 on: March 20, 2011, 04:19:36 PM »
@ Harry_P
Sorry, but I recommend installing avast first, so that when Outpost is installed it detects avast and asks if you have it installed (answer yes). That way it will disable the Outpost anti-spyware and web-control modules so as not to conflict with avast's anti-spyware functionality or its web shield.

I have not excluded the Outpost program folder, I just acknowledged I did on the prompt. The only file that I exclude in the avast File System Shield (Expert Settings, Exclusions) belonging to Outpost was the C:\Program Files\Agnitum\Outpost Firewall Pro\wl_hook.dll file.

Recently after clean reinstalls of avast and the use of the 6.0.1035, I neglected to re-enter this exclusion and I have had no problem in that regard either (just re-entered it) and never had a problem with op_mon.exe.
Thank you!

I did as you described:  Outpost detected avast! and asked if I have it installed and I answered "yes". But I excluded in the avast File System Shield (Expert Settings, Exclusions) the whole folder C:\Program Files\Agnitum\Outpost Firewall Pro.

Well, I'll try various remedies to solve problem but I'll do it tomorrow.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89258
  • No support PMs thanks
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #12 on: March 20, 2011, 04:24:36 PM »
No problem, glad I could help.

Welcome to the forums.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.5.6116 (build 24.5.9153.762) UI 1.0.808/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

dj_g

  • Guest
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #13 on: March 20, 2011, 04:41:01 PM »
What version of avast 6.0.1 are you running? That was a problem in earlier versions but not with the last two. I'm running OFP 7.5 public beta and previously 3415 like you and have no problems with avast 1027 and 1035. Also when you install Outpost Firewall Pro do not install the malware and web components. Win 7 Home Premium 64-bit.

Offline Ashish Singh

  • Poster
  • *
  • Posts: 437
  • Proud to be an Indian
    • Quick Heal
Re: Avast Free 6.0.1 blocks op_mon.exe (file of Outpost User Interface)
« Reply #14 on: March 20, 2011, 07:02:51 PM »
Well if you listen to me. I would suggest you to 1st install OP Firewall and then avast. because this way you will have web control of Outpost Firewall with you. dont install web shield and network shield(just my personal suggestion)
As I believe that Outpost's Web control do much more than avast's Web shield.(see screen shots)
     
Its just my personal observation and suggestion. You can decide on your own...
Windows 7 Ultimate(32 bit), avast! free (always latest released or beta), Intel Core2Duo, 2GB RAM, Outpost Firewall Pro 7.5,IE 9,TuneUp Utilities 2011,Diskeeper 2011

http://www.incredibleindia.org 

Caution! Online world is full of man made Aliens