Author Topic: Installation error: usiGetSkin failed!  (Read 19849 times)

0 Members and 1 Guest are viewing this topic.

Offline Volans

  • Newbie
  • *
  • Posts: 14
Installation error: usiGetSkin failed!
« on: September 27, 2004, 10:56:34 AM »
Hi,

I have a problem with the installation of Avast4, I can't open the main window of Avast4!
When I try to run the main window of Avast4, appear a little box and the program perform a memory scan. After, a message tell that the program now auto-restart, but appear only a box with:
UNKNOWN ERROR
The program can't load the skin. The function "usiGetSkin" is failed.

I have:
Avast! version 4.1 Home Edition (4.1.418 Jun2004), italian version
AMD Athlon 500 MHz with 256 MB of RAM
Windos 98 Second Edition

Previously I had NortonSystemWorks 2002 installed, I have removed NortonAntiVirus and leave the other programs of the SystemWorks suite.

I have read the FAQ of the program and ALL the topics on this forum about this error, and I have try all these solutions:

1 - registering the dll with the command "C:\WINDOWS\SYSTEM\REGSVR32.EXE ACTSKIN4.OCX". The box with "DllRegisterServer in ACTSKIN4.OCX succeeded" appear regularly.

2 - Check if the registry key "HKEY_CLASSES_ROOT\CLSID\{0944D16C-D0F4-4389-982A-A085595A9EB3}" exist and have a subkeys.

3 -  Go to the SKIN folder of the program and double-click on a skin icon. Also with new skin downloaded from the Avast site.

4 - Go to "Add/remove program" and click on avast, then perform a Repair or an Upgrade.

5 - Disinstall and reinstall the program

but none of these has worked...  the error still remain!! :-[

Anyone have another solution that i can try???

Many thanks to all that have read until here!  :)  ;)
« Last Edit: September 28, 2004, 12:08:01 PM by Volans »

Offline Volans

  • Newbie
  • *
  • Posts: 14
Re:Installation error: usiGetSkin failed!
« Reply #1 on: September 28, 2004, 02:39:26 PM »
Really nobody can suggest me other possible solution to try ?
 ??? ??? ???

Thanks
« Last Edit: September 28, 2004, 02:39:46 PM by Volans »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re:Installation error: usiGetSkin failed!
« Reply #2 on: September 28, 2004, 08:44:13 PM »
Well, you've tried the most common solutions for the usiGetSkin function failure.
I think the problem is related to NortonSystemWorks 2002 or, better, NortonAntiVirus.
Remove it is one of the most difficult things in the earth  :(
Try to download 'Control' in my signature, run it and browse for 'Norton uninstallation'.

Although you have already tried, please, try again to repair avast ("Add/remove program").

I've read your post since from the begginning but I could not realise how to help you... Sorry  :'(
The best things in life are free.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re:Installation error: usiGetSkin failed!
« Reply #3 on: September 28, 2004, 08:48:40 PM »
I know it's not exactly the same, but you can see that other avast problems could be solved by completelly Norton uninstall: http://forum.avast.com/index.php?board=2;action=display;threadid=7565  ;)
The best things in life are free.

Offline Volans

  • Newbie
  • *
  • Posts: 14
Re:Installation error: usiGetSkin failed!
« Reply #4 on: September 29, 2004, 01:32:33 AM »
Thanks you for the replies and the suggestions!!!  :D  :D

I don't want to uninstall completely the Norton System Works, for this reason I have uninstalled only the Antivirus component.

I have checked in the Windows Registry for keys such as NAV, Symantec and similar, and I have found over 100 match!!
Now I'm not sure that the System Works still work if I delete them.
What the "Norton Antivirus 2004 uninstall" of your Avast External Control exactly do? (note that I have the 2002 System Works)

Even if often Norton create conflictual situation, I think that this is not a Norton related problem, because is only a Skin loading problem and the Avast scan (mail, memory when I try to load the program and single file right-clicking on it) work properly.

But if You think that this is the ultimate solution, I will try it !!!  ;)  ;)

P.S. at this time I can't try the Repair solution, because I have uninstalled Avast, but previously I have tried it twice.

Online bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 44079
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re:Installation error: usiGetSkin failed!
« Reply #5 on: September 29, 2004, 02:00:23 AM »
Volans
The easyest solution to this problem is to FULLY uninstall Norton Systemworks. You can get the uninstall directly from their site or click on the link in my signature and find it there.
Once Norton has been fully unistalled, reboot the system and re-insall Avast.
Once Avast is running properly, do a selective install of Norton System Works making sure not to install NAV.
Good luck. :)
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re:Installation error: usiGetSkin failed!
« Reply #6 on: September 29, 2004, 02:53:24 AM »
Volans
The easyest solution to this problem is to FULLY uninstall Norton Systemworks. You can get the uninstall directly from their site or click on the link in my signature and find it there.
Once Norton has been fully unistalled, reboot the system and re-insall Avast.
Once Avast is running properly, do a selective install of Norton System Works making sure not to install NAV.
Good luck. :)

I have the same (all except NAV) and I did exactly what Bob is saying... I cannot add a word to this. I'm almost sure it will work like a charm.

If you do not want to do this, you can try the standalone uninstall tool of Symantec and try to remove NAV. It won't be easy. If you manuall delete the keys you can mess your NSW installation, at least, part of it...

What MS Office do you have, I mean, the version?
If you install the last MDAC drivers from Microsoft, will it help? I think MDAC is on version 2.8   ::)
The best things in life are free.

Offline Volans

  • Newbie
  • *
  • Posts: 14
Re:Installation error: usiGetSkin failed!
« Reply #7 on: September 29, 2004, 05:30:15 PM »
The symantec site with the instructions for the manual uninstall of NSW2002 for Win98SE say:
Code: [Select]
Part 2 - Remove NAV 2003
If you previously installed Norton AntiVirus 2003 (this program is included as part of the Norton SystemWorks suite), run the Rnav2003.exe removal utility to ensure that all components of previous versions of NAV have been uninstalled... ... NAV 2003 cannot be uninstalled manually.

Then I have downloaded and run the Rnav2003.exe removal utility, reboot, and install Avast again.... always the same problem! :(

Quote
What MS Office do you have, I mean, the version?
I have office 2000 installed.

Quote
If you install the last MDAC drivers from Microsoft, will it help? I think MDAC is on version 2.8
I have also installed the 2.8 version of the MDAC drivers, but this not help me! :(

Finally I have try this:
1 - uninstal Avast and NSW2002
2 - reboot
3 - manually delete ALL the registry keys, files and folder such as Norton, Symantec, NAV and Avast
4 - Reboot
5 - Install for the LAST times Avast4
6 - Start -> Run "C:\WINDOWS\SYSTEM\REGSVR32.EXE ACTSKIN4.OCX"
7 - Reboot
8 - Try to open the main window of Avast

RESULT:
Quote

UNKNOWN ERROR
The program can't load the skin. The function "usiGetSkin" is failed.


Sorry... but Avast won't work on my PC! :-[

One of the reasons because I've choised Avast, is that I need an SMTP and POP3 antivirus checker, since I use Mozilla as mail client.
Now I'm forced to try AVG.
The new version of free AVG (expexted for november, now there is the beta version) has this function too.

Thank you for the attention and the patience... but the evidence is that this program is not for my PC, even if we have not understood the cause.

Best regards,
Volans

P.S. I will return to check new messages in the next days, therefore if you have other suggestions... post it and I will try them! :D :D

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re:Installation error: usiGetSkin failed!
« Reply #8 on: September 29, 2004, 05:48:45 PM »
Did you just try to download another skin, double click the file and see if you get avast! working?
The best things in life are free.

Offline Volans

  • Newbie
  • *
  • Posts: 14
Re:Installation error: usiGetSkin failed!
« Reply #9 on: September 29, 2004, 05:56:02 PM »
I have tried also this, with two different skins, downloaded into the skin folder of avast, double-click... and...

UNKNOWN ERROR
The program can't load the skin. The function "usiGetSkin" is failed.
« Last Edit: September 29, 2004, 05:56:30 PM by Volans »

Online bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 44079
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re:Installation error: usiGetSkin failed!
« Reply #10 on: September 29, 2004, 07:42:43 PM »
Volans
What is step 6 in your outline of the procedure you followed?
What was so hard about following the outline I had given you?
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline Volans

  • Newbie
  • *
  • Posts: 14
Re:Installation error: usiGetSkin failed!
« Reply #11 on: September 29, 2004, 07:55:57 PM »
It is the step 1 in my first message:
Quote
1 - registering the dll with the command "C:\WINDOWS\SYSTEM\REGSVR32.EXE ACTSKIN4.OCX". The box with "DllRegisterServer in ACTSKIN4.OCX succeeded" appear regularly.
this procedure is explained in the FAQs.

Nothing hard, but I had reason... it isn't a Norton problem.  ;)

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re:Installation error: usiGetSkin failed!
« Reply #12 on: September 29, 2004, 08:59:31 PM »
This is the second user that have to go to AVG because of the same error  :'(

http://forum.avast.com/index.php?board=2;action=display;threadid=5991

What's up?
The best things in life are free.

Online bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 44079
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re:Installation error: usiGetSkin failed!
« Reply #13 on: September 29, 2004, 11:42:19 PM »
Tecnical,
This is the second person who couldn't follow directions and therefore didn't solve their problem. They both just happened to have the same problem. IMHO
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline Volans

  • Newbie
  • *
  • Posts: 14
Re:Installation error: usiGetSkin failed!
« Reply #14 on: September 29, 2004, 11:54:43 PM »
This is your suggestion:
Volans
The easyest solution to this problem is to FULLY uninstall Norton Systemworks. You can get the uninstall directly from their site or click on the link in my signature and find it there.
Once Norton has been fully unistalled, reboot the system and re-insall Avast.
Once Avast is running properly, do a selective install of Norton System Works making sure not to install NAV.
Good luck. :)

If you read my steps, I had done exactly what you have suggested (NSW2002 = Norton System Works 2002)... but this do not have solved the problem!

Quote
This is the second person who couldn't follow directions and therefore didn't solve their problem.
I have follow ALL yours suggestions, why you say this??
« Last Edit: September 29, 2004, 11:56:20 PM by Volans »