Author Topic: AvastSvc.exe, kinda of a piggy. High Mem Usage at times  (Read 10811 times)

0 Members and 1 Guest are viewing this topic.

luckyvic

  • Guest
AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« on: September 16, 2011, 01:55:36 AM »
Just sitting there, nothing going on. Sometimes it can go higher 60-70MB.
I installed over old version.

Online CraigB

  • Avast √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 11248
  • No support PM's thanks
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #1 on: September 16, 2011, 07:01:03 AM »
Best thing to do is a clean install, download the uninstall tool and a fresh copy of avast and save http://files.avast.com/files/eng/aswclear.exe http://files.avast.com/iavs5x/setup_av_free.exe, uninstall avast via remove programs then reboot into safe mode and run the removal tool then reboot back into normal mode and run ccleaner, now install your new copy of avast.

ady4um

  • Guest
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #2 on: September 16, 2011, 10:05:00 AM »
Add that exe to your firewall rules. In Avast 6.0.1289, some traffic is redirected through that exe for scanning.

You could also try:

web shield -> EXPERT settings -> "well known browsers only".

Then reboot, test and report back.

Online CraigB

  • Avast √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 11248
  • No support PM's thanks
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #3 on: September 16, 2011, 11:15:44 AM »
Actually if you haven't already done so all instances of avast need to be set to allow all in your firewall, the avast service, avast ui and the avast setup, if you do have these set to allow already! then continue with a clean install.

luckyvic

  • Guest
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #4 on: September 16, 2011, 06:01:00 PM »
Did all the suggestions, nothing worked, and finally did a clean install. A little better for now. I will monitor throughout the day and get back.
Thank you all for the help. Really appreciate it.

luckyvic

  • Guest
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #5 on: September 16, 2011, 08:33:37 PM »
Did clean install this morning, rebooted, checked after couple (/dog walk/after lunch) hours, here's latest.

luckyvic

  • Guest
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #6 on: September 17, 2011, 02:52:51 AM »
Not looking good here, just keeps going up.

ady4um

  • Guest
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #7 on: September 17, 2011, 01:10:32 PM »
Please manually add that exe to firewall rules.

Try also:

Avast main GUI -> web shield -> EXPERT settings -> "...well known browsers only".

Reboot and test.

luckyvic

  • Guest
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #8 on: September 17, 2011, 06:29:18 PM »
That didn't work.
Why was it that the previous version did not do this? I've been using Avast! for a long time, but this frustrating.
Also when I uninstalled Avast! via Add/Remove programs and then rebooted to Safe Mode, I got a BSOD, "Page FaultIn Nonpaged Area 0x00000050. I tried getting mindump with BlueScreenView and nothing shows.

Thank you your help, I am upset-not your fault.

YoKenny

  • Guest
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #9 on: September 17, 2011, 08:18:43 PM »
Un-install ZoneAlarm.

I would never use anything from Iobit either.

luckyvic

  • Guest
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #10 on: September 17, 2011, 08:35:45 PM »
Un-install ZoneAlarm.

I would never use anything from Iobit either.

It didn't have this problem with previous Avast! versions with ZoneAlarm, so why uninstall it? It's not the problem.
I like some of the IObit programs. Sorry you don't.
I appreciate your help, but it not addressing the problem which I believe is Avast!. I could get rid of ZA and then what? Maybe more headaches? What about the BSOD after clean install of Avast!? Wasn't ZA fault?
Love Avast!, but something has happened here since latest upgrade version.

luckyvic

  • Guest
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #11 on: September 17, 2011, 10:31:14 PM »
I disabled ZoneAlarm, enabled Windows Firewall, rebooted and still the same problem with high Mem Usage.

mitchell64

  • Guest
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #12 on: September 19, 2011, 05:54:43 AM »
I had a similar problem with AvastSvc.exe, not high usage of memory or CPU but it was only happening with Google Chrome.

I use Comodo Firewall which has an animated tray icon, as you would expect you see traffic as a page loaded then it would stop for about a minute then start again for about 3-4 minutes before stopping properly.
Comodo Firewall control panel indicated the traffic as being mostly AvastSvc.exe. I tried all sorts of configurations of Avast resident shields, tried disabling shields independently (and yes firewall rules are set to allow AvastSvc. UI & updater.)

As i said it was only happening with google chrome. My thoughts were because chrome run so many processes but it actually turned out to be the AdBlock plug in. Once i disabled AdBlock plug in the problem ceased, not that it was a big issue for me just more annoying than any thing as in my case i did not suffer any performance issues.  
« Last Edit: September 19, 2011, 06:27:54 AM by mitchell64 »

Offline Shiw Liang

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1432
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #13 on: September 19, 2011, 04:58:49 PM »
Wow 30mb + memory usage by avast is quite unusual :o

luckyvic

  • Guest
Re: AvastSvc.exe, kinda of a piggy. High Mem Usage at times
« Reply #14 on: September 19, 2011, 06:39:19 PM »
Wow 30mb + memory usage by avast is quite unusual :o

65MB+ is alot too!! (check above attachment), I'm sure at point in the near future it will all get worked. I trust Avast! and will keep using it.